Python 运用pip install Flask-MySQLdb报错

如图所示,Python 运用pip install Flask-MySQLdb报错,本人已安装了Microsoft Visual C++ Compiler Package for Python 2.7图片说明图片说明

0

1个回答

vc依赖的vcvarsall.bat找不到,要看看你的VC环境是不是安装好了

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
flask-mysqldb安装出现错误
解决方案:     1、首先安装pip install flask-sqlalchemy     2、接着安装pip install pymysql     3、找到sqlalchemy包安装路径,例:          ~/.virtualenvs/py3_flask/lib/python3.5/site-packages/sqlalchemy         然后在flask-sqlalc...
ubuntu下安装flask-mysqldb问题记录
python中使用mysql的包有pymysql和mysqldb,同样地,flask也为其提供了扩展:flask-mysql(貌似基于pymysql),flask-mysqldb,但flask-mysql只支持python2,而flask-mysqldb同时兼容python2和python3。 在虚拟环境中安装flask-mysqldb: pip install flask-mysqldb 出现如...
Mac下安装MySQLdb报错解决
还是老样子,本来想自己写的,但是发现这个哥们写的相当详细,直接搬过来即可   安装环境:OS X操作系统,Python 2.7.3。   MySQLdb其实包含在MySQL-python包中,因此无论下载还是在pip中search,都应该是搜寻MySQL-python。   以下将说明MySQLdb两种常见的安装方式,下载安装或者pip安装MySQL-python。   下载MySQLdb
mac中MySQLdb的安装及遇到的问题
 MySQLdb 又叫 MySQL-python,是一款较为底层的,python连接mysql用的模块。MySQLdb主要聚焦于如何和数据库进行连接和进行基本的操作,操作的体现形式主要是进行SQL语句的执行。     MySQLdb是 Python 连接 MySQL 最流行的一个驱动,很多框架都也是基于此库进行开发,遗憾的是它只支持 Python2.x,而且安装的时候有很多前置条件,因为它是基于...
flask 安装报错
用 py -3 -m pip install flask 能够正常安装 但 py -3 后使用 import flask 出现如下问题 卸载了flask:  py -3 -m pip uninstall flask 卸载了makeupsafe: py -3 -m pip uninstall makeupsafe 安装了makeupsafe: py -3 -m pip install
本地安装flask过程中遇到的问题解决
1. 首先感谢xuelangZF贡献的源码,源码地址为:https://github.com/xuelangZF/NaHan,项目功能的说明见地址:http://selfboot.cn/2016/07/28/forum_design_framework/ 2. 下面进入正题, 安装的系统为:windows7、64位 Python版本:2.7 mysql版本:5.7 3. 安装的过程中会提
解决Ubuntu 18.04 安装flask-mysqldb失败的问题
解决Ubuntu 18.04 安装flask-mysqldb失败的问题 环境 Ubuntu18.04 + python3 + flask0.10.1 +mysql8.0 安装flask-mysqldb命令如下: pip install flask-mysqldb 报错一: 解决方法: sudo apt-get install libmysqlclient-dev 再次执行 pip ...
python pip install 总是出错的解决方法
可以通过国内镜像进行下载  直接在pip install 加入镜像地址  例如:pip3 install -i https://pypi.tuna.tsinghua.edu.cn/simple django  用PyCharm 安装包的方法  : 菜单: 文件--->设置--->项目--->Project Interpreter--->右上角的加号+     搜
python中使用pip功能报错大全
背景:如果你只使用官方的python软件,没有安装辅助软件如:pycharm这个软件; 使用pip安装报错怎么办? 注意:pip这个功能,是在cmd环境下来敲的。(windows) 首先: python 2 的版本使用的是pip python 3 的版本使用的是pip3 语法:pip install 模块名 错误一: 比如:我安装chardet这个模块,安装失败,报错,代码如...
解决: pip install MySQl-Python 出现:下列问题
问题 1:error: Microsoft Visual C++ 9.0 is required在Windows下用pip安装MySQl-Python报如下错误,看错误提示就知道去http://aka.ms/vcpython27找解决方法了error: Microsoft Visual C++ 9.0 is required (Unable to find vcvarsall.bat). Get ...
WIN下解决MySQL-Python模块pip install安装错误
错误描述:环境win10 64位 python 3.6.3使用 pip install mysql-python 报错:error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-...
pip install mysql_python报错终极解决办法。
首先请注意,mysql_python只支持Python2,所以假如你是python3,就直接用python-connector去吧。下面这一条命令就可以了 pip install mysql-connector 好了正题开始,假如你用pip install mysql_python报错了,就别执着了,换以下方法: 1、安装wheel pip install wheel 2、网上查找并...
windows下面安装Python、pip、Requests、MysqlDB终极教程
参考原文:http://www.cnblogs.com/yuanzm/p/4089856.html最近对网络爬虫比较感兴趣,年前的项目也算告一段落了,接下来就抽时间给自己充充电,做一个Life-Timer Learner。哈哈 总的来说,个人很喜欢Python的语言风格,但是这门语言对于windows并不算很友好,因为如果是初学者在windows环境下安装,简直是折磨人,会遇到各种蛋疼的情况。本文希
python pip安装MySQLdb报错解决方法
一 进入网站 https://www.jb51.net/softs/73369.html#download 下载MySQL-python相关软件。 二 下载后解压,有两个安装包 MySQL-python-1.2.3.win32-py2.7.exe MySQL-python-1.2.3.win-amd64-py2.7.exe 根据实际情况进行安装...
一招解决python pip install 安装库失败
PIP是python强大的安装利器,但是我们经常遇到安装库失败的问题,以下本人觉得最有效的解决方法: 1.打开 https://www.lfd.uci.edu/~gohlke/pythonlibs网站, 2.搜索(CTRL+F)需要安装的库的名称,比如pandas  3.找到对应自己系统的版本并下载,cp后面的数字时python的版本,如cp36代表python3.6版本,WIN后面的数...
树莓派pip安装库错误
报错:ValueError: bad marshal data (unknown type code) python 出现这玩意,一般来说是你的前后的编译器有不相同造成的。 前后安装了2个版本的Py一个是2.7 一个是3.5 的所以在2.7的时候跑了,造成了安装3.5之后就会出问题。 解决方案就是将对应的包目录下的.pyc文件删除,让python编译器重新生成编译就OK了。 执行 find...
下载 pip 工具
下载 python ,pip 安装工具,获取pip, python <3.3, python pip, pip install something
pip安装时出现问题:TypeError
pip安装时出现问题:TypeError
pip install pyltp报错解决办法
报错一:error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C++ Build Tools”: http://landinghub.visualstudio.com/visual-cpp-build-tools笔者安装Microsoft Visual C++ 14.0后,依然不能顺利安装pyltp,...
安装、升级pip,但是python -m pip install --upgrade pip报错的解决办法。
一般我们在安装或者调用pip库的时候,会告诉你pip版本较低,需要你升级,比如我的本机是如下。 一、 我是直接cd到我pip目录文件下查看版本: E:\Program Files (x86)\python\Scripts&gt;pip show pip Name: pip Version: 10.0.1 Summary: The PyPA recommend...
python mac安装MySQLdb 模块 遇到的坑
1.首先需要在mac安装好mysql 2.遇到错误     error: command 'cc' failed with exit status 1 _mysql.c:44:10: fatal error: 'my_config.h' file not found 解决方案 brew install mysql-connector-c   重装一遍这个 3.遇到错误  string i...
python pip 安装第三方库 ssl报错解决方案
命令行输入命令 pip --trusted-host pypi.python.org install 安装包的名称
pip安装python包报错的一些解决办法【转】
用国内镜像通过pip安装python的一些包 学习flask,安装virtualenv环境,这些带都ok,但是一安装包总是出错无法安装, 比如这样超时的问题: (env)user@orz:~/flask_study/venv-test/test$ easy_install Flask-SQLAlchemy Searching for Flask-SQLAlchemy Re
python3 使用pip 安装scrapy报错
直接使用pip3 install scrapy会报很多错误,所以试试以下步骤。 (1) https://www.lfd.uci.edu/~gohlke/pythonlibs/ 在这个python第三方库里下载三个包:分别是lxml,twisted,scrapy。【按照自己的电脑和Python版本下载相应的包】 (2) cd 到放这三个包的文件夹下,依次pip3 install 上述三...
Python pip报错处理
pip install [packagename]时报错: unable to find vcvarsall.bat 这是由于python3.4默认的msvc版本为10.0,而我的机器的版本为15.0,所以报错。在/Lib/distutils/msvc9compiler.py目录下将MSVCCompiler函数中的 vc_env =query_vcvarsall(VERSION, pla
Python安装selenium及报错原因
想用Python + selenium 调用firefox浏览器写个登陆网页的脚本,发现selenium需要手动安装,决定写一下selenium的安装教程。 环境: Windows 7 Python.3.6.1 教程: 1.使用cmd打开Windows的终端,在终端里切换目录到Python的安装目录里: PS: 如果要切换到D盘,直接在终端上打 d:就可以切换到D盘了。 如果要切换...
python中使用pip install 命令时报ssl缺失的错误
python中使用pip install 命令时报ssl缺失的错误
python-thrift安装报错问题解决
pip及setup.py安装均报错 删除Python/Lib下的fcntl.py及fcntl.pyc 从以下链接重新下载fcntl.py并放入Lib文件夹,重新安装thrift,ok https://pypi.python.org/pypi/micropython-fcntl ...
【Python】使用pip install时出现UnicodeDecodeError错误解决方法
分享到... 微信微博复制网址邮件QQ好友QQ空间人人网开心网印象笔记领英飞信豆瓣TwitterFacebook一键分享查看更多(96) JiaThis 首页 科技 娱乐 体育 干货 女人 设计 时尚 旅游 美食 语录 健康 最新
无法使用pip命令安装python第三方库的原因
再dos中无法使用pip,命令主要是没有发现这个命令。我们先找到这个命令的位置,一般是在python里面的Scripts文件夹里面。我们可以把dos切换到对应的文件夹,再使用pip命令就可以了。 如果你在使用pip命令安装Python第三方库时也出现下面这样。 这是我在安装requests库时 我们发现pip命令无法使用,这时我们看一下python文件夹下的Scripts文件,如下 ...
pip安装提示Twisted错误(Python3.6.4安装Twisted错误)
pip安装提示Twisted错误(Python3.6.4安装Twisted错误) 当我们在安装scrapy的过程中出现了Twisted错误,当我们有继续安装Twisted的时候,又继续报错,通过一系列的查询和了解,终于发现了问题,现在就来和大家一起解决这个复杂的BUG…… 环境 Python3.6.4 + Windows 10 问题描述 当我在安装pip install ...
Mac下Python使用Pip安装包错误解决
Found existing installation: six 1.4.1 DEPRECATION: Uninstalling a distutils installed project (six) has been deprecated and will be removed in a future version. This is due to the fact that uninstall
Python安装模块出错解决的办法(pip相关的安装)
python ez_setup.py  #安装 setuptools 然后在cmd进入命令行窗口, 进入ez_setup.py目录,我这里是下载放置在F盘,然后输入命令:python ez_setup.py 系统就会自动下载setuptools工具安装,最后的结局是显示编码错误: F:\>python ez_setup.py Extracting in c:\users\yc
pip安装pyquery报错
近来需要使用python对html进行爬虫抓取数据,在网上看了一下资料,发现很多人推荐pyquery模块。但是这个不是python自带的模块,需要安装。 自此,开始了艰难的探索... 搜了一下网上关于pyquery的安装方式,大多都是一句短短的 pip install pyquery。然后,就安装成功了?反正我没有那么顺利,照着步骤操作一直报错。 原来是因为pyque
python中使用提示的python -m pip install --upgrade pip升级失败解决方案
1,使用python -m pip install --upgrade pip升级失败 2,使用python -m pip install -U --force-reinstall pip依然失败 3,使用pip install --user --upgrade pip成功升级
pip 安装numpy出错
安装numpy时出错: 解决办法:到e:/python/lib/site-packages文件夹下将numpy文件夹删除(因为在卸载numpy时, 没有完全清理)
使用sudo pip install 安装python包出错的解决方法
 最近安装python下的几个包如sudo pip install SpeechRecognition都显示连接不上 无法安装 上网找了很久 发现应该是网络问题 所以我们在这里使用sudo pip install SpeechRecognition -i http://pypi.douban.com/simple/  这个命令换成其他的源就可以了...
windows下用pip安装paramiko------安装过程 依赖的模块pycrypto安装出了问题如何解决
想在windows下用python玩玩ssh,结果安装paramiko是出错,见下图 当然直接  pip install pycrypto也是报错的 那就直接下载别人编译好的可执行文件安装那就行了  ,下载地址:http://www.voidspace.org.uk/python/modules.shtml#pycrypto     选择对应的版本即可,傻瓜式安装 安装完就可以im
pip install 报错问题解决
pip install 报错问题解决有时在用pip install命令安装python库时出现红字报错1.报错:ReadTimeoutError: HTTPSConnectionPool(host=’pypi.python.org’, port=443): Read timed out.Downloading xgboost-0.6a2.tar.gz (1.2MB) 48% |███████
pip easy_install 安装python第三方库 超时报错
最近不管用python的pip 还是easy_install安装第三方库 都超时报错 百度了相关资料 1.设置超时时间 如添加timeout=100 2.手动设置第三方源 个人觉得第二种解决方法更好 eg:pip install packagename -i http://pypi.douban.com/simple --trusted-host pypi.douban.com
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 python运用培训 python删除pip教程