weixin_39562928
2021-01-08 11:59 阅读 2

netperf benchmark on EXSI hypervisor

Hi, I ran the netperf app on Exsi hypervisor, I followed the tutor and converted the image to vmdk files(scripts/convert vmdk). However, when I run the netperf apps, the client show the fault messages. [backtrace] 0x000000000000002257f8 <__assert_fail+24> 0x00000000000000360402 VMW::VMXnet3_rxqueue::receive()+1042 0x000000000000003605b1 VMW::VMXnet3_rxqueue::receive_work()+353 0x0000000000000036284b <:_function_handler vmw>::_M_invoke(std::_Any_data const&)+11> 0x000000000000003e1f86 0x00000000000000388492 <???+3703954></:_function_handler>

Is it a bug?

该提问来源于开源项目:cloudius-systems/osv

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

3条回答 默认 最新

  • weixin_39556853 weixin_39556853 2021-01-08 11:59

    Probably. The vmxnet3 driver appears to have state issues. The change in #793 works for me.

    点赞 评论 复制链接分享
  • weixin_39781326 weixin_39781326 2021-01-08 11:59

    Can we check if this is fixed by #793?

    点赞 评论 复制链接分享
  • weixin_39694838 weixin_39694838 2021-01-08 11:59

    I just realized that we never committed this patch! I don't know why that pull request was ever closed. The patch is sitting on the mailing list, titled "drivers/vmxnet3: Fix driver state issues". I don't know how to test this patch myself (I don't have vmware)... But I believe tested it well so I think I should commit it. I have no idea if it fixes this bug, though, nor how to reproduce it.

    点赞 评论 复制链接分享