iamryan
iamryan
2017-11-07 08:13
浏览 5.4k

安装CDH过程中无法安装cloudera-manager-agent

系统是CENTOS7.2,安装CDH5.11.1。为什么在安装的时候老是会报错有依赖包没装?CM WEB端或者直接系统中安装都 不会。到底是哪里出问题了,有大神帮忙 吗》》???谢谢

[root@master yum.repos.d]# yum -y install cloudera-manager-agent.x86_64
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
--> Running transaction check
---> Package cloudera-manager-agent.x86_64 0:5.11.1-1.cm5111.p0.9.el7 will be installed
--> Processing Dependency: python-psycopg2 for package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64
--> Processing Dependency: openssl-devel for package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64
--> Processing Dependency: MySQL-python for package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64
--> Processing Dependency: /lib/lsb/init-functions for package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64
--> Processing Dependency: /lib/lsb/init-functions for package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64
--> Finished Dependency Resolution
Error: Package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64 (cloudera-manager)
Requires: MySQL-python
Error: Package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64 (cloudera-manager)
Requires: openssl-devel
Error: Package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64 (cloudera-manager)
Requires: python-psycopg2
Error: Package: cloudera-manager-agent-5.11.1-1.cm5111.p0.9.el7.x86_64 (cloudera-manager)
Requires: /lib/lsb/init-functions
You could try using --skip-broken to work around the problem
** Found 4 pre-existing rpmdb problem(s), 'yum check' output follows:
MariaDB-client-10.2.1-1.el7.centos.x86_64 has missing requires of MariaDB-common
MariaDB-server-10.2.1-1.el7.centos.x86_64 has missing requires of MariaDB-common
2:postfix-2.10.1-6.el7.x86_64 has missing requires of libmysqlclient.so.18()(64bit)
2:postfix-2.10.1-6.el7.x86_64 has missing requires of libmysqlclient.so.18(libmysqlclient_18)(64bit)

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

相关推荐