java_lover01
java_lover01
2017-11-10 07:12

IDEA编译过期API错误的问题

  • 编译
  • removal
  • intellij-idea
  • eclipse

是这样的,我有个工程,在eclipse上面编译运行都没有问题,然后我在IDEA2017上checkout了这个
工程,编译的时候就编译出错,我打开出错的地方看了下是由于添加 @Removal 注解的地方,
在IDEA打开.class源文件查看的时候,这些内容都没有,但是在eclipse里这些 注解的代码都在.
下面是图:
idea编译出错:
图片说明
出错的class查看,Eclipse
图片说明
可以看到,在这个class里是有这个属性的,但是加了@Removal注解

IDEA2017:
图片说明
可以看到没有这个属性,我看了下,里面一个带@Removal注解的属性都没有

有没有大神遇到过并解决了的...

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

1条回答

为你推荐

换一换