用LinQ to Entity链接mysql出现不支持ef6的情况

建立数据模型后到选择ef版本的时候,显示不支持ef6,原来的ef5可以生成代码,我重装ef之后5没了,请问怎么解决
图片说明

5个回答

解决资源方案管理器-》右键项目-》管理Nuget程序包-》找的已安装的ef-》之后就可以选择重新安装ef的版本了

sinat_36035248
hhhljlishen 多谢,我试试
2 年多之前 回复

向来ef和mysql兼容就不好,你得找匹配的版本。

sinat_36035248
hhhljlishen 有没有办法把ef降级到5.x
2 年多之前 回复

有没有办法把ef降级到5.x,创建项目或项目使用的.net Framework 版本可以选择或修改的。在项目属性里修改一下。

testcs_dn
微wx笑 回复sinat_36035248: http://blog.csdn.net/ZKH_101/article/details/52518384
2 年多之前 回复
sinat_36035248
hhhljlishen 有没有确定可以支持的ef版本,mysql版本,连接器版本?现在急需ef链接mysql的解决方案
2 年多之前 回复

有没有确定可以支持的ef版本,mysql版本,连接器版本?现在急需ef链接mysql的解决方案

yzj_xiaoyue
yzj_xiaoyue 表示没有写过vs和MySQL结合的程序
2 年多之前 回复

我记得vs中的Nuget可以选择ef的版本的嘛,楼主可以试试

sinat_36035248
hhhljlishen 多谢
2 年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问