编程介的小学生 2017-11-17 05:40 采纳率: 20.5%
浏览 547
已结题

A Computer Graphics Problem

Problem Description
In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard.
We have designed a new mobile phone, your task is to write a interface to display battery powers.
Here we use '.' as empty grids.
When the battery is empty, the interface will look like this:
------------
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
------------

When the battery is 60% full, the interface will look like this:
------------
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
------------

Each line there are 14 characters.
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.

Input
The first line has a number T (T < 10) , indicating the number of test cases.
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)

Output
For test case X, output "Case #X:" at the first line. Then output the corresponding interface.
See sample output for more details.

Sample Input
2
0
60

Sample Output
Case #1:
------------
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
------------
Case #2:
------------
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
------------

  • 写回答

1条回答 默认 最新

  • HHi3s 2018-08-03 21:44
    关注
     #include <stdio.h>
    #include <string.h>
    int main()
    {
        int t,i,j,n,cas=1;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            char mp[20][20]= {"*------------*",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "|............|",
                              "*------------*"
                             };
            n/=10;
            for(i=1; i<=n; i++)
            {
                for(j=1; j<=12; j++)
                    mp[11-i][j]='-';
            }
            printf("Case #%d:\n",cas++);
            for(i=0; i<12; i++)
            {
                for(j=0; j<14; j++)
                {
                    printf("%c",mp[i][j]);
                }
                printf("\n");
            }
        }
        return 0;
    }
    
    
    评论

报告相同问题?

悬赏问题

  • ¥15 有兄弟姐妹会用word插图功能制作类似citespace的图片吗?
  • ¥200 uniapp长期运行卡死问题解决
  • ¥15 请教:如何用postman调用本地虚拟机区块链接上的合约?
  • ¥15 为什么使用javacv转封装rtsp为rtmp时出现如下问题:[h264 @ 000000004faf7500]no frame?
  • ¥15 乘性高斯噪声在深度学习网络中的应用
  • ¥15 关于docker部署flink集成hadoop的yarn,请教个问题 flink启动yarn-session.sh连不上hadoop,这个整了好几天一直不行,求帮忙看一下怎么解决
  • ¥15 深度学习根据CNN网络模型,搭建BP模型并训练MNIST数据集
  • ¥15 C++ 头文件/宏冲突问题解决
  • ¥15 用comsol模拟大气湍流通过底部加热(温度不同)的腔体
  • ¥50 安卓adb backup备份子用户应用数据失败