Maven <type>pom</type>

maven中央仓库找到zookeeper的依赖,我在maven文件中引入

 <dependency> 
<groupId>org.apache.zookeeper</groupId> 
<artifactId>zookeeper</artifactId> 
<version>3.4.6</version> 
<type>pom</type> 
</dependency> 

发现相关jar包并没有下载下来,请问这是怎么回事啊

1个回答

因为type是pom,将jar包打包成pom了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
创建Maven项目 pom.xml文件报错

创建maven项目 pom.xml文件提示错误: Failure to transfer org.apache.maven.surefire:surefire:pom:2.10 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.apache.maven.surefire:surefire:pom:2.10 from/to central (http://repo.maven.apache.org/maven2): java.net.ConnectException: connection timed out to http://repo.maven.apache.org/maven2/org/apache/maven/surefire/surefire/2.10/surefire-2.10.pom 在网上搜索后给出的解决方法是 打开maven的本地库...\repository\org\apache\maven\plugins\maven-surefire-plugin\2.10会发现:里面少只有一个maven-surefire-plugin-2.10.pom.lastUpdated,而没有maven-surefire-plugin-2.10.jar 解决方法: 1.删除maven-surefire-plugin-2.7.1.pom.lastUpdated文件 2.右键点击project -> Maven - Update Dependencies 但我的本地库有aven-surefire-plugin-2.10.jar以及相关文件 没有maven-surefire-plugin-2.10.pom.lastUpdated文件 怎么还报这样的错误 在网上搜索好长时间 一直没有解决 求大神指点!! 谢谢

新建maven工程报错,该怎么解决?

具体情况是这样的,公司jdk为1.6 ,eclipse为kepler版本 ,为了和他们俩不冲突,我下载了maven3.2.5,然后各种配置。。。。。 新建maven项目pom第一行报错:org/apache/maven/plugins/war/WarMojo : Unsupported major.minor version 51.0 然后下面的plugin标签:Multiple annotations found at this line: - CoreException: Could not get the value for parameter compilerId for plugin execution default- testCompile: TypeNotPresentException: Type org.apache.maven.plugin.compiler.TestCompilerMojo not present: UnsupportedClassVersionError: org/apache/maven/plugin/compiler/TestCompilerMojo : Unsupported major.minor version 51.0 - Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven- compiler-plugin:3.7.0:testCompile (execution: default-testCompile, phase: test-compile) - CoreException: Could not get the value for parameter compilerId for plugin execution default- compile: TypeNotPresentException: Type org.apache.maven.plugin.compiler.CompilerMojo not present: UnsupportedClassVersionError: org/apache/maven/plugin/compiler/CompilerMojo : Unsupported major.minor version 51.0 - Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven- compiler-plugin:3.7.0:compile (execution: default-compile, phase: compile) 我真的不知道该怎么解决,网上都说jdk版本和maven冲突,我按照maven官网给出的jdk'版本对应要求下载的3.2.5 为什么就不行了呢,官网是假的?

maven爆出的一个问题,没有查到原因,谁能帮我看看

Multiple annotations found at this line: - Project build error: Non-parseable POM C:\Users\vincent\arquillian-tutorial\pom.xml: Duplicated tag: 'dependencyManagement' (position: START_TAG seen ...</dependencies>\r\n <dependencyManagement>... @50:25) - cvc-complex-type.2.4.a: Invalid content was found starting with element 'dependencyManagement'. One of '{"http://maven.apache.org/POM/ 4.0.0":parent, "http://maven.apache.org/POM/4.0.0":name, "http://maven.apache.org/POM/4.0.0":description, "http://maven.apache.org/POM/4.0.0":url, "http://maven.apache.org/POM/4.0.0":prerequisites, "http://maven.apache.org/POM/4.0.0":issueManagement, "http://maven.apache.org/POM/ 4.0.0":ciManagement, "http://maven.apache.org/POM/4.0.0":inceptionYear, "http://maven.apache.org/POM/4.0.0":mailingLists, "http:// maven.apache.org/POM/4.0.0":developers, "http://maven.apache.org/POM/4.0.0":contributors, "http://maven.apache.org/POM/4.0.0":licenses, "http:// maven.apache.org/POM/4.0.0":scm, "http://maven.apache.org/POM/4.0.0":organization, "http://maven.apache.org/POM/4.0.0":profiles, "http:// maven.apache.org/POM/4.0.0":modules, "http://maven.apache.org/POM/4.0.0":repositories, "http://maven.apache.org/POM/4.0.0":pluginRepositories, "http://maven.apache.org/POM/4.0.0":reports, "http://maven.apache.org/POM/4.0.0":reporting, "http://maven.apache.org/POM/ 4.0.0":distributionManagement}' is expected. 如上所述,在上一个<dependencies>中添加了: <dependency> <groupId>org.jboss.arquillian.junit</groupId> <artifactId>arquillian-junit-container</artifactId> <scope>test</scope> </dependency> 之后,就在下面另一行: <dependencyManagement>中提示,上面的错误,问什么呢?

新导入的maven项目pom报错

``` <dependency> <groupId>oracle.jdbc</groupId> <artifactId>ojdbc</artifactId> <version>6</version> </dependency> <dependency> ``` 提示missing 还有头部报错: Failure to transfer org.codehaus.plexus:plexus-archiver:pom:1.0 from http://repo1.maven.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact org.codehaus.plexus:plexus-archiver:pom:1.0 from/to central (http:// repo1.maven.org/maven2): No response received after 60000 ``` <?xml version="1.0" encoding="UTF-8"?> <web-app xmlns="http://xmlns.jcp.org/xml/ns/javaee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://xmlns.jcp.org/xml/ns/javaee http://xmlns.jcp.org/xml/ns/javaee/web-app_3_1.xsd" version="3.1"> ``` 还有就是web.xml中welcom-file-list报错 Multiple annotations found at this line: - cvc-complex-type.2.3: Element 'welcome-file-list' cannot have character [children], because the type's content type is element-only. - cvc-complex-type.2.4.b: The content of element 'welcome-file-list' is not complete. One of '{"http:// xmlns.jcp.org/xml/ns/javaee":welcome-file}' is expected. ``` <welcome-file-list> index.jsp </welcome-file-list> ```

有关Maven仓库中,type属性问题

** 如下代码中,type是什么意思,pom是什么,为什么这么写。能形象点,详细点。** ``` <dependency> <groupId>org.springframework</groupId> <artifactId>spring-context</artifactId> <version>5.1.3.RELEASE</version> <type>pom</type> </dependency> ```

maven 项目中pom依赖到其他pom【A】,如何递归下载这个pom【A】中的依赖包?

用maven管理的项目,其中引入了 <dependency> <groupId>org.apache.hadoop</groupId> <artifactId>hadoop-yarn</artifactId> <version>${hadoop.version}</version> <type>pom</type> </dependency> 但是这个GAV定位到的是一个POM文件,此文件中包括了一堆modules 如下 <modules> <module>hadoop-yarn-api</module> <module>hadoop-yarn-common</module> <module>hadoop-yarn-server</module> <module>hadoop-yarn-applications</module> <module>hadoop-yarn-site</module> <module>hadoop-yarn-client</module> </modules> 我的本意是想通过这个依赖把他下面的jar包【hadoop-yarn-api.jar hadoop-yarn-common.jar】等等都引入到我的工程中 但是一个包都没进来。 盼高手解答清楚。万分感谢。

在maven的pom.xml中添加<dependency>直接可以下载jar包吗

如题,我eclipse中下载了m2eclipse插件,新建了一个maven项目,然后再pom.xml中添加了 ![图片说明](https://img-ask.csdn.net/upload/201504/03/1428034879_457975.png) 再运行什么命令可以下载jar包呢?求大神解答啊。

maven的pom 提示错误 Failure to transfer com.thoughtworks.xstream:xstream:jar:

<div class="iteye-blog-content-contain" style="font-size: 14px;"> <p>Description    Resource    Path    Location    Type<br>Failure to transfer com.thoughtworks.xstream:xstream:jar:1.4.3 from http://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact com.thoughtworks.xstream:xstream:jar:1.4.3 from/to central (http://repo.maven.apache.org/maven2): No response received after 60000    pom.xml    /testweb    line 1    Maven Configuration Problem</p> <p> </p> <p>奇怪的问题,哪位大大遇到过?</p> </div>

Maven PHP Basic存储库

<div class="post-text" itemprop="text"> <p>Whatever I try I can not get a basic working maven environment for php, despite all efforts I have found on the internet. To start with the basic Settings.xml in the .m2 repository gives errors because that repo is not there anymore, so I use</p> <pre><code>&lt;settings&gt; &lt;mirrors&gt; &lt;mirror&gt; &lt;!--This sends everything else to /public --&gt; &lt;id&gt;nexus&lt;/id&gt; &lt;mirrorOf&gt;*&lt;/mirrorOf&gt; &lt;url&gt;http://sxgio.servehttp.com/nexus/content/groups/public&lt;/url&gt; &lt;/mirror&gt; &lt;/mirrors&gt; &lt;profiles&gt; &lt;profile&gt; &lt;id&gt;profile-php-maven&lt;/id&gt; &lt;pluginRepositories&gt; &lt;pluginRepository&gt; &lt;id&gt;release-repo1.php-maven.org&lt;/id&gt; &lt;name&gt;PHP-Maven 2 Release Repository&lt;/name&gt; &lt;url&gt;http://repos.php-maven.org/releases&lt;/url&gt; &lt;releases&gt; &lt;enabled&gt;true&lt;/enabled&gt; &lt;/releases&gt; &lt;/pluginRepository&gt; &lt;pluginRepository&gt; &lt;id&gt;snapshot-repo1.php-maven.org&lt;/id&gt; &lt;name&gt;PHP-Maven 2 Snapshot Repository&lt;/name&gt; &lt;url&gt;http://repos.php-maven.org/snapshots&lt;/url&gt; &lt;releases&gt; &lt;enabled&gt;false&lt;/enabled&gt; &lt;/releases&gt; &lt;snapshots&gt; &lt;enabled&gt;true&lt;/enabled&gt; &lt;/snapshots&gt; &lt;/pluginRepository&gt; &lt;/pluginRepositories&gt; &lt;repositories&gt; &lt;repository&gt; &lt;id&gt;release-repo1.php-maven.org&lt;/id&gt; &lt;name&gt;PHP-Maven 2 Release Repository&lt;/name&gt; &lt;url&gt;http://repos.php-maven.org/releases&lt;/url&gt; &lt;releases&gt; &lt;enabled&gt;true&lt;/enabled&gt; &lt;/releases&gt; &lt;/repository&gt; &lt;repository&gt; &lt;id&gt;snapshot-repo1.php-maven.org&lt;/id&gt; &lt;name&gt;PHP-Maven 2 Snapshot Repository&lt;/name&gt; &lt;url&gt;http://repos.php-maven.org/snapshots&lt;/url&gt; &lt;releases&gt; &lt;enabled&gt;false&lt;/enabled&gt; &lt;/releases&gt; &lt;snapshots&gt; &lt;enabled&gt;true&lt;/enabled&gt; &lt;/snapshots&gt; &lt;/repository&gt; &lt;repository&gt; &lt;id&gt;snapshot-nexus.org&lt;/id&gt; &lt;name&gt;Nexus repo&lt;/name&gt; &lt;url&gt;http://nexus.php-maven.org/content/repositories/php-maven-plugin-snapshots&lt;/url&gt; &lt;releases&gt; &lt;enabled&gt;false&lt;/enabled&gt; &lt;/releases&gt; &lt;snapshots&gt; &lt;enabled&gt;true&lt;/enabled&gt; &lt;/snapshots&gt; &lt;/repository&gt; &lt;/repositories&gt; &lt;/profile&gt; &lt;/profiles&gt; &lt;activeProfiles&gt; &lt;activeProfile&gt;profile-php-maven&lt;/activeProfile&gt; &lt;/activeProfiles&gt; &lt;/settings&gt; </code></pre> <p>and furthermore the pom.xml</p> <pre><code>&lt;?xml version="1.0" encoding="UTF-8"?&gt; &lt;project&gt; &lt;modelVersion&gt;4.0.0&lt;/modelVersion&gt; &lt;parent&gt; &lt;groupId&gt;org.phpmaven&lt;/groupId&gt; &lt;artifactId&gt;php-parent-pom&lt;/artifactId&gt; &lt;version&gt;2.0.2&lt;/version&gt; &lt;/parent&gt; &lt;properties&gt; &lt;phpmaven.release.number&gt;2.0.2&lt;/phpmaven.release.number&gt; &lt;project.build.sourceEncoding&gt;UTF-8&lt;/project.build.sourceEncoding&gt; &lt;phpunit.version&gt;3.6.10&lt;/phpunit.version&gt; &lt;/properties&gt; &lt;groupId&gt;nict.sample&lt;/groupId&gt; &lt;artifactId&gt;mvn-nict-webapp&lt;/artifactId&gt; &lt;version&gt;2.0.2-SNAPSHOT&lt;/version&gt; &lt;packaging&gt;php&lt;/packaging&gt; &lt;name&gt;PHP 5 web Project&lt;/name&gt; &lt;description&gt;Sample PHP 5 web project.&lt;/description&gt; &lt;url&gt;http://www.php-maven.org&lt;/url&gt; &lt;inceptionYear&gt;2008&lt;/inceptionYear&gt; &lt;build&gt; &lt;plugins&gt; &lt;plugin&gt; &lt;groupId&gt;org.phpmaven&lt;/groupId&gt; &lt;artifactId&gt;maven-php-plugin&lt;/artifactId&gt; &lt;!-- version&gt;${phpmaven.plugin.version}&lt;/version --&gt; &lt;extensions&gt;true&lt;/extensions&gt; &lt;configuration&gt;&lt;/configuration&gt; &lt;/plugin&gt; &lt;!-- &lt;plugin&gt; &lt;groupId&gt;org.sample&lt;/groupId&gt; &lt;artifactId&gt;own-plugin&lt;/artifactId&gt; &lt;version&gt;1.0-SNAPSHOT&lt;/version&gt; &lt;extensions&gt;true&lt;/extensions&gt; &lt;/plugin&gt; --&gt; &lt;plugin&gt; &lt;groupId&gt;org.apache.maven.plugins&lt;/groupId&gt; &lt;artifactId&gt;maven-site-plugin&lt;/artifactId&gt; &lt;version&gt;3.0&lt;/version&gt; &lt;inherited&gt;true&lt;/inherited&gt; &lt;configuration&gt; &lt;reportPlugins&gt; &lt;plugin&gt; &lt;groupId&gt;org.phpmaven&lt;/groupId&gt; &lt;artifactId&gt;maven-php-plugin&lt;/artifactId&gt; &lt;version&gt;${phpmaven.plugin.version}&lt;/version&gt; &lt;reportSets&gt; &lt;reportSet&gt; &lt;reports&gt; &lt;report&gt;phpdocumentor&lt;/report&gt; &lt;report&gt;phpunit-coverage&lt;/report&gt; &lt;report&gt;phpunit&lt;/report&gt; &lt;/reports&gt; &lt;/reportSet&gt; &lt;/reportSets&gt; &lt;/plugin&gt; &lt;/reportPlugins&gt; &lt;/configuration&gt; &lt;/plugin&gt; &lt;/plugins&gt; &lt;/build&gt; &lt;dependencies&gt; &lt;dependency&gt; &lt;groupId&gt;de.phpunit&lt;/groupId&gt; &lt;artifactId&gt;PHPUnit&lt;/artifactId&gt; &lt;version&gt;${phpunit.version}&lt;/version&gt; &lt;scope&gt;test&lt;/scope&gt; &lt;type&gt;phar&lt;/type&gt; &lt;/dependency&gt; &lt;/dependencies&gt; &lt;/project&gt; </code></pre> <p>What on earth is going wrong. It seems so simple and yet no result. Is the PHP maven project stopt in 2012, I see no updates on the repo-site</p> </div>

用maven打war包时报了如下错误,大神们帮忙看看

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-war-plugin:2.0.2:war (default-war) on project shop: A type incompatibility occured while executing org.apache.maven.plugins:maven-war-plugin:2.0.2:war: org.apache.maven.project.MavenProject cannot be cast to java.lang.String [ERROR] ----------------------------------------------------- [ERROR] realm = plugin>org.apache.maven.plugins:maven-war-plugin:2.0.2 [ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy [ERROR] urls[0] = file:/D:/maven/mvnRespo/org/apache/maven/plugins/maven-war-plugin/2.0.2/maven-war-plugin-2.0.2.jar [ERROR] urls[1] = file:/D:/maven/mvnRespo/org/apache/maven/maven-archiver/2.2/maven-archiver-2.2.jar [ERROR] urls[2] = file:/D:/maven/mvnRespo/junit/junit/3.8.1/junit-3.8.1.jar [ERROR] urls[3] = file:/D:/maven/mvnRespo/org/codehaus/plexus/plexus-archiver/1.0-alpha-7/plexus-archiver-1.0-alpha-7.jar [ERROR] urls[4] = file:/D:/maven/mvnRespo/org/codehaus/plexus/plexus-utils/1.0.4/plexus-utils-1.0.4.jar [ERROR] Number of foreign imports: 1 [ERROR] import: Entry[import from realm ClassRealm[maven.api, parent: null]] [ERROR] [ERROR] ----------------------------------------------------- [ERROR] -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please read the following articles: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException pom 配置如下 ``` <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-war-plugin</artifactId> <version>2.0.2</version> <configuration> <webResources> <resource> <directory>src/main/webapp/WEB-INF</directory> <filtering>true</filtering> <targetPath>target</targetPath> </resource> </webResources> </configuration> </plugin> ```

myeclipse10创建maven,pom.xml报错org.apache.maven.archiver.MavenArchiver.getManifest

pom.xml报错,org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject, org.apache.maven.archiver.MavenArchiveConfiguration)我在百度上搜了方法,在help选 install new sofware 然添加链接。但是下载不来下,还时在报错, ,大神们这怎么解决啊,这个问题困了我两天了,头疼啊!![图片说明](https://img-ask.csdn.net/upload/201901/30/1548860838_416589.png) 难道还跟我用的myeclipse有关吗,我用的时myeclipse10

Maven工程出现的问题,哪位大神帮看一下

Failed to execute goal on project assm1web: Could not resolve dependencies for project com.shisen:assm1web:war:0.0.1-SNAPSHOT: The following artifacts could not be resolved: com.shisen:person1:war:0.0.1-SNAPSHOT, com.shisen:goods1web:war:0.0.1-SNAPSHOT: Could not find artifact com.shisen:person1:war:0.0.1-SNAPSHOT - 父工程pom.xml ``` <?xml version="1.0" encoding="UTF-8"?> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>com.shisen</groupId> <artifactId>assm1</artifactId> <version>0.0.1-SNAPSHOT</version> <packaging>pom</packaging> <name>assm1</name> <url>http://maven.apache.org</url> <properties> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> </properties> <dependencies> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> <version>3.8.1</version> <scope>test</scope> </dependency> </dependencies> <modules> <module>assm1web</module> <module>common</module> <module>person1</module> <module>goods1</module> <module>goods1web</module> </modules> </project> ``` 总的web模块pom.xml ``` <?xml version="1.0"?> <project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <modelVersion>4.0.0</modelVersion> <parent> <groupId>com.shisen</groupId> <artifactId>assm1</artifactId> <version>0.0.1-SNAPSHOT</version> </parent> <groupId>com.shisen</groupId> <artifactId>assm1web</artifactId> <version>0.0.1-SNAPSHOT</version> <packaging>war</packaging> <name>assm1web Maven Webapp</name> <url>http://maven.apache.org</url> <dependencies> <dependency> <groupId>com.shisen</groupId> <artifactId>person1</artifactId> <version>0.0.1-SNAPSHOT</version> <type>war</type> </dependency> <dependency> <groupId>com.shisen</groupId> <artifactId>goods1web</artifactId> <version>0.0.1-SNAPSHOT</version> <type>war</type> </dependency> </dependencies> <build> <finalName>assm1web</finalName> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-war-plugin</artifactId> <version>2.4</version> <configuration> <overlays> <overlay> <groupId>com.shisen</groupId> <artifactId>person1</artifactId> </overlay> <overlay> <groupId>com.shisen</groupId> <artifactId>goods1web</artifactId> </overlay> </overlays> </configuration> </plugin> </plugins> </build> </project> ``` 其中person1模块的pom.xml ``` <?xml version="1.0"?> <project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> <modelVersion>4.0.0</modelVersion> <parent> <groupId>com.shisen</groupId> <artifactId>assm1</artifactId> <version>0.0.1-SNAPSHOT</version> </parent> <groupId>com.shisen</groupId> <artifactId>person1</artifactId> <version>0.0.1-SNAPSHOT</version> <packaging>war</packaging> <name>person1 Maven Webapp</name> <url>http://maven.apache.org</url> <dependencies> <dependency> <groupId>junit</groupId> <artifactId>junit</artifactId> <version>3.8.1</version> <scope>test</scope> </dependency> </dependencies> <build> <finalName>person1</finalName> </build> </project> ```

maven ear包的问题!

From file: /home/zx/workspace/adboard2009/adboard-chn-ear/pom.xml Reason: Cannot copy a directory: /home/zx/workspace/adboard2009/adboard-core/entity-jar/target/classes; Did you package/install com.ericsson.adboard:entity-jar:jar:3.0.0-alpha:compile? 原POM如下 <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <parent> <groupId>com.ericsson.adboard</groupId> <artifactId>adboard</artifactId> <version>3.0.0-alpha</version> </parent> <artifactId>adboard-chn-ear</artifactId> <packaging>ear</packaging> <name>Adboard China EAR</name> <dependencies> <dependency> <groupId>com.ericsson.adboard</groupId> <artifactId>entity-jar</artifactId> <version>3.0.0-alpha</version> <type>jar</type> </dependency> </dependencies> <build> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-ear-plugin</artifactId> <configuration> <modules> <jarModule> <groupId>com.ericsson.adboard</groupId> <artifactId>entity-jar</artifactId> <bundleDir>lib</bundleDir> </jarModule> </modules> </configuration> </plugin> </plugins> </build> </project>

eclipse maven install 报错

[ERROR] Plugin org.apache.maven.plugins:maven-surefire-plugin:2.12.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.12.4: Could not transfer artifact org.apache.maven.plugins:maven-surefire-plugin:pom:2.12.4 from/to central (https://repo.maven.apache.org/maven2): Cannot access https://repo.maven.apache.org/maven2 with type default using the available connector factories: BasicRepositoryConnectorFactory: Cannot access https://repo.maven.apache.org/maven2 using the registered transporter factories: WagonTransporterFactory: java.util.NoSuchElementException [ERROR] role: org.apache.maven.wagon.Wagon [ERROR] roleHint: https [ERROR] -> [Help 1]

创建一个 maven 项目 为什么 pom.xml 文件会报错

![图片说明](https://img-ask.csdn.net/upload/201906/06/1559812302_107418.png) Description Resource Path Location Type web.xml is missing and <failOnMissingWebXml> is set to true pom.xml /aa line 6 Maven Java EE Configuration Problem

pom.xml报错 Problems提示Unknown?

pom.xml ![图片说明](https://img-ask.csdn.net/upload/201809/24/1537759128_756541.jpg) Problems ![图片说明](https://img-ask.csdn.net/upload/201809/24/1537759162_703288.png) 求解

使用maven tomcat 插件 启动web 项目,报错,提示jar包冲突,但是不知道问题在哪里?

报错如下: 2016-6-6 17:31:07 org.apache.catalina.core.StandardWrapperValve invoke 严重: Servlet.service() for servlet jsp threw exception java.lang.LinkageError: loader constraint violation: loader (instance of org/apache/jasper/servlet/JasperLoader) previously initiated loading for a different type with name "javax/servlet/http/HttpServletRequest" at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2436) at java.lang.Class.getDeclaredMethods(Class.java:1793) at org.apache.catalina.util.DefaultAnnotationProcessor.processAnnotations(DefaultAnnotationProcessor.java:226) at org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:148) at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:329) at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313) at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260) at javax.servlet.http.HttpServlet.service(HttpServlet.java:717) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:857) at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:588) at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:489) at java.lang.Thread.run(Thread.java:662) pom.xml 如下: <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>quchengming</groupId> <artifactId>helloWeb</artifactId> <version>1.0-SNAPSHOT</version> <packaging>war</packaging> <name>helloWeb</name> <properties> <endorsed.dir>${project.build.directory}/endorsed</endorsed.dir> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> </properties> <!-- <dependencies> <dependency> <groupId>javax</groupId> <artifactId>javaee-web-api</artifactId> <version>6.0</version> <scope>provided</scope> </dependency> </dependencies> --> <build> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>2.3.2</version> <configuration> <source>1.6</source> <target>1.6</target> <compilerArguments> <endorseddirs>${endorsed.dir}</endorseddirs> </compilerArguments> </configuration> </plugin> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-war-plugin</artifactId> <version>2.1.1</version> <configuration> <failOnMissingWebXml>false</failOnMissingWebXml> </configuration> </plugin> <!-- <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-dependency-plugin</artifactId> <version>2.1</version> <executions> <execution> <phase>validate</phase> <goals> <goal>copy</goal> </goals> <configuration> <outputDirectory>${endorsed.dir}</outputDirectory> <silent>true</silent> <artifactItems> <artifactItem> <groupId>javax</groupId> <artifactId>javaee-endorsed-api</artifactId> <version>6.0</version> <type>jar</type> </artifactItem> </artifactItems> </configuration> </execution> </executions> </plugin> --> <plugin> <groupId>org.apache.tomcat.maven</groupId> <artifactId>tomcat6-maven-plugin</artifactId> <version>2.2</version> </plugin> <plugin> <groupId>org.apache.tomcat.maven</groupId> <artifactId>tomcat7-maven-plugin</artifactId> <version>2.2</version> </plugin> <plugin> <groupId>org.mortbay.jetty</groupId> <artifactId>jetty-maven-plugin</artifactId> </plugin> </plugins> </build> <!-- http://tomcat.apache.org/maven-plugin-2.2/index.html --> <!--http://wiki.eclipse.org/Jetty/Feature/Jetty_Maven_Plugin --> </project>

mybatis maven 项目编译问题

我在github上下载mybatis项目 导入eclipse中 pom.xml文件中的: <parent> <groupId>org.mybatis</groupId> <artifactId>mybatis-parent</artifactId> <version>25-SNAPSHOT</version> </parent> ​提示错误: Description Resource Path Location Type Project build error: Non-resolvable parent POM for org.mybatis:mybatis:3.3.1-SNAPSHOT: Could not find artifact org.mybatis:mybatis-parent:pom:25-SNAPSHOT and 'parent.relativePath' points at wrong local POM pom.xml /mybatis line 20 Maven pom Loading Problem 请问需要怎么解决这样的问题。

jar包使用问题Archive for required library

导入别人的Maven项目时依赖的jar包老是提示Archive for required library: cannot be read or is not a valid ZIP file。我是pom直接save的,另外小锁和Manage分别代表什么啊 ![图片说明](https://img-ask.csdn.net/upload/201711/28/1511874976_506579.png)

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

程序员请照顾好自己,周末病魔差点一套带走我。

程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。

Java基础知识面试题(2020最新版)

文章目录Java概述何为编程什么是Javajdk1.5之后的三大版本JVM、JRE和JDK的关系什么是跨平台性?原理是什么Java语言有哪些特点什么是字节码?采用字节码的最大好处是什么什么是Java程序的主类?应用程序和小程序的主类有何不同?Java应用程序与小程序之间有那些差别?Java和C++的区别Oracle JDK 和 OpenJDK 的对比基础语法数据类型Java有哪些数据类型switc...

和黑客斗争的 6 天!

互联网公司工作,很难避免不和黑客们打交道,我呆过的两家互联网公司,几乎每月每天每分钟都有黑客在公司网站上扫描。有的是寻找 Sql 注入的缺口,有的是寻找线上服务器可能存在的漏洞,大部分都...

Intellij IDEA 实用插件安利

1. 前言从2020 年 JVM 生态报告解读 可以看出Intellij IDEA 目前已经稳坐 Java IDE 头把交椅。而且统计得出付费用户已经超过了八成(国外统计)。IDEA 的...

搜狗输入法也在挑战国人的智商!

故事总是一个接着一个到来...上周写完《鲁大师已经彻底沦为一款垃圾流氓软件!》这篇文章之后,鲁大师的市场工作人员就找到了我,希望把这篇文章删除掉。经过一番沟通我先把这篇文章从公号中删除了...

总结了 150 余个神奇网站,你不来瞅瞅吗?

原博客再更新,可能就没了,之后将持续更新本篇博客。

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

MySQL数据库面试题(2020最新版)

文章目录数据库基础知识为什么要使用数据库什么是SQL?什么是MySQL?数据库三大范式是什么mysql有关权限的表都有哪几个MySQL的binlog有有几种录入格式?分别有什么区别?数据类型mysql有哪些数据类型引擎MySQL存储引擎MyISAM与InnoDB区别MyISAM索引与InnoDB索引的区别?InnoDB引擎的4大特性存储引擎选择索引什么是索引?索引有哪些优缺点?索引使用场景(重点)...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

魂迁光刻,梦绕芯片,中芯国际终获ASML大型光刻机

据羊城晚报报道,近日中芯国际从荷兰进口的一台大型光刻机,顺利通过深圳出口加工区场站两道闸口进入厂区,中芯国际发表公告称该光刻机并非此前盛传的EUV光刻机,主要用于企业复工复产后的生产线扩容。 我们知道EUV主要用于7nm及以下制程的芯片制造,光刻机作为集成电路制造中最关键的设备,对芯片制作工艺有着决定性的影响,被誉为“超精密制造技术皇冠上的明珠”,根据之前中芯国际的公报,目...

优雅的替换if-else语句

场景 日常开发,if-else语句写的不少吧??当逻辑分支非常多的时候,if-else套了一层又一层,虽然业务功能倒是实现了,但是看起来是真的很不优雅,尤其是对于我这种有强迫症的程序"猿",看到这么多if-else,脑袋瓜子就嗡嗡的,总想着解锁新姿势:干掉过多的if-else!!!本文将介绍三板斧手段: 优先判断条件,条件不满足的,逻辑及时中断返回; 采用策略模式+工厂模式; 结合注解,锦...

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

2020阿里全球数学大赛:3万名高手、4道题、2天2夜未交卷

阿里巴巴全球数学竞赛( Alibaba Global Mathematics Competition)由马云发起,由中国科学技术协会、阿里巴巴基金会、阿里巴巴达摩院共同举办。大赛不设报名门槛,全世界爱好数学的人都可参与,不论是否出身数学专业、是否投身数学研究。 2020年阿里巴巴达摩院邀请北京大学、剑桥大学、浙江大学等高校的顶尖数学教师组建了出题组。中科院院士、美国艺术与科学院院士、北京国际数学...

为什么你不想学习?只想玩?人是如何一步一步废掉的

不知道是不是只有我这样子,还是你们也有过类似的经历。 上学的时候总有很多光辉历史,学年名列前茅,或者单科目大佬,但是虽然慢慢地长大了,你开始懈怠了,开始废掉了。。。 什么?你说不知道具体的情况是怎么样的? 我来告诉你: 你常常潜意识里或者心理觉得,自己真正的生活或者奋斗还没有开始。总是幻想着自己还拥有大把时间,还有无限的可能,自己还能逆风翻盘,只不是自己还没开始罢了,自己以后肯定会变得特别厉害...

百度工程师,获利10万,判刑3年!

所有一夜暴富的方法都写在刑法中,但总有人心存侥幸。这些年互联网犯罪高发,一些工程师高技术犯罪更是引发关注。这两天,一个百度运维工程师的案例传遍朋友圈。1...

程序员为什么千万不要瞎努力?

本文作者用对比非常鲜明的两个开发团队的故事,讲解了敏捷开发之道 —— 如果你的团队缺乏统一标准的环境,那么即使勤劳努力,不仅会极其耗时而且成果甚微,使用...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

《Oracle Java SE编程自学与面试指南》最佳学习路线图2020年最新版(进大厂必备)

正确选择比瞎努力更重要!

字节跳动面试官竟然问了我JDBC?

轻松等回家通知

面试官:你连SSO都不懂,就别来面试了

大厂竟然要考我SSO,卧槽。

实时更新:计算机编程语言排行榜—TIOBE世界编程语言排行榜(2020年6月份最新版)

内容导航: 1、TIOBE排行榜 2、总榜(2020年6月份) 3、本月前三名 3.1、C 3.2、Java 3.3、Python 4、学习路线图 5、参考地址 1、TIOBE排行榜 TIOBE排行榜是根据全世界互联网上有经验的程序员、课程和第三方厂商的数量,并使用搜索引擎(如Google、Bing、Yahoo!)以及Wikipedia、Amazon、YouTube统计出排名数据。

立即提问
相关内容推荐