此驱动程序不支持1.8 版

此驱动程序不支持1.8 版请使用支持 JDBC 4.0 的 sqljdbc4.jar 类库
如题
Nov 26, 2017 3:25:05 PM com.microsoft.sqlserver.jdbc.SQLServerConnection
严重: 此驱动程序不支持 Java Runtime Environment (JRE) 1.8 版。请使用支持 JDBC 4.0 的 sqljdbc4.jar 类库。
Exception in thread "main" java.lang.UnsupportedOperationException: 此驱动程序不支持 Java Runtime Environment (JRE) 1.8 版。请使用支持 JDBC 4.0 的 sqljdbc4.jar 类库。
at com.microsoft.sqlserver.jdbc.SQLServerConnection.(SQLServerConnection.java:304)
at com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(SQLServerDriver.java:1011)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:247)
at jdbc.JdbcDemo1.main(JdbcDemo1.java:15)

图片说明

0

2个回答

此驱动程序不支持 Java Runtime Environment (JRE) 1.8 版。请使用支持 JDBC 4.0 的 sqljdbc4.jar 类库。
这不是告诉你了么
要么你换java版本,要么换jar版本

1

Java版本太高了,你换个低版本的就可以了,或者升级一下你的数据库到最新版,估计就会支持Java 1.8了

1
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!