在elcipse中导入maven项目时,pom.xml报错

在elcipse中导入maven项目时,pom.xml报在elcipse中导入maven项目时,pom.xml报ArtifactDescriptorException错误

![![图片说明](https://img-ask.csdn.net/upload/201711/30/1512029259_628567.png)

图片说明

图片说明

2个回答

猜测原因:maven在下载jar包的时候没下载好,产生.lastupdated
maven默认的下载repository在国外,在网不好的情况下很容易下载失败,并产生.lastupdated文件
解决办法:删除你的.m2/repository/下所有.lastupdated的文件,重新build以下maven项目
例如:xxx.\m2\repository\commons-lang\commons-lang\2.6\下的xxx.lastupdated文件

williamxiaolifang
williamxiaolifang 已经解决了,谢谢
大约 2 年之前 回复
williamxiaolifang
williamxiaolifang 怎么bulid呢?
大约 2 年之前 回复

你的maven用的是公司的还是maven自己的。看看是不是要改setting文件

williamxiaolifang
williamxiaolifang 改了setting文件的servers标签内的内容还是不行
大约 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问