qq_38350986
2017-11-30 16:05
采纳率: 100%
浏览 1.1k
已采纳

我用eclipse启动tomcat服务器报错了,百度找不到方法

问题是这样的,我单独启动tomcat不会报错,也可以进localhost,但是用eclipse启动tomcat就不行,我都还没上传项目,只是启动tomcat就报错。
图片说明
图片说明
我百度过了,只找到一个和我一样错误的,但是试过没用,我自己也看不懂,求大佬帮帮忙,谢谢

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

6条回答 默认 最新

  • 枣面包 2017-12-01 01:54
    已采纳

    您可以从两个方面排查问题:1.eclipse启动的tomcat和你在外面自己启动的tomcat是不是同一个tomcat(即eclipse里设置tomcat时您指定的位置在哪)
    2.您设置eclipse的tomcat时选择的tomcat版本和你指定的tomcat位置的tomcat版本是同一个版本吗?(根据您贴出来的,你外部tomcat的版本为9.0,那您eclipse中设置选择的tomcat版本是多少?)
    给您的建议:目前tomcat9.0还不是正式稳定的版本,推荐您使用8.5。

    打赏 评论
  • devmiao 2017-11-30 16:32
    打赏 评论
  • COCO_AS 2017-12-01 00:54

    类没有找到,试试在项目里增加依赖jar包

     <!-- https://mvnrepository.com/artifact/javax.xml.ws/jaxws-api -->
    <dependency>
        <groupId>javax.xml.ws</groupId>
        <artifactId>jaxws-api</artifactId>
        <version>2.3.0</version>
    </dependency>
    
    
    打赏 评论
  • D1208 2017-12-01 01:25

    把jdk版本和eclipse版本换成最新的试试

    打赏 评论
  • 建议检查下开发工具的版本和jdk和tomcat的版本是否匹配,同是还有tomcat包是否正常引入

    打赏 评论
  • qq_38350986 2017-12-01 13:57

    把jdk换成1.8(原1.9),tomcat换成8.5(原9.0)解决了,谢谢大家

    打赏 评论

相关推荐 更多相似问题