思科交换实验(MSTP+HSRP)

图片说明

拓扑如上图,IOU1和2是三层交换机,3和4是二层交换机。

配置完之后IOU1和2的HSRP都是ACTIVE状态,重启后直接INIT起不来了,详细配置如下,求大神解答~

IOU1:

hostname IOU1
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!
ip cef
!

!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ccnp
instance 1 vlan 10
instance 2 vlan 20
!
spanning-tree mst 1 priority 24576
spanning-tree mst 2 priority 28672
!
!
!
!
!
!
vlan internal allocation policy ascending
!

ip tcp synwait-time 5
!
track 1 interface Ethernet0/0 line-protocol
!
!
!
!
interface Ethernet0/0
no switchport
ip address 12.1.1.1 255.255.255.0
!
interface Ethernet0/1
no switchport
ip address 14.1.1.1 255.255.255.0
!
interface Ethernet0/2
no switchport
ip address 13.1.1.1 255.255.255.0
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!

interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.10 255.255.255.0
standby 10 ip 192.168.1.254
standby 10 priority 105
standby 10 preempt
standby 10 authentication ccnp
standby 10 track 1 decrement 10
standby 20 track 1 decrement 10
!
interface Vlan20
ip address 192.168.2.20 255.255.255.0
standby 10 track 1 decrement 10
standby 20 ip 192.168.2.254
standby 20 preempt
standby 20 authentication ccnp
standby 20 track 1 decrement 10
!
router rip
network 12.0.0.0
network 13.0.0.0
network 14.0.0.0
!
!
!
no ip http server
!

IOU2:

hostname IOU2
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!

ip cef
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ccnp
instance 1 vlan 10
instance 2 vlan 20
!
spanning-tree mst 1 priority 28672
spanning-tree mst 2 priority 24576
!
!
!
!
!
!

vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
track 1 interface Ethernet0/0 line-protocol
!
track 2 interface Ethernet0/0 line-protocol
!
!
!
!
interface Ethernet0/0
no switchport
ip address 12.1.1.2 255.255.255.0
!
interface Ethernet0/1
no switchport
ip address 24.1.1.2 255.255.255.0
!
interface Ethernet0/2
no switchport
ip address 23.1.1.2 255.255.255.0
!

interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.11 255.255.255.0
standby 10 ip 192.168.1.254
standby 10 preempt
standby 10 authentication ccnp
standby 10 track 1 decrement 10
standby 10 track 2 decrement 10
standby 20 track 1 decrement 10
standby 20 track 2 decrement 10
!
interface Vlan20
ip address 192.168.2.21 255.255.255.0
standby 10 track 1 decrement 10
standby 10 track 2 decrement 10
standby 20 ip 192.168.2.254
standby 20 priority 105
standby 20 preempt
standby 20 authentication ccnp
standby 20 track 1 decrement 10
standby 20 track 2 decrement 10
!
router rip
network 12.0.0.0
network 13.0.0.0
network 14.0.0.0
!

!
!
no ip http server

IOU3:

hostname IOU3
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!

ip cef
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ccnp
instance 1 vlan 10
instance 2 vlan 20
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!

ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
no switchport
ip address 13.1.1.3 255.255.255.0
!
interface Ethernet0/1
no switchport
ip address 23.1.1.3 255.255.255.0
!
interface Ethernet0/2
switchport access vlan 10
switchport mode access
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 13.0.0.0
network 23.0.0.0
!
!
!
no ip http server

IOU4:

hostname IOU4
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
no ip icmp rate-limit unreachable
!

ip cef
!
!
no ip domain-lookup
no ipv6 cef
ipv6 multicast rpf use-bgp
!
spanning-tree mode mst
spanning-tree extend system-id
!
spanning-tree mst configuration
name ccnp
instance 1 vlan 10
instance 2 vlan 20
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!

ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
no switchport
ip address 24.1.1.4 255.255.255.0
!
interface Ethernet0/1
no switchport
ip address 14.1.1.4 255.255.255.0
!
interface Ethernet0/2
switchport access vlan 20
switchport mode access
duplex auto
!
interface Ethernet0/3
duplex auto
!
interface Ethernet1/0
duplex auto
!
interface Ethernet1/1
duplex auto
!
interface Ethernet1/2
duplex auto
!
interface Ethernet1/3
duplex auto
!
interface Ethernet2/0
duplex auto
!
interface Ethernet2/1
duplex auto
!
interface Ethernet2/2
duplex auto
!
interface Ethernet2/3
duplex auto
!
interface Ethernet3/0
duplex auto
!
interface Ethernet3/1
duplex auto
!
interface Ethernet3/2
duplex auto
!
interface Ethernet3/3
duplex auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 14.0.0.0
network 24.0.0.0
!
!
!
no ip http server

1个回答

你在重启之前保存了么?我感觉你的配置文件没问题。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
思科交换实验(MSTP+HSRP)

![图片说明](https://img-ask.csdn.net/upload/201712/01/1512138504_325004.png) 拓扑如上图,IOU1和2是三层交换机,3和4是二层交换机。 配置完之后IOU1和2的HSRP都是ACTIVE状态,重启后直接INIT起不来了,详细配置如下,求大神解答~ # IOU1: hostname IOU1 ! boot-start-marker boot-end-marker ! ! logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL logging buffered 50000 logging console discriminator EXCESS ! no aaa new-model no ip icmp rate-limit unreachable ! ip cef ! ! no ip domain-lookup no ipv6 cef ipv6 multicast rpf use-bgp ! spanning-tree mode mst spanning-tree extend system-id ! spanning-tree mst configuration name ccnp instance 1 vlan 10 instance 2 vlan 20 ! spanning-tree mst 1 priority 24576 spanning-tree mst 2 priority 28672 ! ! ! ! ! ! vlan internal allocation policy ascending ! ip tcp synwait-time 5 ! track 1 interface Ethernet0/0 line-protocol ! ! ! ! interface Ethernet0/0 no switchport ip address 12.1.1.1 255.255.255.0 ! interface Ethernet0/1 no switchport ip address 14.1.1.1 255.255.255.0 ! interface Ethernet0/2 no switchport ip address 13.1.1.1 255.255.255.0 ! interface Ethernet0/3 duplex auto ! interface Ethernet1/0 duplex auto ! interface Ethernet1/1 duplex auto ! interface Ethernet1/2 duplex auto ! interface Ethernet1/3 duplex auto ! interface Ethernet2/0 duplex auto ! interface Ethernet2/1 duplex auto ! interface Ethernet2/2 duplex auto ! interface Ethernet2/3 duplex auto ! interface Ethernet3/0 duplex auto ! interface Ethernet3/1 duplex auto ! interface Ethernet3/2 duplex auto ! interface Ethernet3/3 duplex auto ! interface Vlan1 no ip address shutdown ! interface Vlan10 ip address 192.168.1.10 255.255.255.0 standby 10 ip 192.168.1.254 standby 10 priority 105 standby 10 preempt standby 10 authentication ccnp standby 10 track 1 decrement 10 standby 20 track 1 decrement 10 ! interface Vlan20 ip address 192.168.2.20 255.255.255.0 standby 10 track 1 decrement 10 standby 20 ip 192.168.2.254 standby 20 preempt standby 20 authentication ccnp standby 20 track 1 decrement 10 ! router rip network 12.0.0.0 network 13.0.0.0 network 14.0.0.0 ! ! ! no ip http server ! # IOU2: hostname IOU2 ! boot-start-marker boot-end-marker ! ! logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL logging buffered 50000 logging console discriminator EXCESS ! no aaa new-model no ip icmp rate-limit unreachable ! ip cef ! ! no ip domain-lookup no ipv6 cef ipv6 multicast rpf use-bgp ! spanning-tree mode mst spanning-tree extend system-id ! spanning-tree mst configuration name ccnp instance 1 vlan 10 instance 2 vlan 20 ! spanning-tree mst 1 priority 28672 spanning-tree mst 2 priority 24576 ! ! ! ! ! ! vlan internal allocation policy ascending ! ip tcp synwait-time 5 ! track 1 interface Ethernet0/0 line-protocol ! track 2 interface Ethernet0/0 line-protocol ! ! ! ! interface Ethernet0/0 no switchport ip address 12.1.1.2 255.255.255.0 ! interface Ethernet0/1 no switchport ip address 24.1.1.2 255.255.255.0 ! interface Ethernet0/2 no switchport ip address 23.1.1.2 255.255.255.0 ! interface Ethernet0/3 duplex auto ! interface Ethernet1/0 duplex auto ! interface Ethernet1/1 duplex auto ! interface Ethernet1/2 duplex auto ! interface Ethernet1/3 duplex auto ! interface Ethernet2/0 duplex auto ! interface Ethernet2/1 duplex auto ! interface Ethernet2/2 duplex auto ! interface Ethernet2/3 duplex auto ! interface Ethernet3/0 duplex auto ! interface Ethernet3/1 duplex auto ! interface Ethernet3/2 duplex auto ! interface Ethernet3/3 duplex auto ! interface Vlan1 no ip address shutdown ! interface Vlan10 ip address 192.168.1.11 255.255.255.0 standby 10 ip 192.168.1.254 standby 10 preempt standby 10 authentication ccnp standby 10 track 1 decrement 10 standby 10 track 2 decrement 10 standby 20 track 1 decrement 10 standby 20 track 2 decrement 10 ! interface Vlan20 ip address 192.168.2.21 255.255.255.0 standby 10 track 1 decrement 10 standby 10 track 2 decrement 10 standby 20 ip 192.168.2.254 standby 20 priority 105 standby 20 preempt standby 20 authentication ccnp standby 20 track 1 decrement 10 standby 20 track 2 decrement 10 ! router rip network 12.0.0.0 network 13.0.0.0 network 14.0.0.0 ! ! ! no ip http server # IOU3: hostname IOU3 ! boot-start-marker boot-end-marker ! ! logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL logging buffered 50000 logging console discriminator EXCESS ! no aaa new-model no ip icmp rate-limit unreachable ! ip cef ! ! no ip domain-lookup no ipv6 cef ipv6 multicast rpf use-bgp ! spanning-tree mode mst spanning-tree extend system-id ! spanning-tree mst configuration name ccnp instance 1 vlan 10 instance 2 vlan 20 ! ! ! ! ! ! ! vlan internal allocation policy ascending ! ip tcp synwait-time 5 ! ! ! ! interface Ethernet0/0 no switchport ip address 13.1.1.3 255.255.255.0 ! interface Ethernet0/1 no switchport ip address 23.1.1.3 255.255.255.0 ! interface Ethernet0/2 switchport access vlan 10 switchport mode access duplex auto ! interface Ethernet0/3 duplex auto ! interface Ethernet1/0 duplex auto ! interface Ethernet1/1 duplex auto ! interface Ethernet1/2 duplex auto ! interface Ethernet1/3 duplex auto ! interface Ethernet2/0 duplex auto ! interface Ethernet2/1 duplex auto ! interface Ethernet2/2 duplex auto ! interface Ethernet2/3 duplex auto ! interface Ethernet3/0 duplex auto ! interface Ethernet3/1 duplex auto ! interface Ethernet3/2 duplex auto ! interface Ethernet3/3 duplex auto ! interface Vlan1 no ip address shutdown ! router rip network 13.0.0.0 network 23.0.0.0 ! ! ! no ip http server # IOU4: hostname IOU4 ! boot-start-marker boot-end-marker ! ! logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL logging buffered 50000 logging console discriminator EXCESS ! no aaa new-model no ip icmp rate-limit unreachable ! ip cef ! ! no ip domain-lookup no ipv6 cef ipv6 multicast rpf use-bgp ! spanning-tree mode mst spanning-tree extend system-id ! spanning-tree mst configuration name ccnp instance 1 vlan 10 instance 2 vlan 20 ! ! ! ! ! ! ! vlan internal allocation policy ascending ! ip tcp synwait-time 5 ! ! ! ! interface Ethernet0/0 no switchport ip address 24.1.1.4 255.255.255.0 ! interface Ethernet0/1 no switchport ip address 14.1.1.4 255.255.255.0 ! interface Ethernet0/2 switchport access vlan 20 switchport mode access duplex auto ! interface Ethernet0/3 duplex auto ! interface Ethernet1/0 duplex auto ! interface Ethernet1/1 duplex auto ! interface Ethernet1/2 duplex auto ! interface Ethernet1/3 duplex auto ! interface Ethernet2/0 duplex auto ! interface Ethernet2/1 duplex auto ! interface Ethernet2/2 duplex auto ! interface Ethernet2/3 duplex auto ! interface Ethernet3/0 duplex auto ! interface Ethernet3/1 duplex auto ! interface Ethernet3/2 duplex auto ! interface Ethernet3/3 duplex auto ! interface Vlan1 no ip address shutdown ! router rip network 14.0.0.0 network 24.0.0.0 ! ! ! no ip http server

RPR和MPLS技术以及MSTP的仿真问题

这个MSTP仿真用华为模拟器仿真的话,怎么操作,以前没接触过华为模拟器。求大神们支点招。感激不尽。

H3C MSR 3620 双wan口接入配置问题,盼解答!

单位目前使用100M光纤接入G1口,内部一个192.168.1.1网段,有几个应用web服务器供内部访问 由于集团要求,现接入MSTP专线,准备接入G2口,集团规划网段10.33.10.0网段,需要通过专线访问特定应用系统和网站 专线本端地址为IP1,集团端为IP2,子网掩码255.255.255.248 已提供集团的DNS 需求: 1、单位办公电脑需要既能访问Internet外网,也能通过专线访问集团系统 但希望访问外网是走G1口,访问集团特定系统走G2口,路由器如何设置,G2口增加本端地址和掩码?还需加策略路由?怎 么加? 2、 原客户端计算机ip地址如何设置,使之满足仍能访问192.168.1.0网段的web服务器,并且能根据需要访问外网或专线 需要修改IP地址,如何修改? 如原ipv4设置192.168.1.X,是否要在高级添加10.33.10.X地址? 还是把ipv4设置成10.33.10.X,再在高级里面添加192.168.1.X?

华为交换机2318 cpu bcmRX 利用率16%

开启vlan2 后交换机设置的地址ping vlan2 网关 延时130nm左右,cpu 利用率16% , 交换机告警: <JiKe2318_nan>dis cpu-usage [Unit 0] CPU Usage Stat. Cycle: 5 (Second) CPU Usage : 24% Max: 100% CPU Usage Stat. Time : 2020-03-27 15:52:59 CPU Usage Stat. Tick : 0xf74(CPU Tick High) 0x570a594f(CPU Tick Low) Actual Stat. Cycle : 0x0(CPU Tick High) 0x1dd368fa(CPU Tick Low) TaskName CPU Runtime(CPU Tick High/CPU Tick Low) BUFM 0% 0/ bbbde VIDL 76% 0/15538d45 TICK 0% 0/ 390140 IPCQ 0% 0/ 17645 RPCQ 0% 0/ 17af4 VFS 0% 0/ 13cc STND 0% 0/ 1f1bc bcmDPC 2% 0/ b19f80 tCOU 0% 0/ 28ca93 bcmTX 0% 0/ 6beae multiAsyncTX 0% 0/ dcebd bcmRX 14% 0/ 4329ba5 vt0 0% 0/ 437964 INFO 0% 0/ 1a89 SRM 1% 0/ 825b37 L2IF 0% 0/ 42739 FIB6 0% 0/ d70f ROUT 1% 0/ 515a1a SNPG 0% 0/ 6ac9 LLDP 0% 0/ 39fb DH1 0% 0/ 6634 SOCK 2% 0/ dc3e43 VTYD 0% 0/ 52103 LBDT 0% 0/ 6cd20 TRAP 0% 0/ 16ad38 TRUN 0% 0/ 16d538 NTPT 0% 0/ 20416d AUTH 0% 0/ 182 EAP 0% 0/ 5f99 MACA 0% 0/ 2b4f TAC 0% 0/ 68f93 MSTP 0% 0/ 4f18 WEBS 0% 0/ 1f378f SRMT 1% 0/ 5eb16a CLST 0% 0/ eeafa NTDP 0% 0/ 2645dd NDP 0% 0/ 67d1d RMON 0% 0/ 4ff0 OS 3% 0/ 0 dis log Logging buffer configuration and contents:enabled Allowed max buffer size : 1024 Actual buffer size : 512 Channel number : 4 , Channel name : logbuffer Dropped messages : 0 Overwritten messages : 0 Current messages : 181 Mar 27 2020 15:32:13 JiKe2318_nan %%01SEC/4/ATCKDF(l): AttackType:Land attack; Receive IfIndex: Vlanif200 ; from ; to ; begin time :2020/03/27 15:31:53; end time: 2020/03/27 15:31:53; total packets: 1; Mar 27 2020 15:22:13 JiKe2318_nan %%01CFM/4/SAVE(l): When deciding whether to save configuration to the device, the user chose Y. Aug 6 2008 17:12:19 JiKe2318_nan %%01SEC/4/ATCKDF(l): AttackType:Land attack; Receive IfIndex: Vlanif200 ; from ; to ; begin time :2008/08/06 17:12:02; end time: 2008/08/06 17:12:02; total packets: 1;

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

程序员请照顾好自己,周末病魔差点一套带走我。

程序员在一个周末的时间,得了重病,差点当场去世,还好及时挽救回来了。

C++(数据结构与算法)78:---分而治之

一、分而治之的思想 分而治之方法与软件设计的模块化方法非常相似 分而治之通常不用于解决问题的小实例,而要解决一个问题的大实例。一般步骤为: ①把一个大实例分为两个或多个更小的实例 ②分别解决每个小实例 ③把这些小实例的解组合成原始大实例的解 二、实际应用之找出假币 问题描述 一个袋子有16个硬币,其中只有一个是假币,这个假币比其他的真币重量轻(其他所有真币的重量都是相同的)...

springboot+jwt实现token登陆权限认证

一 前言 此篇文章的内容也是学习不久,终于到周末有时间码一篇文章分享知识追寻者的粉丝们,学完本篇文章,读者将对token类的登陆认证流程有个全面的了解,可以动态搭建自己的登陆认证过程;对小项目而已是个轻量级的认证机制,符合开发需求;更多精彩原创内容关注公主号知识追寻者,读者的肯定,就是对作者的创作的最大支持; 二 jwt实现登陆认证流程 用户使用账号和面发出post请求 服务器接受到请求后使用私...

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

win10暴力查看wifi密码

刚才邻居打了个电话说:喂小灰,你家wifi的密码是多少,我怎么连不上了。 我。。。 我也忘了哎,就找到了一个好办法,分享给大家: 第一种情况:已经连接上的wifi,怎么知道密码? 打开:控制面板\网络和 Internet\网络连接 然后右击wifi连接的无线网卡,选择状态 然后像下图一样: 第二种情况:前提是我不知道啊,但是我以前知道密码。 此时可以利用dos命令了 1、利用netsh wlan...

女程序员,为什么比男程序员少???

昨天看到一档综艺节目,讨论了两个话题:(1)中国学生的数学成绩,平均下来看,会比国外好?为什么?(2)男生的数学成绩,平均下来看,会比女生好?为什么?同时,我又联想到了一个技术圈经常讨...

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

MySQL数据库面试题(2020最新版)

文章目录数据库基础知识为什么要使用数据库什么是SQL?什么是MySQL?数据库三大范式是什么mysql有关权限的表都有哪几个MySQL的binlog有有几种录入格式?分别有什么区别?数据类型mysql有哪些数据类型引擎MySQL存储引擎MyISAM与InnoDB区别MyISAM索引与InnoDB索引的区别?InnoDB引擎的4大特性存储引擎选择索引什么是索引?索引有哪些优缺点?索引使用场景(重点)...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

程序员写出这样的代码,能不挨骂吗?

当你换槽填坑时,面对一个新的环境。能够快速熟练,上手实现业务需求是关键。但是,哪些因素会影响你快速上手呢?是原有代码写的不够好?还是注释写的不够好?昨夜...

带了6个月的徒弟当了面试官,而身为高级工程师的我天天修Bug......

即将毕业的应届毕业生一枚,现在只拿到了两家offer,但最近听到一些消息,其中一个offer,我这个组据说客户很少,很有可能整组被裁掉。 想问大家: 如果我刚入职这个组就被裁了怎么办呢? 大家都是什么时候知道自己要被裁了的? 面试软技能指导: BQ/Project/Resume 试听内容: 除了刷题,还有哪些技能是拿到offer不可或缺的要素 如何提升面试软实力:简历, 行为面试,沟通能...

优雅的替换if-else语句

场景 日常开发,if-else语句写的不少吧??当逻辑分支非常多的时候,if-else套了一层又一层,虽然业务功能倒是实现了,但是看起来是真的很不优雅,尤其是对于我这种有强迫症的程序"猿",看到这么多if-else,脑袋瓜子就嗡嗡的,总想着解锁新姿势:干掉过多的if-else!!!本文将介绍三板斧手段: 优先判断条件,条件不满足的,逻辑及时中断返回; 采用策略模式+工厂模式; 结合注解,锦...

!大部分程序员只会写3年代码

如果世界上都是这种不思进取的软件公司,那别说大部分程序员只会写 3 年代码,恐怕就没有程序员这种职业。

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

2020阿里全球数学大赛:3万名高手、4道题、2天2夜未交卷

阿里巴巴全球数学竞赛( Alibaba Global Mathematics Competition)由马云发起,由中国科学技术协会、阿里巴巴基金会、阿里巴巴达摩院共同举办。大赛不设报名门槛,全世界爱好数学的人都可参与,不论是否出身数学专业、是否投身数学研究。 2020年阿里巴巴达摩院邀请北京大学、剑桥大学、浙江大学等高校的顶尖数学教师组建了出题组。中科院院士、美国艺术与科学院院士、北京国际数学...

为什么你不想学习?只想玩?人是如何一步一步废掉的

不知道是不是只有我这样子,还是你们也有过类似的经历。 上学的时候总有很多光辉历史,学年名列前茅,或者单科目大佬,但是虽然慢慢地长大了,你开始懈怠了,开始废掉了。。。 什么?你说不知道具体的情况是怎么样的? 我来告诉你: 你常常潜意识里或者心理觉得,自己真正的生活或者奋斗还没有开始。总是幻想着自己还拥有大把时间,还有无限的可能,自己还能逆风翻盘,只不是自己还没开始罢了,自己以后肯定会变得特别厉害...

男生更看重女生的身材脸蛋,还是思想?

往往,我们看不进去大段大段的逻辑。深刻的哲理,往往短而精悍,一阵见血。问:产品经理挺漂亮的,有点心动,但不知道合不合得来。男生更看重女生的身材脸蛋,还是...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

早上躺尸,晚上干活:硅谷科技公司这么流行迟到?

硅谷科技公司上班时间OPEN早已不是什么新鲜事,早九晚五是常态,但有很多企业由于不打卡,员工们10点、11点才“姗姗来迟”的情况也屡见不鲜。 这种灵活的考勤制度为人羡慕,甚至近年来,国内某些互联网企业也纷纷效仿。不过,硅谷普遍弹性的上班制度是怎么由来的呢?这种“流行性迟到”真的有那么轻松、悠哉吗? 《动态规划专题班》 课程试听内容: 动态规划的解题要领 动态规划三大类 求最值/计数/可行性 常...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

Python爬虫,高清美图我全都要(彼岸桌面壁纸)

爬取彼岸桌面网站较为简单,用到了requests、lxml、Beautiful Soup4

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

Java岗开发3年,公司临时抽查算法,离职后这几题我记一辈子

前几天我们公司做了一件蠢事,非常非常愚蠢的事情。我原以为从学校出来之后,除了找工作有测试外,不会有任何与考试有关的事儿。 但是,天有不测风云,公司技术总监、人事总监两位大佬突然降临到我们事业线,叫上我老大,给我们组织了一场别开生面的“考试”。 那是一个风和日丽的下午,我翘着二郎腿,左手端着一杯卡布奇诺,右手抓着我的罗技鼠标,滚动着轮轴,穿梭在头条热点之间。 “淡黄的长裙~蓬松的头发...

大牛都会用的IDEA调试技巧!!!

导读 前天面试了一个985高校的实习生,问了他平时用什么开发工具,他想也没想的说IDEA,于是我抛砖引玉的问了一下IDEA的调试用过吧,你说说怎么设置断点...

都前后端分离了,咱就别做页面跳转了!统统 JSON 交互

文章目录1. 无状态登录1.1 什么是有状态1.2 什么是无状态1.3 如何实现无状态1.4 各自优缺点2. 登录交互2.1 前后端分离的数据交互2.2 登录成功2.3 登录失败3. 未认证处理方案4. 注销登录 这是本系列的第四篇,有小伙伴找不到之前文章,松哥给大家列一个索引出来: 挖一个大坑,Spring Security 开搞! 松哥手把手带你入门 Spring Security,别再问密...

面试官:你连SSO都不懂,就别来面试了

大厂竟然要考我SSO,卧槽。

终于,月薪过5万了!

来看几个问题想不想月薪超过5万?想不想进入公司架构组?想不想成为项目组的负责人?想不想成为spring的高手,超越99%的对手?那么本文内容是你必须要掌握的。本文主要详解bean的生命...

自从喜欢上了B站这12个UP主,我越来越觉得自己是个废柴了!

不怕告诉你,我自从喜欢上了这12个UP主,哔哩哔哩成为了我手机上最耗电的软件,几乎每天都会看,可是吧,看的越多,我就越觉得自己是个废柴,唉,老天不公啊,不信你看看…… 间接性踌躇满志,持续性混吃等死,都是因为你们……但是,自己的学习力在慢慢变强,这是不容忽视的,推荐给你们! 都说B站是个宝,可是有人不会挖啊,没事,今天咱挖好的送你一箩筐,首先啊,我在B站上最喜欢看这个家伙的视频了,为啥 ,咱撇...

代码注释如此沙雕,会玩还是你们程序员!

某站后端代码被“开源”,同时刷遍全网的,还有代码里的那些神注释。 我们这才知道,原来程序员个个都是段子手;这么多年来,我们也走过了他们的无数套路… 首先,产品经理,是永远永远吐槽不完的!网友的评论也非常扎心,说看这些代码就像在阅读程序员的日记,每一页都写满了对产品经理的恨。 然后,也要发出直击灵魂的质问:你是尊贵的付费大会员吗? 这不禁让人想起之前某音乐app的穷逼Vip,果然,穷逼在哪里都是...

前端还能这么玩?(女朋友生日,用前端写了一个好玩的送给了她,高兴坏了)

前端还能这么玩?(女朋友生日,用前端写了一个好玩的送给了她,高兴坏了)

爬虫(101)爬点重口味的

小弟最近在学校无聊的很哪,浏览网页突然看到一张图片,都快流鼻血。。。然后小弟冥思苦想,得干一点有趣的事情python 爬虫库安装https://s.taobao.com/api?_ks...

在拼多多上班,是一种什么样的体验?我心态崩了呀!

之前有很多读者咨询我:武哥,在拼多多上班是一种什么样的体验?由于一直很忙,没抽出时间来和大家分享。上周末特地花点时间来写了一篇文章,跟大家分享一下拼多多的日常。 1. 倒时差的作息 可能很多小伙伴都听说了,拼多多加班很严重。这怎么说呢?作息上确实和其他公司有点区别,大家知道 996,那么自然也就能理解拼多多的“11 11 6”了。 所以当很多小伙伴早上出门时,他们是这样的: 我们是这样的: 当...

应聘3万的职位,有必要这么刁难我么。。。沙雕。。。

又一次被面试官带到坑里面了。面试官:springmvc用过么?我:用过啊,经常用呢面试官:springmvc中为什么需要用父子容器?我:嗯。。。没听明白你说的什么。面试官:就是contr...

太狠了,疫情期间面试,一个问题砍了我5000!

疫情期间找工作确实有点难度,想拿到满意的薪资,确实要点实力啊!面试官:Spring中的@Value用过么,介绍一下我:@Value可以标注在字段上面,可以将外部配置文件中的数据,比如可以...

从联想昭阳到MacBook Pro,致我的那些败家玩意——电脑

对于程序员来说,你懂的,电脑就是我们的女朋友,在很多层面上,它都是,打游戏、敲代码,以及看影片。 我第一台电脑是联想的笔记本(昭阳系列),花了 4000 多块买的。 那时候,家里很是缺钱,4000 多块可不是小数目。后来听父母说是他们忙活了两个多月,摘辣椒卖的钱。这还没算上插苗浇水除草的人力成本。可惜这台笔记本被偷了——小偷真特么无情,我真特么败家。 这台笔记本陪伴我的时间非常短暂,也就是从洛阳...

自学编程的 6 个致命误区

嗨,小伙伴们大家好,我是沉默王二。本篇文章来和大家聊聊自学编程中的一些误区——这是我在 B 站上看了羊哥的一期视频后有感而发的文章。因为确实有很多读者也曾私信问过我这些方面的问题,很有代表性,所以我就结合自己的亲身体会来谈一谈,希望对小伙伴们有所启发。 01、追求时髦 所谓基础不牢,地动山摇啊。可很多小伙伴压根就没注意过这个问题,市面上出什么新鲜的技术就想去尝试,结果把自己学的乱七八糟,心灰意冷...

小姐姐手机被偷后发朋友圈,结果…

事情的经过是这样的前些天上午,我正在开心的刷朋友圈看到了我们公司的HR小姐姐悲伤地宣布她的手机被偷了作为吃瓜同事我也没太在意继续愉快的刷朋友圈直到晚上小姐姐又更新了一条朋友圈不对啊瓜再这...

你离黑客的距离,就差这20个神器了

郑重声明:本文仅限技术交流,不得用于从事非法活动 在不少电影电视剧中,主角的身边都有这么一位电脑高手:他们分分钟可以黑进反派的网络,攻破安全防线,破解口令密码,拿到重要文件。他们的电脑屏幕上都是一些看不懂的图形和数字,你能看懂的就只有那个进度条,伴随着紧张的BGM,慢慢的向100%靠近······ 上面的场景和套路是不是很眼熟? 影视作品中的黑客当然有夸张和戏剧化的表现,不过,现实世界中的黑客也...

2020年5月中国编程语言排行榜

编程语言比例 排名 编程语言 平均工资 工资中位数 最低工资 最高工资 人头 人头百分比 1 scala 20165 18000 7000 45000 3309 0.71% 2 rust 19364 17500 5398 43687 483 0.10% 3 python 18622 17500 6500 45000 36531 7.81% 4 julia 18455 ...

立即提问
相关内容推荐