新手求助Android studio问题 5C

could not find any version that matches com.android.support:appcompat-v7:27.+是什么错误

10个回答

你这个gradle下载包,没下载成功了把,

用ali的gradle地址试试

可能是sdk环境没配好,又或者sdk版本不对

android sdk 版本的问题吧

你看看.gradle里的版本号是否跟你的Android Studio版本号对应。

查看你的buildToolsVersion 这个是不能超过那个版本号的 可以随便找一个

例如版本号是 26 那可以用compile 'com.android.support:appcompat-v7:26.+'

找不到支持库。在Android SDK Manager中安装

你应该是直接copy的代码吧,看下你自己有的SDK版本,或者在你项目结构里面看看主程序依赖的版本,
然后在代码里把关于com.android.support:appcompat-v7:27的换过去

应该是sdk 版本的问题

你的v7包没有27+的,找一个你有的版本修改一下

android支持库未安装,编译不过,在Android SDK Manager中安装即可

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问