返克
2017-12-29 07:24
采纳率: 66.7%
浏览 3.2k
已采纳

eclipse启动时报错,求解决方法

网上解决的方法我都试了下,还是不行!![![图片说明](https://img-ask.csdn.net/upload/201712/29/1514532222_580505.png)图片说明](https://img-ask.csdn.net/upload/201712/29/1514532204_873316.png)图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

48条回答 默认 最新

  • 猫先生9527 2017-12-29 07:31
    已采纳

    换个1.8的JDK再试试

    点赞 评论
  • 向阳居士 2017-12-29 07:27

    jdk的版本太低了,最少要1.8的

    点赞 评论
  • xinganbaby 2017-12-29 07:31

    jdk版本太低,卸载,重装下1.8的

    点赞 评论
  • 江枫月晚 2017-12-29 07:32

    jvm的1.7.0_75版本不适合这个产品版本:需要1.8或更高版本

    点赞 评论
  • qq_40685462 2017-12-29 07:39

    也可以重新下载一个eclipse 下载一个luna版本或者mars版本的

    点赞 评论
  • 更好的自己520 2017-12-29 07:40

    Version 1.7.0_75 of the JVM is not suitable for this product.Version:1.8 or greater is required,看懂这句话就知道错误在哪啦? java虚拟机版本1.7.0_75 不合适项目,版本1.8或更高的才合适

    点赞 评论
  • 直接再安装一个jdk1.8就可以了,不卸载也没关系

    点赞 评论
  • u010934975 2017-12-29 07:41

    下载最新的JDK安装

    点赞 评论
  • 老飞pfy 2017-12-29 07:41

    要么换个高版本的jdk,要么换个低版本的eclipse

    点赞 评论
  • eternitylizw 2017-12-29 07:54

    换1.8的jdk,并且jdk和eclipse版本一致,都是32或64

    点赞 评论
  • Lishyer 2017-12-29 07:57

    重新下载个1.8版本的 直接安装 覆盖掉之前的就可以了

    点赞 评论
  • 向阳居士 2017-12-29 08:02

    1.再另找个路径安装jdk1.8,将环境变量改一下,指向1.8的。
    2.换一个eclipse的安装包,找个版本低一点能用jdk1.7的eclipse安装。

    点赞 评论
  • 旋转的钢笔 2017-12-29 08:08

    你这个eclipse是新版的吧? 老版本的支持1.7,新版的只能重新安装jdk1.8,环境变量更改下就可以了

    点赞 评论
  • weixin_41368177 2017-12-29 08:17

    你这两个版本不一样,要换成一样的版本

    点赞 评论
  • Yu_yangfeng 2017-12-29 08:22

    mar2以后的eclipse都要求JDK1.8

    点赞 评论
  • qq_20076823 2017-12-29 08:23

    eclipse绑定的是jdk1.8 本地安装的是1.7 换1.8试试

    点赞 评论
  • 小星宇 2017-12-29 08:47

    重新下载一个1.8的就可以了

    点赞 评论
  • 丶等到烟火清凉 2017-12-29 09:03
    点赞 评论
  • 斌哥哥之初出茅庐 2017-12-29 09:35

    重新下载个1.8版本的jdk 直接安装,修改 eclipse中eclipse.ini 这个文件的jdk路径就行了,这个代表初始启动时去该路径下找jdk,还是值得学习下哦,老司机经验

    点赞 评论
  • 野火1020149932 2017-12-29 10:52

    查看是否有jdk1.8版本,如果没有需要安装一个,如果有的话选择使用1.8版本

    点赞 评论
  • zy5756 2017-12-29 12:21

    按提示换个高版本的即可,你有软件版本高,JDK版本低导致

    点赞 评论
  • 优萌科技 2017-12-29 12:26
    1. eclipse.ini中相关参数内存设置过大
      把Xmx512m 改为 Xmx256m, 减少内存分配----------(我就是使用此种方法解决的本次故障)

    2. 重装JDK

    3. 检查设置的环境变量

    4. jdk版本不正确
      要求的版本是1.5,你装的jdk是1.6,最好重装一个更高版本的eclipse

    5.已经装了两个JRE
    根据需要删除

    1. 若发现弹出的对话框上的jvm.dll为jre中的 jvm.dll为jre6\bin\client\jvm.dll,应改为jdk目录下的jvm.dll(jdk\bin\client\jvm.dll)。

    需要如下修改:
    在eclipse.ini中添加或者更改 -vm c:program files\java\jre6\bin\client\jvm.dl

    点赞 评论
  • wangyunyu1998 2017-12-29 12:45

    JDK的版本太低了,要重新换一个试试看

    点赞 评论
  • Q544471255 2017-12-29 14:21

    升级一下jdk版本到1.8,记得要和eclipse的位数一致。

    点赞 评论
  • YX5337934887 2017-12-29 14:25

    eclipse oxygen 及以后的都只支持JDK 1.8

    点赞 评论
  • MossL 2017-12-30 01:30

    版本1.7.75的JVM不适合这种产品。版本需要1.8或更高版本。可以重新去下载更高版本

    点赞 评论
  • 晨曦朝露 2017-12-30 02:17

    更换Java环境变量然后命令行验证一下,是否改变了,因为有的系统默认会采用你最后一次安装的jdk版本作为Java环境变量的版本,如果不对就重装1.8的jdk

    点赞 评论
  • m0_37088025 2017-12-30 03:12

    jdk版本太低,卸载,下1.8的,重新安装jdk,注意环境变量重新配置一下,望采纳。图片说明

    点赞 评论
  • weixin_38851700 2017-12-30 07:10

    这个是要求你更新版本了,你是本机导入别处的project吧,别人用的版本可能高一些

    点赞 评论
  • 秋眯眯 2017-12-30 07:58

    你换一个高版本的SDK就可以了,应该是

    点赞 评论
  • vistoliu 2017-12-30 10:33

    换成高版本的jdk,或者换成低版本的eclipse

    点赞 评论
  • point_chen 2017-12-30 10:33

    要么换个高版本的jdk,要么换个低版本的eclipse

    点赞 评论
  • zwy12321 2017-12-31 04:49

    重新下一个jdk吧或者换个eclipse,可以找我

    点赞 评论
  • lilamei170607 2017-12-31 07:07

    安装也个1.8的jdk

    点赞 评论
  • qq_40366394 2017-12-31 13:58

    版本低了,换一个高点的,就如你的截图中所说,换到1.8或者更高的版本试一试或许能够解决你的问题,行为java和eclipse下载安装时要是对应的,不然版本不互相兼容

    点赞 评论
  • 大胖白兔 2018-01-01 04:29

    本机安装的jdk版本过低,升级到jdk1.8

    点赞 评论
  • 魏宏斌 2018-01-01 20:50

    两种方案,

    第一种:下载低版本Eclipse

    第二种:安装配置JDK1.8

    点赞 评论
  • 三狗子丶 2018-01-02 02:35

    卸了,重新安装一个jdk1.8,配置环境变量,再试试

    点赞 评论
  • Java批发 2018-01-02 11:17

    首先 jdk 工具 tomcat 这三个东西最好是一致 例如都64位

    点赞 评论
  • CN2014_000 2018-01-02 14:02

    jdk的问题,提示很明显啊

    点赞 评论
  • wllw6 2018-01-03 02:00

    重新安装jdk8,或者重新装eclipse

    点赞 评论
  • hissql 2018-01-03 02:36

    JDK1.7不适合,需要安装JDK1.8.安装完记得重新配置一下环境。如果你的Eclipse不能支持JDK1.8,那你还需要重新安装一个适合JDK1.8版本的Eclipse

    点赞 评论
  • Coral Gajic 2018-01-03 08:24

    eclipse与jdk版本不匹配,重新换一个eclipse版本

    点赞 评论
  • icecoola_ 2018-01-11 13:00

    提示很明显,技术这个东西要自己多专研,英文阅读能力也是必不可少的
    下载低版本Eclipse
    安装配置JDK1.8 或 更高版本

    点赞 评论
  • Devin9566 2018-01-18 06:41

    英文提示的很详细。就是说你的jvm的1.7._0_75版本不适合这个产品版本:需要1.8或更高版本。

    点赞 评论
  • 周慧雨 2018-02-25 08:10

    JDK版本太低了 换新的

    点赞 评论
  • alonelovely 2018-04-18 07:18

    JVM的版本和你eclipse的版本不匹配,重装高版本的JDK吧

    点赞 评论
  • LONGMA12 2018-07-13 07:44

    jdk版本太低了,换个高点的试试,修改eclispe.ini里的路径,指向高版本

    点赞 评论

相关推荐 更多相似问题