砖厂管理员
2018-01-09 12:40
采纳率: 50%
浏览 4.7k

Jquery 报 对象不支持“addEventListener”属性或方法 的错误

如题:
最近写了一下.Net的小东西,使用IE浏览器跑的时候,报了题述错误。
IE
很Gay的是在公司的台式机上不报这个错,在我的笔记本上就报错。
都是 IE 11。
大佬们知道的,教教我呀

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

7条回答 默认 最新

  • lxpfunny 2018-01-09 12:49
    已采纳

    ie切换成标准渲染模式,查一下如何切换。望采纳

    点赞 评论
  • CSDNRGY 2018-01-10 00:35

    我之前也遇到过这个问题
    不过当时需要兼容的是ie8
    于是乎我就从jQuery1.9切换成了jQuery1.8
    然后问题就解决了
    你可以按照我这个思路去试试

    点赞 1 评论
  • blownewbee 2018-01-09 12:44

    看看是不是有什么外部脚本没有加载进来(特别是网络环境不好)。导致某个标签对象为空,因为标签对象没有加载上,所以就提示不支持xxx方法。
    还有,清除下浏览器的缓存看看。

    点赞 评论
  • Andy_hyh 2018-01-09 12:55

    看下是否是 js冲突

    点赞 评论
  • 梦里能抱住风 2018-01-09 12:57

    有可能是ie版本不支持,换个谷歌

    点赞 评论
  • 砖厂管理员 2018-01-09 12:58

    我靠。。。

    我加了一句,果然可以了。
    那我想问一下,为什么同样的代码,同样的IE11 ,就是机器不同为啥会出现这种错误。

    点赞 评论
  • 无想无念 2021-07-16 16:02

    ··

    点赞 评论

相关推荐 更多相似问题