weixin_39648430
weixin_39648430
2021-01-09 04:31

LEDE support

Unfortunately, Snapclient does not compile under current LEDE (OpenWrt fork). The error I get is:

In file included from player/player.h:29:0, from player/alsaPlayer.h:22, from player/alsaPlayer.cpp:19: ../common/log.h:29:24: error: expected initializer before '<<' token

define logO std::clog << kOut

                   ^

In file included from ../common/strCompat.h:10:0, from player/alsaPlayer.cpp:22: /home/buildd/lede/staging_dir/toolchain-mips_24kc_gcc-5.4.0_musl-1.1.16/mips-openwrt-linux-musl/include/c++/5.4.0/cmath:353:11: error: '::log' has not been declared using ::log; ^ Makefile:74: recipe for target 'player/alsaPlayer.o' failed make[3]: *** [player/alsaPlayer.o] Error 1`

Is support for LEDE planned?

Or does anybody has a clue how to get around this error?

Thanks! Sven

该提问来源于开源项目:badaix/snapcast

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

8条回答