qq_39301152
Code1010
采纳率100%
2018-01-29 03:43

python pip安装总是失败

20
已采纳

最近在学爬虫 使用pip命令安装包总是失败
也上网查询了很多方法尝试 还是不行 所以来提问 希望得到回答
图片说明

就是那个红字 我在家里的台式机上就可以安装成功 笔记本怎么也不行 不知道为什么

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

18条回答

  • hdl277 hdl277 3年前

    你的bs版本弄错了,应该是 pip install beautifulsoup4
    错误提式为语法错误,print后面没有括号,这是python2的写法,很明显你是下错beautifulsoup的版本了。

    点赞 评论 复制链接分享
  • qq_21165007 SuperScfan 3年前

    1.Beautifulsoup官网:https://www.crummy.com/software/BeautifulSoup/
    官网说明:Beautiful Soup 3 works only under Python 2.x.
    确定python版本是否符合
    2.排除pip问题,用pip install xlrd 测试
    3.本地安装测试

    (env) [fdm@ES ~]$ pip install BeautifulSoup
    Collecting BeautifulSoup
      Downloading BeautifulSoup-3.2.1.tar.gz
    Building wheels for collected packages: BeautifulSoup
      Running setup.py bdist_wheel for BeautifulSoup ... done
      Stored in directory: /home/fdm/.cache/pip/wheels/5e/be/6d/ed01d5d434a821557b674c9da976f60b1b93d9009447eb9d16
    Successfully built BeautifulSoup
    Installing collected packages: BeautifulSoup
    Successfully installed BeautifulSoup-3.2.1
    
    (env) [fdm@ES ~]$ python -V
    Python 2.7.11
    
    点赞 1 评论 复制链接分享
  • BFInWR 虾米馅煎包 3年前

    这个错误显示是语法错误,那是因为你的Python环境是3.x的,你直接输入 beautifulsoup 它默认的版本是bs3, 所以你需要的命令行是 pip install beautifulsoup4。

    点赞 1 评论 复制链接分享
  • lkj_0000 lkj_0000 3年前

    其实python3安装beautifulsoup采用的是pip install bs4

    点赞 评论 复制链接分享
  • qq_21165007 SuperScfan 3年前

    Beautiful Soup 4 works on both Python 2 (2.7+) and Python 3.

    点赞 评论 复制链接分享
  • qiuhui00 qiuhui00 3年前

    python版本不匹配吧

    点赞 评论 复制链接分享
  • qq_33363973 清风不识字12138 3年前

    pip install beautifulsoup4
    或者在网上找到对应版本的 beautifulsoup库,下载下来后用python setup.py命令安装

    点赞 评论 复制链接分享
  • u010738823 九月北雪 3年前

    这个我遇到过,请重新安装python,选一个适合该库的python版本。

    点赞 评论 复制链接分享
  • mingyang_wang 一瓶果粒橙 3年前

    不知道上面给的回答是否解决了您的问题,还有一个情况就是更新一下pip,命令行:python -m pip install --upgrade pip 更新完pip之后再尝试安装一下,
    看是否能安装成功。

    点赞 评论 复制链接分享
  • qq_34727158 贝格逮塔 3年前

    可能::
    1:权限问题,尝试以管理员运行cmd, cmd在C:\Windows\System32下
    2:网络问题(爬梯,可能性不大)
    3:内存问题(可能性更小)
    4:版本兼容问题 比如Package是2.X的 可是你在3环境下操作
    解决办法:python看下版本 查一下package要求版本 确定版本无误后 管理员运行 可以私信我

    点赞 评论 复制链接分享
  • fenghui187 小鬼web 3年前

    试试看pip3 install

    点赞 评论 复制链接分享
  • qq_27206435 qq_27206435 3年前

    以管理员权限登录cmd,再行安装

    点赞 评论 复制链接分享
  • lymmm2 yo_law 3年前

    系统指定的python版本问题,可以在控制台输入python看看默认的版本是什么

    点赞 评论 复制链接分享
  • qq_36474649 qq_36474649 3年前

    可能存在多个python版本,建议python -V看下版本

    点赞 评论 复制链接分享
  • xiaohai3821 xiaohai3821 3年前

    你直接到那个目录下 cmd 然后pip install 。你安装了多个版本 环境变量不一样

    点赞 评论 复制链接分享
  • wning13 若时光倒转 3年前

    我猜你的python应该是3.x,可以试试pip install bs4

    点赞 评论 复制链接分享
  • u014576683 miniyet 3年前

    有可能是版本的问题 版本保持一致 或者更新python版本

    点赞 评论 复制链接分享
  • zanweb zanweb 3年前

    可能是版本问题,使用python安装目录下Scripts目录里的pip命令安装试试。

    点赞 评论 复制链接分享

相关推荐