Maven 集成jeecg jar包报错 5C

Maven集成jeecg jeecgframework 里的jar包全部有问题,删了加载好几遍了,没有用,版本也换了。大家帮忙看一看图片说明

4个回答

右键maven update project 然后重新改设置。不行就重装下再试吧。记得把validation得取消了。
具体原因我也不清楚。。

百度可以解决的,以前弄过的,可以

把这个文件目录删掉,pom.xml重新保存一下,会重新下载

qq_41756011
qq_41756011 回复lovelongm: 4人
一年多之前 回复
lovelongm
lovelongm 没有用,试过很多遍,工作区间和仓库也换过 ,下载下来的总是这样
一年多之前 回复

有依赖的jar可能会间接依赖该jar,导致跟你直接引用的jar冲突

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Maven集成oracle的jar包时报错问题解决
由于oracle是收费的,所以仅仅在pom.xml文件中配置上oracle驱动然后跟新maven项目是无法下载到jar包的,所以需要事先下载好oracle的jar包然后手动导入     在命令窗口中执行一下命令即可 ,如下:mvn install:install-file -DgroupId=com.oracle -DartifactId=ojdbc6 -Dversion=11.2.0.3 -Df...
maven集成dubbox报错
我已经把dubbox的包从git上下载下来了,而且也导入到项目里面了,但是项目打包却一直报找不到包rn[img=https://img-bbs.csdn.net/upload/201805/04/1525425767_799133.png][/img]
jeecg报错
jeecg启动报错“com.mysql.jdbc.exceptions.jdbc4.MySQLNonTransientConnectionException: Could not create connection to database server.” 解决方法:查看MySQL版本和jar包版本是否冲突。 修改后继续报错:java.sql.SQLException: The serve...
maven 添加jar包是报错
[img=https://img-bbs.csdn.net/upload/201605/24/1464102435_107328.png][/img]rnArtifactTransferException: Failure to transfer org.springframework:spring-context:jar:4.2.6.RELEASE from http://repo.maven.apache.org/maven2 was cached in the local rn repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced. Original error: Could not transfer artifact rn org.springframework:spring-context:jar:4.2.6.RELEASE from/to central (http://repo.maven.apache.org/maven2): No response received after 60000
【JEECG插件集成文档】JEECG在线聊天插件 - 集成文档
JEECG在线聊天插件附件 博文链接:https://jeecg.iteye.com/blog/2320670
JEECG 单点登录集成文档(kisso集成)
JEECG 开发文档系列 ——JEECG 单点登录集成文档(kisso集成)
maven集成jetty所需jar包maven-jetty-plugin,多版本
maven集成jetty必须jar包maven-jetty-plugin,内含多个版本
SpringBoot 集成 达梦数据库 maven依赖本地jar包
最近做ZF项目,需要使用国产数据库,考虑到人气较高的达梦数据库,这里是版本7。达梦数据库是参考Oracle,和MySQL有一点点的区别,这里介绍下spring boot/cloud项目里如何集成达梦数据库。 1.下载Dm7JdbcDriver17.jar,下载地址:https://download.csdn.net/download/las723/11046200 2.在src下建lib文件夹...
Maven集成时依赖jar包版本控制问题
我有一个WEB工程需要用到commons-collections和commons-dbcp.rn代码中用到的是commons-collections的3.1版本特性,但是资源库中commons-dbcp依赖的rncommons-collections指定了2.1版本。看了下commons-dbcp-1.2.1.pom:rnrn commons-collectionsrn commons-collectionsrn 2.1rn rnrn当我将web工程打包时,maven会将commons-collections-3.1.jarrn和commons-collections-2.1.jar都拷贝进WAR包。 如何只让maven只将rncommons-collections-3.1.jar拷贝到war包中去?rnrnrn n[b]问题补充:[/b]n谢谢,jansel的答复,方案1是可以行的,但是觉得maven应该有其它解决方案,所以发贴出来咨询一下。方案2我试过了,在我自己的工程pom.xml文件中指定了rn高版本的common-collections,但是maven做package的时候依赖会将两个版本的common-collections库都打进WEB-INF/lib,我的maven版本是2.0.9.n[b]问题补充:[/b]nE:\NGWORK\javaprj\webapp>mvn dependency:tree -Dverbose -Dincludes=commons-collectionsrnrnE:\NGWORK\javaprj\webapp>set MAVEN_OPTS=-Xms64m -Xmx512mrn[INFO] Scanning for projects...rn[INFO] Searching repository for plugin with prefix: 'dependency'.rn[INFO] ------------------------------------------------------------------------rn[INFO] Building Unnamed - asiainfo.cboss:cboss:war:SNAPSHOTrn[INFO] task-segment: [dependency:tree]rn[INFO] ------------------------------------------------------------------------rnDownloading: http://repo1.maven.org/maven2/asiainfo/cas/aicasclient/1.0/aicasclient-1.0.pomrnDownloading: http://repo1.maven.org/maven2/cmcc/twcmcc/1.4/twcmcc-1.4.pomrnDownloading: http://repo1.maven.org/maven2/castor/castor-xml/1.0/castor-xml-1.0.pomrnDownloading: http://repo1.maven.org/maven2/asiainfo/openboss/openclient/2.0/openclient-2.0.pomrnDownloading: http://repo1.maven.org/maven2/xstream/xstream/1.3/xstream-1.3.pomrnDownloading: http://repo1.maven.org/maven2/jdk/tools/1.4.2/tools-1.4.2.pomrnDownloading: http://repo1.maven.org/maven2/servlet/servlet/2.3/servlet-2.3.pomrnDownloading: http://repo1.maven.org/maven2/asiainfo/cboss/portalExternal/1.8/portalExternal-1.8.pomrnDownloading: http://repo1.maven.org/maven2/asiainfo/openbuff/EzfrmWeb/1.0/EzfrmWeb-1.0.pomrnDownloading: http://repo1.maven.org/maven2/asiainfo/openbuff/EzfrmBiz/1.0/EzfrmBiz-1.0.pomrnDownloading: http://repo1.maven.org/maven2/net/sf/jasperreports/2.0.3/jasperreports-2.0.3.pomrnDownloading: http://repo1.maven.org/maven2/lowagie/itext/1.3.1/itext-1.3.1.pomrnDownloading: http://repo1.maven.org/maven2/lowagie/itext-asian/1.0/itext-asian-1.0.pomrnDownloading: http://repo1.maven.org/maven2/net/sf/json/2.2.1/json-2.2.1.pomrnDownloading: http://repo1.maven.org/maven2/net/sf/ezmorph/1.0.4/ezmorph-1.0.4.pomrnDownloading: http://repo1.maven.org/maven2/edu/concurrent/1.0/concurrent-1.0.pomrnDownloading: http://repo1.maven.org/maven2/asiainfo/ny/nysecurity/1.0/nysecurity-1.0.pomrnDownloading: http://repo1.maven.org/maven2/cmcc/trustwork/1.4/trustwork-1.4.pomrnDownloading: http://repo1.maven.org/maven2/cmcc/pwdSvr/1.4/pwdSvr-1.4.pomrnDownloading: http://repo1.maven.org/maven2/poi/poi/2.5.1-FINAL/poi-2.5.1-FINAL.pomrn[INFO] [dependency:tree]rn[INFO] asiainfo.cboss:cboss:war:SNAPSHOTrn[INFO] +- asiainfo.cboss:cboss-common:jar:SNAPSHOT:compilern[INFO] | \- org.apache.velocity:velocity:jar:1.5:compilern[INFO] | \- (commons-collections:commons-collections:jar:3.1:compile - omitted for conflict with 2.1)rn[INFO] +- commons-collections:commons-collections:jar:3.1:runtime (scope not updated to compile)rn[INFO] +- commons-dbcp:commons-dbcp:jar:1.2.1:compilern[INFO] | \- (commons-collections:commons-collections:jar:2.1:compile - omitted for conflict with 3.1)rn[INFO] +- commons-beanutils:commons-beanutils:jar:1.6:compilern[INFO] | \- (commons-collections:commons-collections:jar:2.0:compile - omitted for conflict with 3.1)rn[INFO] \- commons-pool:commons-pool:jar:1.2:compilern[INFO] \- (commons-collections:commons-collections:jar:2.1:compile - omitted for conflict with 3.1)rn[INFO] ------------------------------------------------------------------------rn[INFO] BUILD SUCCESSFULrn[INFO] ------------------------------------------------------------------------rn[INFO] Total time: 33 secondsrn[INFO] Finished at: Wed Sep 09 13:18:59 CST 2009rn[INFO] Final Memory: 13M/63Mn[b]问题补充:[/b]n的确是按最短路径实现的,我在自己的pom.xml中指定了使用版本,maven就是使用这个版本的。 上午是因为忘记做clean了,所以原来已经拷贝到WEB-INF/lib目录的库没有被清理这样commons-collections-2.1.jar还是会存在, 让我误认为不能生效。
jeecg开源项目分享Maven版
JEECG是一款基于代码生成器的J2EE快速开发平台,开源界“小普元”超越传统商业企业级开发平台。引领新的开发模式(Online Coding模式(自定义表单) - > 代码生成器模式 - > 手工MERGE智能开发), 可以帮助解决Java项目60%的重复工作,让开发更多关注业务逻辑。既能快速提高开发效率,帮助公司节省人力成本,同时又不失灵活性。具备:表单配置能力(无需编码)、移动配置能力、工作流配置能力、报表配置能力(支持移动端)、插件开发能力(可插拔)
Jeecg最新源码,Maven版本
JEECG(J2EE Code Generation)是一款基于代码生成器的免费开源的快速开发平台。使用JEECG可以简单快速地开发出企业级的Web应用系统。Jeecg最新源码,Maven版本
SpringBoot集成外部jar包无法使用maven打jar包的问题
问题起源于我们公司对支付宝支付的应用。在后台服务中,我们使用SpringBoot构建工程,然后集成蚂蚁金服提供的七八个jar包,使用Add Library加到项目中。一切封装完成之后,直接运行是没有问题的。但是我们的项目需要部署到公网的服务器上面,我们习惯使用maven打包,然后直接运行。但是这样打包最终失败,错误提示是一大堆的什么包找不到、符号找不到等一系列问题。 最初以为是蚂蚁金服给的jar
kafka和storm集成是报错,找不到jar包
我使用java对kafka和storm集成开发时报错,找不到jar包,可是在网上找了好久也没有找到报错所需要的jar包,请问这是怎么回事?我用的是最土的方法,把jar包全部引入项目里的。nkafka版本是2.9.2-0.8.2.1,storm版本是0.9.7,jdk版本是1.7。n错误日志如下:n9391 [refresh-active-timer] INFO backtype.storm.daemon.worker - All connections are ready for worker 5e95c764-cf8b-4ac9-9c89-911e34720c23:1024 with id b788e814-1915-4116-87ad-1514bc9a201bn9417 [Thread-15-__system] INFO backtype.storm.daemon.executor - Preparing bolt __system:(-1)n9428 [Thread-15-__system] INFO backtype.storm.daemon.executor - Prepared bolt __system:(-1)n9437 [Thread-17-__acker] INFO backtype.storm.daemon.executor - Preparing bolt __acker:(1)n9440 [Thread-17-__acker] INFO backtype.storm.daemon.executor - Prepared bolt __acker:(1)n9457 [Thread-11-kafkabolt] INFO backtype.storm.daemon.executor - Preparing bolt kafkabolt:(3)n9465 [Thread-9-bolt] INFO backtype.storm.daemon.executor - Preparing bolt bolt:(2)n9465 [Thread-9-bolt] INFO backtype.storm.daemon.executor - Prepared bolt bolt:(2)n9480 [Thread-13-spout] INFO backtype.storm.daemon.executor - Opening spout spout:(4)n9484 [Thread-13-spout] ERROR backtype.storm.util - Async loop died!njava.lang.NoClassDefFoundError: com/netflix/curator/RetryPolicyn at storm.kafka.KafkaSpout.open(KafkaSpout.java:68) ~[storm-kafka.jar:na]n at backtype.storm.daemon.executor$fn__3371$fn__3386.invoke(executor.clj:529) ~[storm-core-0.9.7.jar:0.9.7]n at backtype.storm.util$async_loop$fn__460.invoke(util.clj:461) ~[storm-core-0.9.7.jar:0.9.7]n at clojure.lang.AFn.run(AFn.java:24) [clojure-1.5.1.jar:na]n at java.lang.Thread.run(Unknown Source) [na:1.7.0_17]nCaused by: java.lang.ClassNotFoundException: com.netflix.curator.RetryPolicyn at java.net.URLClassLoader$1.run(Unknown Source) ~[na:1.7.0_17]n at java.net.URLClassLoader$1.run(Unknown Source) ~[na:1.7.0_17]n at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.0_17]n at java.net.URLClassLoader.findClass(Unknown Source) ~[na:1.7.0_17]n at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n ... 5 common frames omittedn9485 [Thread-13-spout] ERROR backtype.storm.daemon.executor - njava.lang.NoClassDefFoundError: com/netflix/curator/RetryPolicyn at storm.kafka.KafkaSpout.open(KafkaSpout.java:68) ~[storm-kafka.jar:na]n at backtype.storm.daemon.executor$fn__3371$fn__3386.invoke(executor.clj:529) ~[storm-core-0.9.7.jar:0.9.7]n at backtype.storm.util$async_loop$fn__460.invoke(util.clj:461) ~[storm-core-0.9.7.jar:0.9.7]n at clojure.lang.AFn.run(AFn.java:24) [clojure-1.5.1.jar:na]n at java.lang.Thread.run(Unknown Source) [na:1.7.0_17]nCaused by: java.lang.ClassNotFoundException: com.netflix.curator.RetryPolicyn at java.net.URLClassLoader$1.run(Unknown Source) ~[na:1.7.0_17]n at java.net.URLClassLoader$1.run(Unknown Source) ~[na:1.7.0_17]n at java.security.AccessController.doPrivileged(Native Method) ~[na:1.7.0_17]n at java.net.URLClassLoader.findClass(Unknown Source) ~[na:1.7.0_17]n at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n at java.lang.ClassLoader.loadClass(Unknown Source) ~[na:1.7.0_17]n ... 5 common frames omittedn9725 [Thread-11-kafkabolt] INFO backtype.storm.daemon.executor - Prepared bolt kafkabolt:(3)n9885 [Thread-13-spout] ERROR backtype.storm.util - Halting process: ("Worker died")njava.lang.RuntimeException: ("Worker died")n at backtype.storm.util$exit_process_BANG_.doInvoke(util.clj:325) [storm-core-0.9.7.jar:0.9.7]n at clojure.lang.RestFn.invoke(RestFn.java:423) [clojure-1.5.1.jar:na]n at backtype.storm.daemon.worker$fn__4694$fn__4695.invoke(worker.clj:495) [storm-core-0.9.7.jar:0.9.7]n at backtype.storm.daemon.executor$mk_executor_data$fn__3272$fn__3273.invoke(executor.clj:241) [storm-core-0.9.7.jar:0.9.7]n at backtype.storm.util$async_loop$fn__460.invoke(util.clj:473) [storm-core-0.9.7.jar:0.9.7]n at clojure.lang.AFn.run(AFn.java:24) [clojure-1.5.1.jar:na]n at java.lang.Thread.run(Unknown Source) [na:1.7.0_17]n
Maven报错,找不到符号或者相关jar包
Maven项目build、install的时候,报jar包找不到,和符号错误的。 尝试很多办法,无意间发现了这个方法! 1、首先保证项目编码与jdk版本统一。 2、右键项目选择buildpath---->config build path---->按图选择本地安装的jdk即可
本地仓库有jar包maven依然报错的原因
问题描述:本地Maven仓库有所需jar包依然报错,missing………………既然有这个jar包为什么还会报错呢?找到本地仓库后发现里面有一个_remote.repositories文件问题在_remote.repositories>nexus说明这个依赖是从私服中下载下来的。而此时我是连不上私服的,所以会有lastupdate后缀的文件出现,但是下载不到。 查看一个能正常显示的依赖,发现_...
【Maven】Eclipse项目红色感叹号,JAR包无报错
疑惑了很久,我那个上说什么jar包导错,配置文件错,看了一下都是对的,但是就是红色感叹号,代码无法导入包   解决方案: 查看problems( window--》show view--》problems),找到报错显示目录(我的是/home/hadoop/.m2/repository/) 进入maven配置时设置的.m2目录,找到你导入失败的那个目录,发现是之前配置时多导入了几个版本,简...
Maven下载jar包报错或无法查看源码
1、下载并安装Maven maven下载地址:http://maven.apache.org/download.cgi 下载后,解压 配置环境变量:MAVEN_HOME;path 验证是否安装成功:mvn -v 最新版本的Eclipse代号Mars的,已经直接集成了Maven,所以无需安装M2Eclipse插件。 2、 修改默认的本地仓库位置 修改Maven安装目录的conf子目...
maven 工程安装报错及对应jar包地址
创建项目时遇到工程报错: Could not resolve archetype org.apache.maven.archetypes:maven-archetype-quickstart:RELEASE from any of the configured repositories.   Could not resolve artifact     Missing org.apache.
maven生成jar包以及相应的报错
eclipse中使用maven插件的时候,运行run as maven build的时候报错 -Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match.1)apache-maven-3.3.1需要配置jdk1.7以上
eclipse中maven打jar包时报错
如题,使用eclipse中的maven install命令打jar时,报错:No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?解决方式:在Eclipse的菜单中:Window > Preferences > Java > Installed...
Maven集成
Maven的Eclipse插件
mavenjar包
maven jar包 和 repository使用 使用maven配置 没啥看的
maven jar包
maven-aether-provider-3.2.1-sources.jar maven-antrun-plugin-1.3.jar maven-archiver-2.2.jar maven-artifact-3.2.1-sources.jar maven-assembly-plugin-2.2-beta-5.jar maven-bundle-plugin-1.0.0.jar maven-clean-plugin-2.4.1.jar maven-clean-plugin-2.5.jar maven-common-artifact-filters-1.3.jar maven-compat-3.2.1-sources.jar maven-compiler-plugin-2.5.1.jar maven-compiler-plugin-3.1.jar maven-core-3.2.1-sources.jar maven-dependency-plugin-2.1.jar maven-dependency-tree-1.0.jar maven-deploy-plugin-2.7.jar maven-deploy-plugin-2.8.1.jar maven-eclipse-plugin-2.9.jar maven-embedder-3.2.1-sources.jar maven-filtering-1.1.jar maven-install-plugin-2.3.1.jar maven-install-plugin-2.4.jar maven-install-plugin-2.5.1.jar maven-jar-plugin-2.4.jar maven-model-3.2.1-sources.jar maven-model-builder-3.2.1-sources.jar maven-osgi-0.1.0.jar maven-osgi-0.2.0.jar maven-plugin-annotations-3.1.jar maven-plugin-api-3.2.1-sources.jar maven-release-plugin-2.0.jar maven-reporting-api-2.0.6.jar maven-reporting-api-2.0.8.jar maven-reporting-api-2.0.9.jar maven-repository-metadata-3.2.1-sources.jar maven-resources-plugin-2.6.jar maven-settings-3.2.1-sources.jar maven-settings-builder-3.2.1-sources.jar maven-shared-incremental-1.1.jar maven-shared-utils-0.1.jar maven-site-plugin-3.0.jar maven-site-plugin-3.3.jar maven-surefire-common-2.12.4.jar maven-surefire-plugin-2.12.4.jar maven-surefire-plugin-2.17.jar maven-war-plugin-2.3.jar
maven的安装,maven与ecpliese集成
maven与ecpliese集成
maven学习笔记--maven和eclipse的集成
maven和eclipse安装完成之后,如何集成到一起呢? 1、下载eclipse的maven插件 下载路径: http://download.csdn.net/detail/heyrian/9832739 2、创建如下目录结构: 3、创建links文件夹,目录结构如下 并在links目录中创建 maven.link文件,文件内容为步骤2中maven插件的路径。
【Maven】eclipse集成自定义maven
一、准备工作 1、下载jdk https://www.oracle.com/technetwork/java/javase/downloads/index.html 2、下载eclipse https://www.eclipse.org/downloads/packages 3、下载maven http://maven.apache.org/download.cgi 二、配置 ...
Maven 和Maven下载的jar包库
包含Maven程序apache-maven-3.3.9-bin.zip,解压到无中文目录即可使用;和Maven的本地jar包库方便使用,不用什么都去下载
jeecg快速开发平台(springmvc+easyui) 集成fixflow工作流源码
工作流引擎使用fixflow.动态表达使用jeecg.不多说直接上源码.注:本人使用的jdk为6.0、mysql、tomcat6.0其中fixflow-expand 为eclips流程设计核心jeecg-framework 为合并后的运行框架框架中自带一个可运行的项目流程(使用动态模版、带任务分发功能)验证码为了开发方便已经默认设置为123456启动任务帐号:zh001 123456流程步骤中可能...
maven报错
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-help-plugin:2.2:sy stem (default-cli) on project standalone-pom: Execution default-cli of goal org. apache.maven.plugins:maven-help-plu...
maven 报错
编码 UTF-8 的不可映射字符 方法源自: https://blog.csdn.net/bigtree_3721/article/details/52838957 在pom的/project/build/plugins/下的编译插件声明 中加入下面的配置: <plugin> <groupId>org.apache.maven.plugins</group...
JEECG 集成KiSSO单点登录实现统一身份认证
JEECG 集成KiSSO单点登录实现统一身份认证 JEECG 如何为其他第三方系统实现统一身份认证服务,实现单点登录? 第三方系统如何对接呢? 今天为大家揭开这层面纱,让大家了解实质,使用它更快速的构建大家需要的业务  一、KISSO单点登录介绍           kisso 采用的是加密会话 cookie 机制实现单点登录 SSO 服务,具备“无状态”、“分散验证” 等特性。 ...
【maven报错】maven报错的通用解决办法
maven报错怎么解决?首先maven插件是java编写的,java代码报错怎么解决?查打印的堆栈信息啊! 所以,运行时添加参数: 这样就会把所有的错误信息打印出来,自己查找就可以了。...
cefinitialize 崩溃
求大神帮忙
Maven报错
介绍 本文介绍有关maven使用过程中可能会遇到的问题。 You need to run build with JDK or have tools.jar on the classpath. 这时候您需要修改eclipse.ini,把配置中vm的路径指向jdk根目录下的bin\javaw.exe 参考 本文为原创,如果您当前访问的域名不是surenpi.com,请
相关热词 c# stream 复制 android c# c#监测窗口句柄 c# md5 引用 c# 判断tabtip 自己写个浏览器程序c# c# 字符串变成整数数组 c#语言编程写出一个方法 c# 转盘抽奖 c#选中treeview