Bmob的SDK包找不到,求大神帮忙,困扰了许久。 5C

compile 'cn.bmob.android:bmob-sdk:3.5.0'

maven{ url "https://raw.github.com/bmob/bmob-android-sdk/master"}

以上这两句话我都配置到了对应的文件下,
但是在java类里面访问不了Bmob,就是这语句Bmob.initialize(context, "*******");
这个Bmob提示找不到类。
但是如果我用compile 'cn.bmob.android:bmob-sdk:3.4.6'的话就可以,请问怎么解决

我想是不是maven仓库里面没有这个sdk,但是我看了官网的视频跟我一模一样,他的可以我的就不可以,有点纳闷。。。

2个回答

maven仓库用的源码版本和依赖添加的不一样

a731896628
a731896628 但是我自己的就不行
2 年多之前 回复
a731896628
a731896628 我看视屏添加这两句话之后项目会自动关联的
2 年多之前 回复
a731896628
a731896628 compile 'cn.bmob.android:bmob-sdk:3.5.0' maven{ url "https://raw.github.com/bmob/bmob-android-sdk/master"}
2 年多之前 回复

我引入的是3.5.5的可以直接成功,
在项目的最外层build.gradle中添加maven仓库,然后在app的build.gradle中添加sdk即可
maven添加如图,我使用的studio是3.0.1的
图片说明

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问