kyle_2015
kylestyle
采纳率50%
2018-04-08 14:47

Mac 10.13.3 想打开任意来源,终端输入却显示如下内容,请教大神如何解决?

20
已采纳

KyleStyledeMBP:~ kylestyle$ sudo spctl--master-disable
sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set
KyleStyledeMBP:~ kylestyle$

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • happyzhangdi008 tylerzhangdi 3年前

    先启用root用户

    系统偏好设置 - 用户与群组 - 解锁 - 登录选项

    网络账户服务器: 点击 “加入” 按钮

    打开目录实用工具

    解锁

    上方工具栏 - 编辑 - 启用root用户 - 设置密码

    注销 - 切换root用户登录

    注销登录

    点击其他- 输入“root” - 输入“密码” - 回车登录

    激活

    终端中修改sudo权限

    运行终端

    重置sudo 属性

    运行 chown root /usr/bin/sudo

    运行 chmod 4755 /usr/bin/sudo

    注销 - 切换回原用户

    运行终端-执行sudo 命令

    问题解决,停用root账户

    点赞 1 评论 复制链接分享
  • happyzhangdi008 tylerzhangdi 3年前

    通用”里有时没有“任何来源”这个选项:

         显示"任何来源"选项在控制台中执行:
    
    sudo spctl --master-disable
    

    不显示"任何来源"选项(macOS 10.12默认为不显示)在控制台中执行:

    sudo spctl --master-enable
    
    点赞 评论 复制链接分享
  • u012531642 叼着奶嘴上学 3年前

    可以 按着control 直接打开软件 会出现指之前你想要的打开 ,命令行 Mac OS 10.12 亲测sudo spctl --master-disable可以没有出现你的那个问题。

    点赞 评论 复制链接分享
  • q447552640 三阶魔方 3年前

    怎么会权限不够呢,sudo -s一下,输入你的密码进入root模式,然后给sudo 用chmod开权限.还有就是,在设置里明明可以直接勾选任意来源啊?我就是手动勾选的啊。

    点赞 评论 复制链接分享