eclipse里面tomcat无法启动的问题

图片说明
图片说明
图片说明

单独运行startup.bat是可以的,但是从eclipse里面运行tomcat就不行,为啥??
(JDK的环境变量配置也没问题 CMD输入JAVA -VERSION可以看到版本信息)

12个回答

朋友毕设刚出这个问题,完全相同,最后找到原因是jdk版本过高与tomcat不兼容,重新下个旧点的jdk配置好环境就行了

m0_38119899
loveoct 谢谢,问题已经得到解决。我将版本更换为JDK9+TOMCAT7并重新配置了环境变量,可以正常运行了。:)
大约 2 年之前 回复
qq_26315481
qq_26315481 tomcat 和jdk不匹配,换个Tomcat 试试
大约 2 年之前 回复
m0_38119899
loveoct 您好,我用的是JDK10和TOMCAT8.5 请问您朋友最后换成什么版本解决问题了?。。 我看有说是因为JDK版本高的 也有说TOMCAT版本高的。。@_@
大约 2 年之前 回复

jdk如果是7.0的话不建议用tomcat8,换个tomcat是最快的解决方法,也可能是eclipse来大姨妈了,删了原来的新建一个server也可以

tomcat版本太高

tomcat版本太高不稳定,建议使用7.6

tomcat和jdk是否是对应的版本

清理版本 建议使用 8.5 如果jdk是1.7及以上 打开service 工具栏 右键清理 然后重新rmove add 方法二 找到 tomcat 工作空间 手动清理

这个跟你的Eclipse使用的版本有点关系,并且可能配置上存在错误的,建议下载一个tomcatplugin工具,可以解决你的问题

使用tomcat7试一试,应该是版本的问题吧

jdk版本和tomcat版本有点不匹配 升级一下jdk 或者 换个tomcat吧

tomcat 和jdk不匹配,换个Tomcat 试试

共12条数据 1 尾页
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐