安装glibc出错怎么解决!!!!! 5C

mv: "/mnt/hgfs/linux/glibc-2.17/build/csu/stamp.oST" 与"/mnt/hgfs/linux/glibc-2.17/build/csu/stamp.oS" 为同一文件
make[2]: *** [/mnt/hgfs/linux/glibc-2.17/build/csu/stamp.oS] 错误 1
make[2]: *** 正在等待未完成的任务....
make[2]: Leaving directory /mnt/hgfs/linux/glibc-2.17/csu'
make[1]: *** [csu/subdir_lib] 错误 2
make[1]: Leaving directory
/mnt/hgfs/linux/glibc-2.17'
make: *** [all] 错误 2
[root@localhost build]# make instal
make -r PARALLELMFLAGS="" -C .. objdir=pwd instal
make[1]: Entering directory /mnt/hgfs/linux/glibc-2.17'
make[1]: *** 没有规则可以创建目标“instal”。 停止。
make[1]: Leaving directory
/mnt/hgfs/linux/glibc-2.17'
make: *** [instal] 错误 2
[root@localhost build]# ../configure --prefix=/opt/glibc-2.17^C
[root@localhost build]#

0

2个回答

0
0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
编译glibc(gcc)以及过程中遇到的一些错误
下面总结了一下编译glibc遇到的错误。
Centos6.3使用rpm安装gcc时遇到的问题
安装gcc的时候,会发现依赖glibc-devel包,而安装glibc-devel的时候会发现依赖glibc,而glibc已经安装了,但版本不匹配。 使用rpm的升级命令也不成功。年少无知的我想着先强制卸载再安装,但卸载完出事了,linux中的命令基本都不能用了。 这时我的解决方法是插入centos安装光盘进入修复模式,此时chroot也不能用了,就在此状态下对glibc进行安装。
Centos 升级 glibc 时失败, 解决方案
一. 环境介绍          今天开发调用so文件,发现该so库依赖了 glibc_2.14,但我使用的Centos6.5 x86_64的glibc是glibc-2.12,版本偏低,需要升级。没有升级前的版本如下图,查询 rpm -qa | grep glibc 二. 升级出错          我当时下载的包为glibc-2.14.tar.xz ,升级过程中出现如下错误
Debian_Kali下glibc版本过低解决方法
Debian wheezy下的glibc版本为2.13,安装几个软件都运行不了,报以下类似错误: xxxx: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version 'GLIBC_2.15' not found (required by xxxx) 解决办法:把glibc升级到2.15版本 添加软件源,刷新系统: echo "deb http://
Glibc-2.4.tar.gz的安装问题一个一个解决
 1.       现在下面的网站上下载glibc-2.4.tar.gz 和glibc-libidn-2.4.tar.gz (目前不知道为什么要下载这个)http://ftp.gnu.org/gnu/glibc/ 2.       解压缩[root@RHEL4 programes]# tar zxvf glibc-libidn-2.4.tar.gz 3.http://ftp.gnu.
Linux升级Glibc时系统奔溃怎么办?
现象:   在安装HP硬件监控(hpasmcli)提示需要依赖Glibc-2.7,而本机的是Glibc-2.5,看来得升级Glibc了,可惜在升级时又出现了更多的依赖问题,想到在其他服务器上安装hpasmcli时很顺利,就想到将其他服务器的glibc库文件直接拷贝到本机尝试,涉及的文件有:   /lib/libc-2.5.so # 32位系统   /lib64/libc-2.5.so # 64
glibc-2.12-1.132.el6.i686.rpm
安装oracle11g是提示缺少包,安装glibc-2.12-1.132.el6.i686.rpm 后,再次检查不再提示。
Ubuntu12.04 更新Glibc 到2.18 失败引发的问题
在Ubuntu12.04上安装了AS3.0 在进行NDK 练习JNI的的时候无法编译通过,提示glibc 版本太低 需要2,17 或 2.18版本 按照网上的做法 下载包, configure -- xxx ; make; make install install的时候发生错误 一些基本命令无法使用 eg: ls cat strings, 无法通过图形化界面重启系统。强制重启系统之后发现系统...
centos6.5系统升级glibc时出错导致不管输入什么命令都是 Segmentation fault 解决
因为升级glibc-2.18结果导致系统出现错误不管输入什么命令都是段错误: [root@node04 ~]# ls Segmentation fault [root@node04 ~]# vim Segmentation fault 出现这种情况如果是虚拟机没有重要的东西可以直接重装 解决办法: 挂载光盘,设置从光盘启动(系统开机后按F2进入): 选择完从光
查看安装的glibc版本
方法一: 找到libc的DSO(dynamic shared object)并运行它,如下所示: [whb@jcwkyl ~]$ locate libc.so  /lib/libc.so.6  /lib/i686/nosegneg/libc.so.6  /usr/lib/libc.so  [whb@jcwkyl ~]$ /lib/libc.so.6  GNU C Library st
Glibc 安装指南
Glibc 安装指南(适用于2.3/2.4/2.5/2.6/2.7) Glibc 安装指南(适用于2.3/2.4/2.5/2.6/2.7)编译前的预备知识与要点提示 Glibc-2.3.6 建议使用 GCC-4.0 编译,Glibc-2.4/2.5 建议使用 GCC-4.1 编译,Glibc-2.6/2.7 建议使用 GCC-4.2 编译。所有这些版本最低要求使用 GCC-3.4
升级centos6.9 glibc引发的惨案
起因 在安装iperf时提示glibc版本依赖过低,提示依赖2.14或2.15,查看本机版本 centos6.9 glibc-2.12,然后想当然的升级到14 惨案发生了,ssh断开后不好使了,重启sshd服务失败,系统重启后无法启动,提示内核错误 回想一下最近的操作,一定是glibc搞的 重要的事情说三遍 不要随意升级内核运行库! 不要随意升级内核运行库! 不要随意升级内核运行库...
在一个系统内安装两个 glibc 环境
http://stackoverflow.com/questions/29023614/problems-with-a-local-installation-of-libc http://stackoverflow.com/questions/8657908/deploying-yesod-to-heroku-cant-build-statically/8658468#8658468 http
今天rpm装glibc和glibc-common版本,出现二个包相互依赖,解决办法
rpm -ivh glibc-common-2.12-1.132.e16.x86_64.rpm 报 dependence glibc = 2.12-1.132.e16.x86_64 rpm -ivh glibc-2.12-1.132.e16.x86_64.rpm 报 dependence glibc-common= 2.12-1.132.e16.x86_64 要一起
glibc 安装出错解决方案
glibc 版本glibc-2.14.1 修改如下两个文件 [root@flydream glibc_install]# vim ../glibc-2.14.1/sysdeps/unix/sysv/linux/i386/sysdep.h [root@flydream glibc_install]# vim ../glibc-2.14.1/nptl/sysdeps/pthread/pt-i
glibc-2.14离线安装包及安装命令
在centos6中redis2.8.2依赖2.14版本的glibc,但是原版本只是2.12,找了好久才找到,并且离线安装时也踩了几个坑,终于完成,分享出来,资源分也算是对自己辛苦付出的认可,谢谢
linux 系统安装 升级glibc库2.14
首先要下载 rpm安装文件,使用rpm安装方式如果直接下载 tar.gz压缩包,解压ln -s -f /opt/glibc-2.14/lib/libc.so.6 /lib64/libc.so.6    ##强制创建软连接会把内核系统glibc 引用覆盖掉,导致内核出现问题所以不建议上述创建软连接的方式下载glibc2.14 rpm 安装包:这些文件都需要安装,在安装会提示冲突和依赖关系建议一下指令...
使用源码升级至glibc-2.7
用的redhat版本太老,而安装mentohust,需要glibc-2.7版本以上,所以从GNU的官网 上下载了glibc-2.7的源码,将原有的glibc-2.5升级到2.7。必须注意的是,几乎所有的应用程序都依赖于glibc的动态库,重新编译安装glibc必须非常谨慎,一旦出错可能导致系统无法继续使用。所以强烈建议阅读源码目录下的INSTALL和FAQ文档。 1 ../glibc-2.7/c
glibc安装指南
<br />版权声明<br /> 本文作者是一位自由软件爱好者,所以本文虽然不是软件,但是本着 GPL 的精神发布。任何人都可以自由使用、转载、复制和再分发,但必须保留作者署名,亦不得对声明中的任何条款作任何形式的修改,也不得附加任何其它条件。您可 以自由链接、下载、传播此文档,但前提是必须保证全文完整转载,包括完整的版权信息和作译者声明。<br /><br />其他作品<br /> 本文作者十分愿意与他人共享劳动成果,如果你对我的其他翻译作品或者技术文章有兴趣,可以在如下位置查看现有作品的列表:
RedHat6.0误删glibc 大部分命令失效急救办法
RedHat6.0误删glibc 大部分命令失效急救办法 修复条件如下: 1.系统原来安装了busybox,busybox tftp命令可用 2.ssh连接没有断开 以上两个条件缺一不可 ,如果不满足那只能用光盘引导进入急救模式修复了。
CentOS6.5下安装mysql(glibc包安装)
1.下载并解压mysql glibc安装包官网下载压缩包即可 解压:tar -xvzf mysql-5.6.33-linux-glibc2.5-x86_64.tar.gz mv mysql-5.6.33-linux-glibc2.5-x86_64 /usr/local/mysql2.编译安装mysql/usr/local/mysql/scripts/mysql_install_db \ --bas
linux下编译安装glibc
Glibc 包含了linux一些主要的C库,用于分配内存、搜索目录、打开关闭文件、读写文件、字串处理、模式匹配、数学计算等等。centos默认的glibc版本比较低,不支持一些新的应用,所以对glibc进行更新,发现编译glibc报一个错误: Makeconfig:42: *** missing separator. Stop 看了glibc文档发现,glibc不能在源代码目录编译,建
Linux查看glibc安装版本
Linux查看glibc安装版本 64bit:strings /lib64/libc.so.6 |grep GLIBC 32bit:strings /lib/libc.so.6 |grep GLIBC
Linux/CentOS 升级C基本运行库CLIBC的注意事项(当想解决GLIBC_2.x找不到的编译问题)
在你准备升级GLIBC库之前,你要好好思考一下, 你真的要升级GLIBC么? 你知道你自己在做什么么?
centos升级glibc(升级到 2.17版)
1、原先的系统glibc库的版本是2.12,需要升级到2.17版本。下载地址:http://ftp.gnu.org/gnu/glibc/glibc-2.17.tar.gz 这里可以选择你所需要的版本。2、安装部署[root@kafzook1 common]# tar -xf glibc-2.17.tar.gz [root@kafzook1 common]# cd glibc-2.17 [root
glibc-2.15升级库(附安装脚步)
glibc-2.15升级库(附安装脚步)
折腾了大半天的问题-交叉编译的时候缺少glibc-static库
编译ncurses提示/usr/bin/ld: cannot find -lc 类似的问题参考 http://trac.cross-lfs.org/ticket/226   上面作者是自己复制了一个libc.a文件,可是我从工具链里也复制一个libc.a文件确提示库不兼容,看来有可能是主机上少什么库,glibc,glibc-devel都装了呀,看了几次没发现什么东西少了,没法,最试试了一下...
SUSE11 SP3系统源码升级安装glibc2.18
SUSE11 SP3系统源码升级安装glibc2.18 1、下载源码安装包         glibc-2.18.tar.gz 2、保存以下脚本到setup.sh,或者手动执行install函数里面的脚本 [root@QIANZI-BASE home]# vim setup.sh #!/bin/bash NAME=&quot;&quot; VERSION=&quot;&quot; SUFFIX=&quot;tar.gz&quot; SUBJEC...
centos7 glibc 2.17-55.el7的相关rpm包glibc-static-2.17-55.el7.x86_64.rpm
安装此资源,可以解决/lib64/libstdc++.so.5: undefined reference to `memcpy@GLIBC_2.14' 这个问题 包里有glibc-static-2.17-55.el7.x86_64.rpm及其相关依赖包
oracle ORA-01033问题怎么解决
oracle ORA-01033问题怎么解决 !! 能修复文件出错问题
glibc-2.27
C标准库 glibc-2.27.tar.tar
安装glibc
Linux下C开发环境的搭建过程(三) (2010-12-15 21:36:07)转载 标签: linux 开发环境 c语言 glibc gcc 安装 杂谈 分类: 学无止境 Linux下C开发环境的搭建过程(三) ——安装glibc 有些软件可能要求系统的 Glib
Linux 安装Mono环境 运行ASP.NET(二)
Linux 安装Mono环境 运行ASP.NET(二) 一、安装libgdiplus     前面我们已经安装了apr、apr_util、pcre和httpd apache 。现在我们来安装libgdiplus     Libgdiplus是一个Mono库,用于对非Windows操作系统提供GDI+兼容的API。libgdiplus是mono中的System.Drawing依
Ubuntu下 gcc编译 glibc-2.15静态库文件
Ubuntu 12.04 32位 gcc4.6.3   查看当前所用glibc版本 ldd --version ldd (Ubuntu EGLIBC 2.15-0ubuntu10.3) 2.15 Copyright (C) 2012 Free Software Foundation, Inc. This is free software; see the source for cop...
glib-2.28.6 的编译和安装 以及错误的解决方法
要编译glib-2.28.6,那么首先要的就是有它的源码,源码的下载地址在http://ftp.acc.umu.se/pub/gnome/sources/glib/,要什么版本都有,我这里用的是2.28.6版本(其他版本没有试,推荐该版本)。 解压什么的,我就不再啰嗦了。 这里首先在glib-2.28.6根目录下建立一个文件arm-linux.cache,并写入以下内容: glib_cv_l
Linux系统源代码升级glibc到最新版本2.25.90(正在开发的版本)
网上关于升级glibc的文章不少,但没有一篇能成功的,本人被坑过无数次,以至后来能避就避,今天自己在虚拟机上实验,终于成功,我把升级过程记录下来,为网友提供完整的升级方法。 升级是在ubuntu下进行的,但是其他系统升级也类似: 准备两个Linux系统, 一个是你要升级glibc的系统B, 另一个B用于glibc升级失败之后恢复, 它能挂载升级失败的系统的根文件系统, 恢复失败的系
Ubuntu下查看glibc版本
在Ubuntu下查看glibc版本我知道的有两种: 第一种为:ldd --version,其输出如下。 ldd (Ubuntu EGLIBC 2.19-0ubuntu6.6) 2.19 Copyright (C) 2014 Free Software Foundation, Inc. This is free software; see the source for copying condi
glibc版本信息及安装
  在高版本的glibc上编译的不能到底版本的glibc机器上运行的 问题:我需要找出我的Linux系统上的GNU C库(glibc)的版本,我怎样才能检查Linux上的glibc版本呢?   GNU C库(glibc)是标准C库的GNU实现。glibc是GNU工具链的关键组件,用于和二进制工具和编译器一起使用,为目标架构生成用户空间应用程序。当从源码进行构建时,一些Linux程序可能...
Linux系统glibc库版本信息查看
以下内容参考自:https://www.cnblogs.com/dux2016/p/6229283.htmlhttps://blog.csdn.net/feisy/article/details/177920931. CentOS/lib/i386-linux-gnu/libc.so.6 或rpm -qi glibc或ls -l /lib/libc.so.6 2. Ubuntuls -l /lib...
glibc-devel-2.17-55.el7.x86_64.rpm
glibc-devel-2.17-55.el7.x86_64.rpm
文章热词 设计制作学习 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 区块链解决 人工智能解决夜班

相似问题

1
Centos7安装Selenium+chrome+chromedrive
0
我在安装thrift时,进行./configure不成功?
0
请问:如何解决配置LDAP的Schemas时报错
1
悬赏 100起步 求大神帮忙指导linux下安装cmake和ccmake
2
为什么Kali Linux系统下,安装VMware-Tools会出现这个???装不上呀,求指点!!
0
db2数据库服务端怎么获取客户端connect连接数据库时使用的登录名和密码?
1
乌班图安装时不能点击下一步
1
ubuntu16.04下PX4编译一直出错
5
windows server 2008 r2企业版老是蓝屏 解决重谢
4
Linux系统yum安装http服务总是失败怎么解决?
1
生产应用weblogic被停用,偶然出现的,麻烦高手解答怎么解决,急急急!!!!
0
用xManager的xstart连接ContOS报错,怎么处理?
2
centos下,tomcat7关闭后报错内存泄露,并开启多个java进程,不知怎么处理
2
xargs怎么排除指定文件然后打包
0
在Redhat6.1上安装datastage8.7,启动./setup报错file or path Segmentation fault。
1
Linux 上 安装mssql 模块,之前的都安装完毕,最后一步将mssql.so加入php.ini ,重启php报错。
0
Linux下运行JFrame程序,报java.lang.UnsupportedOperationException(当前系统不支持系统托盘),怎么解决
1
rpm安装jenkins启动后报错 UnknownHostException: centos68-192-168-18-4: Name or service not known
0
使用cygwin配置交叉编译失败,提示无法执行二进制文件?(第一次配置,学网上很多的教程还是没解决)
0
hue安装后修改python环境造成的问题