sky_flying對滴
2018-04-24 07:32
采纳率: 100%
浏览 3.6k
已采纳

tomcat在eclipse中无法启动

今天在配置环境,tomcat解压配置环境变量后,
启动startup.bat文件,访问localhost:8080,访问成功,说明配置成功。
可是部署到eclipse里面后,启动不了,报错:图片说明32629.png)
在网上搜了好多种情况:什么端口占用啊,jdk不一样啊,什么的都没用,一直报这个错
还有大神知道别的错吗?

  • 写回答
  • 好问题 提建议
  • 关注问题
  • 收藏
  • 邀请回答

18条回答 默认 最新

  • 御赐 2018-04-24 08:08
    已采纳

    方法1:杀掉占用端口的软件。

    打开任务管理器,找到java虚拟机相关的进程javaw.exe,将它结束掉。如果问题没有解决,往下看。
    如果没有这个进程,那可能是其他软件占用了端口。
    在开始菜单->运行->cmd->输入 netstat -ano 或netstat -an | grep 8080 命令,可以查看哪个进程占用了8080和8009端口,找到占用端口软件的PID,然后在任务管理器找到对应PID的软件,关闭结束该进程即可。如果任务管理器中没有显示PID列,需要设置,查看---》选择列---》勾选“PID(进程标识符)”。

    方法2:修改tomcat默认端口号。

    修改Tomcat的配置文件。
    例如:C:/tomcat5.5.25/conf/server.xml
    maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
    enableLookups="false" redirectPort="8443" acceptCount="100"
    connectionTimeout="20000" disableUploadTimeout="true" />

    Connector 节点,将port="8080"中的端口改为一个没有被占用的端口。

    如果刚才的不行试试这两个方法

    已采纳该答案
    评论
    解决 无用
    打赏 举报
  • sky_flying對滴 2018-04-24 07:37

    图片说明

    评论
    解决 2 无用 1
    打赏 举报
  • 好想打麻将 2018-04-24 08:00

    1、java版本太低,不支持tomcat 9;
    2、tomcat的8080端口被占了。

    评论
    解决 1 无用
    打赏 举报
  • IAmObject 2018-04-24 07:33

    看不到图片。。。。。

    评论
    解决 无用
    打赏 举报
  • sky_flying對滴 2018-04-24 07:37

    图片说明

    评论
    解决 无用
    打赏 举报
  • Vimouse 2018-04-24 07:41

    估计是你已启动tomcat,先把tomcat关了再在eclipse里面启动tomcat

    评论
    解决 无用
    打赏 举报
  • qq_38049796 2018-04-24 07:46

    你部署eclipse位置对吗 是放workspace里了还是放到webapps 下了

    评论
    解决 无用
    打赏 举报
  • 御赐 2018-04-24 07:51

    可能是eclipse有自带tomcat 已经启动,导致这个启动失败。
    还又一种可能是版本问题,可以换个tomcat版本试试 。
    可以试试7.0 8.0的tomcat

    评论
    解决 无用
    打赏 举报
  • sspttl 2018-04-24 07:53

    你Eclipse是否有多个工作空间使用了同一个位置的Tomcat,如果是这样,你就先把其他工作空间的Tomcat设置为不可用,再打开你要使用的工作空间试试启动项目!

    评论
    解决 无用
    打赏 举报
  • daojian_ 2018-04-24 08:02

    先删除部署项目再运行Tomcat看看能不能成功

    评论
    解决 无用
    打赏 举报
  • qq_41219376 2018-04-24 08:05

    已经启动,你需在任务管理器中关闭吧···

    评论
    解决 无用
    打赏 举报
  • qq_33601255 2018-04-24 08:48

    在任务管理器 => 进程 , 删除java相关的进程试试

    评论
    解决 无用
    打赏 举报
  • yanfuxing333 2018-04-24 09:03

    eclipse中的server文件夹看看,里面的server。xml

    评论
    解决 无用
    打赏 举报
  • guwenguanzhi123 2018-04-24 09:57

    1,tomcat文件夹不能有中文的
    2,在eclipse中自定义tomcat,不要使用默认的

    评论
    解决 无用
    打赏 举报
  • CBeann 2018-04-24 13:45

    tomcat换一高版本的或者低版本的安装包,我的也有时候出现这毛病,我一下装了两个图片说明

    评论
    解决 无用
    打赏 举报
  • 我不是周同学啊 2018-04-25 00:45

    把Tomcat关了,在Eclipse中配置你的Tomcat,然后部署项目后在Eclipse中启动Tomcat

    评论
    解决 无用
    打赏 举报
  • 陈鑫x 2018-04-25 02:46

    可以考虑换个版本,端口被占了

    评论
    解决 无用
    打赏 举报
  • sky_flying對滴 2018-04-25 05:47

    找到问题了,是jdk版本太高,用的10,我改成Jdk1.8后就可以启动了。。。差点就放弃了。

    评论
    解决 无用
    打赏 举报

相关推荐 更多相似问题