asp.net core angular4 升级 angular5 后运行报错

升级方式:执行的这个命令
npm install @angular/animations@^5.2.0 @angular/common@^5.2.0 @angular/compiler@^5.2.0 @angular/compiler-cli@^5.2.0 @angular/core@^5.2.0 @angular/forms@^5.2.0 @angular/http@^5.2.0 @angular/platform-browser@^5.2.0 @angular/platform-browser-dynamic@^5.2.0 @angular/platform-server@^5.2.0 @angular/router@^5.2.0 typescript@2.4.2 rxjs@^5.5.2
升级后的包也没有异常
图片说明
升级编译报错:
图片说明
angular/compiler-cli needs to be 2.3.1 or greater. Current version is "5.2.1"
这个错误不知是什么地方的问题。初学请各位大神指教

5个回答

使用 npm uninstall @angular/compiler-cli卸载后 重新升级试试,升级最好使用npm update或者先卸载再安装比较好

ljj82livecn
FIFA_Online 还是不行,我先卸载后,再安装,安好了,然后还是报我之前的错
一年多之前 回复

angular / compiler-cli需要为2.3.1或更高。 当前版本是“5.2.1”。版本不匹配,

当前版本是“5.2.1”。版本不匹配,

我也知道是版本不匹配,可是官方升级上写的就是这个命令
angular升级向导

npm install @angular/animations@^5.2.0 @angular/common@^5.2.0 @angular/compiler@^5.2.0 @angular/compiler-cli@^5.2.0 @angular/core@^5.2.0 @angular/forms@^5.2.0 @angular/http@^5.2.0 @angular/platform-browser@^5.2.0 @angular/platform-browser-dynamic@^5.2.0 @angular/platform-server@^5.2.0 @angular/router@^5.2.0 typescript@2.4.2 rxjs@^5.5.2

怎么会出现这种情况呢

很明显当前我的版本5.2.1 版本比2.3.1高呀,怎么提示还要比 2.3.1要高的版本呢

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!