scrapy\selenium兼容问题 5C

在scrapy中from selenium import webdriver,但是总报错没有selenium这个模块:ModuleNotFoundError: No module named 'selenium'

但是引入from selenium import webdriver时又正常、没有报错,不在scrapy中使用selenium\phantomjs时是可以正常使用的,请诸位大神解惑,selenium已经换了好几个版本了,但还是报错

Yangirl_Sunny
candy-girl 同问这个问题,想知道解决了没有
大约一年之前 回复

3个回答

selenium版本和驱动版本要一致,否则会报错

song6052
song6052 回复zbrj12345:不知道你是什么浏览器,一般selenium3.0以上版本对应firefox版本是48以上了
大约 2 年之前 回复
zbrj12345
Arthur54271 我是macbook pro,怎么看selenium和驱动是否匹配,selenium模块是通过Pycharm添加的
大约 2 年之前 回复

查看相关兼容问题

zbrj12345
Arthur54271 我是macbook pro,怎么看selenium和驱动是否匹配,selenium模块是通过Pycharm添加的
大约 2 年之前 回复

selenium驱动与浏览器版本不符,现在应该可以使用最新版本浏览器加最新版本驱动了

zbrj12345
Arthur54271 我是macbook pro,怎么看selenium和驱动是否匹配,selenium模块是通过Pycharm添加的
大约 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问