qq_39872018
逸_0520
采纳率25%
2018-06-02 02:18 阅读 1.7k
已采纳

Myeclipse显示中文乱码

5

在度娘上找过很多 都说把所有的GBK改成utf-8 我也都给改了但是改完后一点效果也
没有 现在导入项目后一头雾水的看着中文注释(乱码), 图片说明啥都看不懂,请各位帮帮忙 有没有什么其他的建议。

记得度娘上还有说什么是导入之前的那个人没有用utf-8所以导过来后也会成这样 但是我看别人的也没有什么问题呢

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

18条回答 默认 最新

  • 已采纳
    shanhanyu shanhanyu 2018-06-02 03:57
    1. 确认当前文件是UTF-8 右键文件 properties 如果不是修改为UTF-8
    2. 确认myeclipse设置java文件的编码
      windows -preference --general--content types- java sources file -确认窗口最下面的default encoding 是不是UTF-8 如果不是修改

    3. 确认文件本身是否是UTF-8 用notepad++或者其他文本编辑工具,打开,如果不是乱码,说明文件不是UTF-8编码的,修改为UTF-8再拖到项目中即可

    点赞 4 评论 复制链接分享
  • weixin_41219675 28_鬼鬼 2018-06-02 02:31

    1,修改一类文件的编码方式:Windows--Preferences--General--Content Types--选中text下的Java Source File在下方的Default encoding 输入 GBK 点击 Update

    2,Windows--Preferences--General--Workspace---将Text file encoding改为 UTF8 【或者是GBK)----->根据所导入工程的编码格式来改】

    修改单个工程的编码方式:右键点击项目--Preferences--Resource--将Text file encoding改为UTF-8

    点赞 2 评论 复制链接分享
  • abcd2333 abcd2333 2018-06-02 03:18

    打开Eclipse或者MyEclipse
    Windows -> Preferences
    Eclipse和MyEclipse中文显示乱码问号非正常显示
    General -> Content type
    Java Class File
    Text目录下
    CSS
    HTML
    Java Properties File
    Java Source File
    JavaScript Source File
    JSP
    Refactoring History File
    Refactoring History Index
    XML
    XML(illformed)
    以上项目的Default encoding都改为UTF-8 并点击 Update
    Eclipse和MyEclipse中文显示乱码问号非正常显示
    General -> Workspace
    Text file encoding更改为Other:UTF-8
    点击Apply OK
    Eclipse和MyEclipse中文显示乱码问号非正常显示
    在自己开发的一个项目上点击右键
    项目右键->Properties 或者 左键点击->Alt+Enter
    Eclipse和MyEclipse中文显示乱码问号非正常显示
    Resource
    Text file encoding 选择 Other:UTF-8
    Apply OK
    Eclipse和MyEclipse中文显示乱码问号非正常显示
    重启Eclipse
    经过上述5个步骤,Eclipse的中文编码便设置完毕.
    如数据库中中文还是显示问号及其乱码
    请检查数据库设置
    代码
    过滤器

    点赞 2 评论 复制链接分享
  • qq_27755715 qq_27755715 2018-06-02 03:19

    右键项目 properties 然后resource 把gkb换成 utf-8

    点赞 2 评论 复制链接分享
  • qingchenluowu 山西卫鹏飞 2018-06-02 02:30

    中文乱码我遇到过两种情况:一种是GBK可以正常显示,设置成utf-8就会变成乱码,需要把格式设置成GBK之后记下所有的中文,然后把格式改成utf-8,再重新把中文输入一遍就好了。第二种情况是:不管设置成哪种都无法正常显示的,那就没办法了。

    点赞 1 评论 复制链接分享
  • szstephenzhou 勿勿 2018-06-02 04:10

    当前文件是UTF-8 右键文件 properties 如果不是修改为UTF-8

    点赞 1 评论 复制链接分享
  • barrytyh barrytyh 2018-06-02 03:36

    tomcat设置给启动参数就可以了

    点赞 评论 复制链接分享
  • lsc5062 lsc5062 2018-06-02 03:42

    1,修改一类文件的编码方式:Windows--Preferences--General--Content Types--选中text下的Java Source File在下方的Default encoding 输入 GBK 点击 Update

    2,Windows--Preferences--General--Workspace---将Text file encoding改为 UTF8 【或者是GBK)----->根据所导入工程的编码格式来改】

    修改单个工程的编码方式:右键点击项目--Preferences--Resource--将Text file encoding改为UTF-8

    点赞 评论 复制链接分享
  • qq_41931927 qq_41931927 2018-06-02 03:50

    把pageEncoding="ISO-8859-1"改成 pageEncoding="UTF-8"

    点赞 评论 复制链接分享
  • u012888704 scott-zhu 2018-06-02 05:19

    估计是你这个文件的编码有问题,要是java文件需要修改系统java文件的编码设置

    点赞 评论 复制链接分享
  • QLiGongZhongJieZhe QLiGongZhongJieZhe 2018-06-02 05:53

    之前编码的方式和myeclipse 不一致,导致乱吗,好解决,改变编码,要想看到中文,改一下当前项目的编码方式,试一下就行,(GBK,utf-8)

    点赞 评论 复制链接分享
  • qq_41917201 qq_41917201 2018-06-02 06:07

    windous-->properties 把这里的编码配置改成utf-8试试

    点赞 评论 复制链接分享
  • qq_34973645 qq_34973645 2018-06-02 07:15

    代码文件编码与eclipse编码格式不一致,将编码格式改为“utf-8”试试!!!

    点赞 评论 复制链接分享
  • qq_40884224 张半仙- 2018-06-02 08:52

    1.可以将你的IDE文本属性设置为utf-8或者gbk,普遍java ide的默认编码为iso
    2.用note编写, 将代码 保存为UTF-8的格式 。
    3.在编写代码时所用的字符集要和显示 的时候的字符集一样, 才不会出现乱码。

    点赞 评论 复制链接分享
  • pressure7 pressure7 2018-06-03 04:27

    导出的文件也要一开始就已经设置好中文,哪些修改中文乱码的方法才有效的好像

    点赞 评论 复制链接分享
  • qq_35104429 qq_35104429 2018-06-03 05:36

    将编码格式设置为中文GBK

    点赞 评论 复制链接分享
  • sanluo11 sanluo11 2018-06-04 03:07

    右键项目 properties 然后resource 换成 utf-8

    点赞 评论 复制链接分享
  • weixin_42371832 A夏小小 2018-06-11 10:21

    一般情况下都是将编码设置为UTF-8,如果还不可以
    ,可能是你安装的版本的为题,可以选择重新下载一个,
    因为之前我的也是这样的,后来没法子就重新安装了另外一个版本的软件。

    点赞 评论 复制链接分享