druid 怎么支持达梦数据库

报这种异常 Caused by: java.sql.SQLException: xa not support dbType : dm

4个回答

配置文件如下;
jdbc.driver=dm.jdbc.driver.DmDriver
jdbc.url=jdbc:dm://localhost:5236/TEST
jdbc.username=TEST
jdbc.password=123456789

最新版本druid地址:http://search.maven.org/#search%7Cga%7C1%7Cdruid

Yangyuanwang
Yangyuanwang 回复a718089112: 博主你好,请问可以把修改的jar包发我一份吗,感谢
6 个月之前 回复
zxhello
zxhello 回复a718089112: 请问那个包能不能也发我份呢?邮箱8917833@qq.com
一年多之前 回复
qq_31104067
wxiaohe1 这是我QQ 1530109882 能qq聊聊吗?
一年多之前 回复
qq_31104067
wxiaohe1
一年多之前 回复
a718089112
a718089112 你用xa吗?
一年多之前 回复
qq_31104067
wxiaohe1 回复a718089112: 1530109882@qq.com 谢谢了
一年多之前 回复
a718089112
a718089112 如果你使用XA就改jar,不使用xa就用这个:com.alibaba.druid.pool.DruidDataSource
一年多之前 回复
a718089112
a718089112 或者你留个邮箱 我这有改好的jar 给你一份
一年多之前 回复
a718089112
a718089112 回复qq_31104067: 你改一下jar包里源码吧,追加支持达梦类型就行了,很简单的: DruidXADataSource类中createPhysicalXAConnection方法,if(JdbcUtils.DM.equals(dbType)){ return new DmdbXAConnection(physicalConn); }
一年多之前 回复
qq_31104067
wxiaohe1 最新的druid里的DruidXADataSource也不支持啊? 是用其他的DataSource类吗? 大神
一年多之前 回复

可以支持的,开头 jdbc:dm: 别忘了添加达梦的驱动,用最新的druid版本

qq_31104067
wxiaohe1 回复qq_31104067: 有没支持的druid发我看看
一年多之前 回复
qq_31104067
wxiaohe1 最新的druid也不支持啊
一年多之前 回复

druid对数据库支持还是挺广泛的 用什么数据库 就在driver那点配置数据库jdbc就哦了

spring.datasource.druid.url=jdbc:dm://127.0.0.1/
spring.datasource.druid.username=SYSDBA
spring.datasource.druid.password=SYSDBA

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问