邪恶八进制
2018-07-03 09:02
采纳率: 50%
浏览 1.1k
已采纳

Jenkins 插件开发 调试运行问题 急急急!!!

不论我是执行 mvn hpi:run 还是mvn hpi:run -Djetty.port=8083或者mvn package
再或者mvn -DdownloadSources=true eclipse:eclipse 到会报下面的错误信息:

 [WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireMavenVersion failed with message:
3.1.0 required by frontend-maven-plugin at least.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 4.786s
[INFO] Finished at: Tue Jul 03 16:55:56 CST 2018
[INFO] Final Memory: 124M/389M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M1:enforce (display-info) on project JenkinsPlug: Some Enforcer rules have failed. Look above for specific messages explaining why the rule failed. -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

已百度千百回,pom应该没有问题,应为我是直接调试的 使用 mvn archetype:generate -Dfilter=io.jenkins.archetypes:plugin 方式生成的。

  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

2条回答 默认 最新

相关推荐 更多相似问题