android studio 3.1.3 Unable to resolve dependency 5C

android studio 3.1.3 Bulid 一直报错,网上各种方法都无效。报错信息:

Unable to resolve dependency for ':app@debug/compileClasspath': Could not download appcompat-v7.aar (com.android.support:appcompat-v7:27.0.1)

Unable to resolve dependency for ':app@debug/compileClasspath': Could not download support-fragment.aar (com.android.support:support-fragment:27.0.1)

……
……
但是直接在浏览器输入下载链接,又是能下载下来的。被这个问题困扰了好久了,请大神神们指点,不吝赐教!

3个回答

u011799045
风雨同舟jk 兄嘚,按照上面的方法都试过了,还是不行哦
接近 2 年之前 回复

是否禁用了网络下载?
图片说明

u011799045
风雨同舟jk 这个方法没起作用哦
接近 2 年之前 回复

在设置里面将离线模式禁用

u011799045
风雨同舟jk 这个方法没起作用哦
接近 2 年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Android studio 3.1.3 初始化项目 build 失败问题

本机环境:mac 10.12.6 . Android Studio 3.1.3 代理已测试可连结youtube.com ![图片说明](https://img-ask.csdn.net/upload/201807/07/1530931982_394881.png) build.gradle ``` apply plugin: 'com.android.application' android { compileSdkVersion 28 defaultConfig { applicationId "com.example.hubs.ok" minSdkVersion 19 targetSdkVersion 28 versionCode 1 versionName "1.0" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } buildToolsVersion '28.0.1' compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 } } dependencies { implementation fileTree(include: ['*.jar'], dir: 'libs') implementation 'com.android.support:appcompat-v7:28.0.0-alpha3' implementation 'com.android.support.constraint:constraint-layout:1.1.2' testImplementation 'junit:junit:4.12' androidTestImplementation 'com.android.support.test:runner:1.0.2' androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2' } ``` 点击编译时一直卡在Download .... ![图片说明](https://img-ask.csdn.net/upload/201807/07/1530932031_62049.png) 命令行里gradlew build 也一直卡在这 ![图片说明](https://img-ask.csdn.net/upload/201807/07/1530932050_488694.png) 本地curl -i 是可以访问链接的 ![图片说明](https://img-ask.csdn.net/upload/201807/07/1530932079_448161.png) 到底是什么原因呢...崩溃了....哪些同学遇到过这个情况?谢谢。

android studio 更新到3.1.4 遇到了的问题求助

![图片说明](https://img-ask.csdn.net/upload/201808/12/1534084874_198025.png) ![图片说明](https://img-ask.csdn.net/upload/201808/12/1534084879_282755.png)

Android 提示获取不到pom文件

新手入门安卓,公司的网ping dl.google.com 可以ping通,但是在下载依赖时 一直出错,尝试了网上的各种解决办法,都不行,求大神帮忙![图片说明](https://img-ask.csdn.net/upload/201809/18/1537247924_730670.png)![图片说明](https://img-ask.csdn.net/upload/201809/18/1537248014_892311.png)

adnroid 开发编译mqtt报错

android studio 下载并打开paho.mqtt.android 编译报错,我的gradle版本4.4 as版本3.1.3 下载地址https://github.com/eclipse/paho.mqtt.android 直接git到的原始的项目,打开编译就报错,我本地新建空内容项目都能编译成功,adnroid 开发编译mqtt报错× 报错如下: Cannot create variant 'android-lint' after configuration ':org.eclipse.paho.android.service:debugRuntimeElements' has been resolved ![图片说明](https://img-ask.csdn.net/upload/201808/10/1533894738_767361.png) org.gradle.initialization.ReportedException: org.gradle.internal.exceptions.LocationAwareException: A problem occurred configuring project ':org.eclipse.paho.android.service'. at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(DefaultGradleLauncher.java:139) at org.gradle.initialization.DefaultGradleLauncher.executeTasks(DefaultGradleLauncher.java:109) at org.gradle.internal.invocation.GradleBuildController$1.call(GradleBuildController.java:78) at org.gradle.internal.invocation.GradleBuildController$1.call(GradleBuildController.java:75) at org.gradle.internal.work.DefaultWorkerLeaseService.withLocks(DefaultWorkerLeaseService.java:152) at org.gradle.internal.invocation.GradleBuildController.doBuild(GradleBuildController.java:100) at org.gradle.internal.invocation.GradleBuildController.run(GradleBuildController.java:75) at org.gradle.tooling.internal.provider.runner.BuildModelActionRunner.run(BuildModelActionRunner.java:53) at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35) at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35) 。。。 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at org.gradle.internal.concurrent.ThreadFactoryImpl$ManagedThreadRunnable.run(ThreadFactoryImpl.java:55) at java.lang.Thread.run(Thread.java:745) Caused by: org.gradle.internal.exceptions.LocationAwareException: A problem occurred configuring project ':org.eclipse.paho.android.service'. at org.gradle.initialization.DefaultExceptionAnalyser.transform(DefaultExceptionAnalyser.java:74) at org.gradle.initialization.MultipleBuildFailuresExceptionAnalyser.transform(MultipleBuildFailuresExceptionAnalyser.java:47) at org.gradle.initialization.StackTraceSanitizingExceptionAnalyser.transform(StackTraceSanitizingExceptionAnalyser.java:30) at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(DefaultGradleLauncher.java:137) at org.gradle.initialization.DefaultGradleLauncher.executeTasks(DefaultGradleLauncher.java:109) at org.gradle.internal.invocation.GradleBuildController$1.call(GradleBuildController.java:78) at org.gradle.internal.invocation.GradleBuildController$1.call(GradleBuildController.java:75) at org.gradle.internal.work.DefaultWorkerLeaseService.withLocks(DefaultWorkerLeaseService.java:152) at org.gradle.internal.invocation.GradleBuildController.doBuild(GradleBuildController.java:100) at org.gradle.internal.invocation.GradleBuildController.run(GradleBuildController.java:75) at org.gradle.tooling.internal.provider.runner.BuildModelActionRunner.run(BuildModelActionRunner.java:53) at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35) at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35) at org.gradle.tooling.internal.provider.ValidatingBuildActionRunner.run(ValidatingBuildActionRunner.java:32) at org.gradle.launcher.exec.RunAsBuildOperationBuildActionRunner$1.run(RunAsBuildOperationBuildActionRunner.java:43) at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:336) at org.gradle.internal.progress.DefaultBuildOperationExecutor$RunnableBuildOperationWorker.execute(DefaultBuildOperationExecutor.java:328) at org.gradle.internal.progress.DefaultBuildOperationExecutor.execute(DefaultBuildOperationExecutor.java:199) at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:110) at org.gradle.launcher.exec.RunAsBuildOperationBuildActionRunner.run(RunAsBuildOperationBuildActionRunner.java:40) 。。。 at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36) at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:122) at org.gradle.launcher.daemon.server.exec.EstablishBuildEnvironment.doBuild(EstablishBuildEnvironment.java:82) at org.gradle.launcher.daemon.server.exec.BuildCommandOnly.execute(BuildCommandOnly.java:36) at org.gradle.launcher.daemon.server.api.DaemonCommandExecution.proceed(DaemonCommandExecution.java:122) at org.gradle.launcher.daemon.server.exec.StartBuildOrRespondWithBusy$1.run(StartBuildOrRespondWithBusy.java:50) at org.gradle.launcher.daemon.server.DaemonStateCoordinator$1.run(DaemonStateCoordinator.java:295) at org.gradle.internal.concurrent.ExecutorPolicy$CatchAndRecordFailures.onExecute(ExecutorPolicy.java:63) at org.gradle.internal.concurrent.ManagedExecutorImpl$1.run(ManagedExecutorImpl.java:46) at org.gradle.internal.concurrent.ThreadFactoryImpl$ManagedThreadRunnable.run(ThreadFactoryImpl.java:55) Caused by: org.gradle.api.ProjectConfigurationException: A problem occurred configuring project ':org.eclipse.paho.android.service'. at org.gradle.configuration.project.LifecycleProjectEvaluator.addConfigurationFailure(LifecycleProjectEvaluator.java:94) at org.gradle.configuration.project.LifecycleProjectEvaluator.notifyAfterEvaluate(LifecycleProjectEvaluator.java:89) 。。。 ... 62 more Caused by: org.gradle.api.InvalidUserCodeException: Cannot create variant 'android-lint' after configuration ':org.eclipse.paho.android.service:debugRuntimeElements' has been resolved at org.gradle.api.internal.artifacts.configurations.DefaultConfigurationPublications$ConfigurationVariantFactory.create(DefaultConfigurationPublications.java:158) at org.gradle.api.internal.artifacts.configurations.DefaultConfigurationPublications$ConfigurationVariantFactory.create(DefaultConfigurationPublications.java:151) at org.gradle.api.internal.FactoryNamedDomainObjectContainer.doCreate(FactoryNamedDomainObjectContainer.java:100) at org.gradle.api.internal.AbstractNamedDomainObjectContainer.create(AbstractNamedDomainObjectContainer.java:67) at com.android.build.gradle.internal.scope.VariantScopeImpl.lambda$publishArtifactToConfiguration$2(VariantScopeImpl.java:378) at org.gradle.api.internal.artifacts.configurations.DefaultConfigurationPublications.variants(DefaultConfigurationPublications.java:139) at com.android.build.gradle.internal.scope.VariantScopeImpl.publishArtifactToConfiguration(VariantScopeImpl.java:376) at com.android.build.gradle.internal.scope.VariantScopeImpl.publishIntermediateArtifact(VariantScopeImpl.java:347) at com.android.build.gradle.internal.scope.VariantScopeImpl.addTaskOutput(VariantScopeImpl.java:298) at com.android.build.gradle.internal.TaskManager.configureGlobalLintTask(TaskManager.java:536) at com.android.build.gradle.BasePlugin.createAndroidTasks(BasePlugin.java:7

配置Android环境后,eclipse启动报错

在配置完Android环境后,且创建了Android应用程序,此后每次启动eclipse,都会报以下错误: Error: Error parsing D:\Program Files\Java\Android\android-sdk\system-images\android-23\android-wear\armeabi-v7a\devices.xml cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。 Error: Error parsing D:\Program Files\Java\Android\android-sdk\system-images\android-23\android-wear\x86\devices.xml cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。 Error: Error parsing D:\Program Files\Java\Android\android-sdk\system-images\android-23\android-wear\armeabi-v7a\devices.xml cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。 Error: Error parsing D:\Program Files\Java\Android\android-sdk\system-images\android-23\android-wear\x86\devices.xml cvc-complex-type.2.4.d: 发现了以元素 'd:skin' 开头的无效内容。此处不应含有子元素。 不清楚是什么原因,求解答?

sparkR install failed

#R >library(devtools) > install_github("amplab-extras/SparkR-pkg", subdir="pkg") ########################################### following is part of the errors: ########################################## [warn] Merging 'org/apache/commons/beanutils/ConstructorUtils.class' with strategy 'first' [warn] Merging 'com/esotericsoftware/reflectasm/AccessClassLoader.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/converters/ClassConverter.class' with strategy 'first' [warn] Merging 'com/esotericsoftware/reflectasm/shaded/org/objectweb/asm/Opcodes.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/BeanAccessLanguageException.class' with strategy 'first' ........ [warn] Merging 'com/esotericsoftware/reflectasm/shaded/org/objectweb/asm/Item.class' with strategy 'first' [warn] Merging 'com/esotericsoftware/reflectasm/shaded/org/objectweb/asm/AnnotationWriter.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/locale/converters/DateLocaleConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/logging/impl/SimpleLog.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/MutableDynaClass.class' with strategy 'first' [warn] Merging 'com/esotericsoftware/reflectasm/shaded/org/objectweb/asm/Edge.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/converters/BigDecimalConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/converters/StringConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/locale/converters/ByteLocaleConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/RowSetDynaClass.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/locale/converters/SqlTimestampLocaleConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/converters/BigIntegerConverter.class' with strategy 'first' [warn] Merging 'org/apache/commons/collections/FastHashMap$KeySet.class' with strategy 'first' [warn] Merging 'org/apache/commons/beanutils/locale/LocaleBeanUtilsBean$1.class' with strategy 'first' ... [warn] Merging 'org/apache/commons/collections/FastHashMap$1.class' with strategy 'first' [warn] Strategy 'concat' was applied to a file [warn] Strategy 'discard' was applied to 2 files [warn] Strategy 'first' was applied to 170 files [info] Checking every *.class/*.jar file's SHA-1. [info] SHA-1: 9daccfa535029502574bf866e4be0e23bc9e6ecc [info] Packaging /tmp/RtmpanBGc5/devtoolsbb4b53a21bb8/amplab-extras-SparkR-pkg-e24b1ad/pkg/src/target/scala-2.10/sparkr-assembly-0.1.jar ... [info] Done packaging. [success] Total time: 1156 s, completed Mar 19, 2015 8:32:57 PM cp -f target/scala-2.10/sparkr-assembly-0.1.jar ../inst/ R CMD SHLIB -o SparkR.so string_hash_code.c make[1]: Entering directory `/tmp/RtmpanBGc5/devtoolsbb4b53a21bb8/amplab-extras-SparkR-pkg-e24b1ad/pkg/src' gcc -std=gnu99 -I/usr/share/R/include -DNDEBUG -fpic -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Werror=format-security -D_FORTIFY_SOURCE=2 -g -c string_hash_code.c -o string_hash_code.o gcc -std=gnu99 -shared -L/usr/lib/R/lib -Wl,-Bsymbolic-functions -Wl,-z,relro -o SparkR.so string_hash_code.o -L/usr/lib/R/lib -lR make[1]: Leaving directory `/tmp/RtmpanBGc5/devtoolsbb4b53a21bb8/amplab-extras-SparkR-pkg-e24b1ad/pkg/src' installing to /usr/local/lib/R/site-library/SparkR/libs ** R ** inst ** tests ** preparing package for lazy loading Creating a generic function for ‘lapply’ from package ‘base’ in package ‘SparkR’ Creating a generic function for ‘Filter’ from package ‘base’ in package ‘SparkR’ ** help *** installing help indices ** building package indices ** testing if installed package can be loaded * DONE (SparkR) Warning message: package ‘’ is not available (for R version 3.1.3) > library(SparkR) [SparkR] Initializing with classpath /usr/local/lib/R/site-library/SparkR/sparkr-assembly-0.1.jar > sc<-sparkR.init(master="spark://localhost:7077",sparkEnvir=list(spark.executor.memory="1g",spark.cores.max="10")) .......... at org.jboss.netty.channel.socket.nio.NioServerBoss.run(NioServerBoss.java:42) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) at java.lang.Thread.run(Thread.java:745) Error: returnStatus == 0 is not TRUE >

接入MM SDK 初始化过程中闪退

我把SDK中的DEMO拿来运行,可以正常运行,但是在assets中加入几个资源文件夹后,(没有修改任何代码)一运行程序就会 崩溃。附图: ![图片说明](https://img-ask.csdn.net/upload/201506/08/1433739804_641635.png) 资源附件不太好传,感兴趣的朋友留一下QQ或邮箱。 接入的是MM最新的版本3.1.3

Ubuntu14.04升级gcc版本到5出错

我主要按照博客[Ubuntu 14.04 LTS 下升级 gcc 到 gcc-4.9、gcc-5 版本](http://www.cnblogs.com/BlackStorm/p/5183490.html "")的步骤升级gcc。 ``` sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install software-properties-common sudo apt-get upgrade sudo apt-get install gcc-5 g++-5 ``` 之后出现问题: ``` gph@gph-pc:~$ sudo apt-get install gcc-5 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: gcc-5:i386 : Depends: cpp-5:i386 (= 5.4.1-2ubuntu1~14.04) but it is not going to be installed Depends: libcc1-0:i386 (>= 5.4.1-2ubuntu1~14.04) but it is not going to be installed Depends: binutils:i386 (>= 2.24) but it is not going to be installed Depends: libgcc-5-dev:i386 (= 5.4.1-2ubuntu1~14.04) but it is not going to be installed Depends: libc6:i386 (>= 2.15) but it is not going to be installed Depends: libgcc1:i386 (>= 1:3.0) but it is not going to be installed Depends: libgmp10:i386 but it is not going to be installed Depends: libisl15:i386 (>= 0.15) but it is not going to be installed Depends: libmpc3:i386 but it is not going to be installed Depends: libmpfr4:i386 (>= 3.1.3) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed Depends: zlib1g:i386 (>= 1:1.1.4) but it is not going to be installed Recommends: libc6-dev:i386 (>= 2.13-0ubuntu6) but it is not going to be installed E: Unable to correct problems, you have held broken packages. ``` 请问有人知道如何解决吗? 已经百度和Google过相关的问题了,还是没有解决,请各位提供帮助,谢谢! =================================================================== 最后通过本地编译安装的方式安装了gcc5.3.0,但是在编译一个代码的时候出现如下错误: ``` .build_release/lib/libcaffe.so: undefined reference to `boost::match_results<__gnu_cxx::__normal_iterator<char const*, std::__cxx11::basic_string<char.build_release/lib, std/libcaffe.so: undefined reference to `boost::match_results<__gnu_cxx::__normal_iterator<char const*, std:::__cxx11:::basic_string<charchar_traits, std<::char_traits<charchar>, std::allocator<char> > >, std::allocator<boost::sub_match<>__gnu_cxx::__normal_iterator<, .build_release/tools/get_image_size.o: In function `std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >* google::MakeCheckOpString<unsigned long, unsigned long>(unsigned long const&, unsigned long const&, char const*)': get_image_size.cpp:(.text._ZN6google17MakeCheckOpStringImmEEPNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKT_RKT0_PKc[_ZN6google17MakeCheckOpStringImmEEPNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKT_RKT0_PKc]+0x41): undefined reference to `google::base::CheckOpMessageBuilder::NewString[abi:cxx11]()' .build_release/tools/get_image_size.o: In function `main': get_image_size.cpp:(.text.startup+0x66): undefined reference to `google::SetUsageMessage(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)' get_image_size.cpp:(.text.startup+0x722): undefined reference to `caffe::GetImageSize(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, int*, int*)' 。 。 。 。 。 。 .build_release/lib/libcaffe.so: undefined reference to `google::base::CheckOpMessageBuilder::NewString[abi:cxx11]()' collect2: error: ld returned 1 exit status make: *** [.build_release/tools/device_query.bin] Error 1 ``` 这又是什么问题。。。?

升级as3.1.4后kotlin-android-extensions不生效

如题, 配置都正常, as3.1.3使用的时候没问题,就是在线更新patch后 每个类的代码会爆红, 会自动导包 ``` import R.id.* ``` **而不是** ``` import kotlinx.android.synthetic.main.xxx.* ``` 虽然不影响build和打包 ,但是看起来很不舒服: **已尝试过: ** 1. 卸载kotlin插件重新安装 2. 清空缓存重启as 3. 重新ConfigKotlin in Project 4. Clean Project --> Rebuild 5. 开启Enable offline --> Rebuild 6. 重启电脑 没辙了...求大神相助!!! ![图片说明](https://img-ask.csdn.net/upload/201808/10/1533868357_965196.jpg)

android gradle更新后,app的耗时功能模块运行速度变慢很多

android gradle插件版本更新到2.2以上之后如3.1.3,app的耗时功能模块运行速度变慢很多 有可能是什么原因造成的呢,只修改gradle版本别的代码不变

在codeigniter 3.1.3中使用WiredDesignz的HMVC时,使用回调验证规则时,本机验证规则不会运行?

<div class="post-text" itemprop="text"> <p>I recently noticed this weird bug in CI(3.1.3 but might as well be present in other versions). The navtive validation rules like required, valid_email etc don't run while I use the callback. I've already built a My_Form_validation library to make the callback validation rules work with HMVC. But that seems to create another bug in the form_validation library. For eg. I've the following validation rules setup:</p> <pre><code> $this-&gt;form_validation-&gt;set_rules('email', "Email",'required|valid_email|callback__validate_credentials|callback__check_user_status'); </code></pre> <p>The validation rules should be run in the order they are stated, but the validation rules goes straight to validating the callbacks without checking the "required" and "valid_email" rules. These native validation rules run as they should if I remove the callbacks. Has anybody found a fix around this? Thanx in advance.</p> </div>

Program type already present问题应该怎么解决

根据网上的搜索信息改成了27.1.1,但问题还没有解决,请问该怎么做? ``` apply plugin: 'com.android.application' buildscript { repositories { mavenCentral() jcenter() google() } dependencies { classpath 'com.android.tools.build:gradle:3.1.3' } allprojects { repositories { jcenter() } } } dependencies { implementation fileTree(include: '*.jar', dir: 'libs') // implementation project(':appcompat_v7') // implementation project(':recyclerview') implementation 'com.android.support:appcompat-v7:27.1.1' implementation project(':recyclerview') debugCompile 'me.ele:uetool:1.0.15' releaseCompile 'me.ele:uetool-no-op:1.0.15' // if you want to show more attrs about Fresco's DraweeView debugCompile 'me.ele:uetool-fresco:1.0.15' // // configurations { // all*.exclude group: 'com.android.support', module: 'support-v13' // } } android { compileSdkVersion 26 buildToolsVersion '26.0.2 ' useLibrary 'org.apache.http.legacy' compileOptions { sourceCompatibility JavaVersion.VERSION_1_7 targetCompatibility JavaVersion.VERSION_1_7 } aaptOptions.cruncherEnabled = false aaptOptions.useNewCruncher = false lintOptions { abortOnError false } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } sourceSets { main { manifest.srcFile 'AndroidManifest.xml' java.srcDirs = ['src'] resources.srcDirs = ['src'] aidl.srcDirs = ['src'] renderscript.srcDirs = ['src'] res.srcDirs = ['res'] assets.srcDirs = ['assets'] jniLibs.srcDirs = ['jniLibs']; } androidTest .setRoot('tests') // Move the build types to build-types/<type> // For instance, build-types/debug/java, build-types/debug/AndroidManifest.xml, ... // This moves them out of them default location under src/<type>/... which would // conflict with src/ being used by the main source set. // Adding new build types or product flavors should be accompanied // by a similar customization. debug.setRoot('build-types/debug') release.setRoot('build-types/release') } } repositories { google() } ```

在父类pom中配置了maven-war-plugin插件问题

在父类pom中配置了maven-war-plugin插件,为什么复制到的是target\m2e-wtp\web-resources\WEB-INF\下的web-inf,这个m2e-wtp到底是个什么文件夹通俗点讲讲 ![图片说明](https://img-ask.csdn.net/upload/201811/28/1543399755_133235.png)![图片说明](https://img-ask.csdn.net/upload/201811/28/1543399767_867845.png)

非典型SSH项目,启动服务器,出现如下错误,求大神支招

10:19:56.250 WARN org.hibernate.ejb.Ejb3Configuration[1132] - HHH000144: hibernate.connection.autocommit = false breaks the EJB3 specification 10:19:56.745 WARN o.h.e.jdbc.internal.JdbcServicesImpl[169] - HHH000342: Could not obtain connection to query metadata : Driver:net.sf.log4jdbc.DriverSpy@ef57f8 returned null for URL:jdbc:log4jdbc:mysql://localhost:3306/crmdb?useUnicode=true&characterEncoding=utf-8 10:19:56.760 ERROR o.s.web.context.ContextLoader[307] - Context initialization failed org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.dao.annotation.PersistenceExceptionTranslationPostProcessor#0': Initialization of bean failed; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in file [D:\dev\tools\springsource\vfabric-tc-server-developer-2.8.2.RELEASE\base-instance\wtpwebapps\operation-crm\WEB-INF\classes\context\spring-context.xml]: Invocation of init method failed; nested exception is javax.persistence.PersistenceException: [PersistenceUnit: default] Unable to build EntityManagerFactory at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:527) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:294) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:225) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:291) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:197) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.context.support.AbstractApplicationContext.registerBeanPostProcessors(AbstractApplicationContext.java:734) ~[spring-context-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:457) ~[spring-context-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.web.context.ContextLoader.configureAndRefreshWebApplicationContext(ContextLoader.java:383) ~[spring-web-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:283) ~[spring-web-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:111) [spring-web-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4797) [catalina.jar:7.0.35.B] at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5291) [catalina.jar:7.0.35.B] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150) [catalina.jar:7.0.35.B] at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901) [catalina.jar:7.0.35.B] at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877) [catalina.jar:7.0.35.B] at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:633) [catalina.jar:7.0.35.B] at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:657) [catalina.jar:7.0.35.B] at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1637) [catalina.jar:7.0.35.B] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) [na:1.6.0_32] at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) [na:1.6.0_32] at java.util.concurrent.FutureTask.run(FutureTask.java:138) [na:1.6.0_32] at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [na:1.6.0_32] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [na:1.6.0_32] at java.lang.Thread.run(Thread.java:662) [na:1.6.0_32] Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in file [D:\dev\tools\springsource\vfabric-tc-server-developer-2.8.2.RELEASE\base-instance\wtpwebapps\operation-crm\WEB-INF\classes\context\spring-context.xml]: Invocation of init method failed; nested exception is javax.persistence.PersistenceException: [PersistenceUnit: default] Unable to build EntityManagerFactory at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1455) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:294) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:225) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:291) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:197) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.DefaultListableBeanFactory.getBeansOfType(DefaultListableBeanFactory.java:420) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.BeanFactoryUtils.beansOfTypeIncludingAncestors(BeanFactoryUtils.java:277) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.dao.support.PersistenceExceptionTranslationInterceptor.detectPersistenceExceptionTranslators(PersistenceExceptionTranslationInterceptor.java:139) ~[spring-tx-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.dao.support.PersistenceExceptionTranslationInterceptor.<init>(PersistenceExceptionTranslationInterceptor.java:79) ~[spring-tx-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.dao.annotation.PersistenceExceptionTranslationAdvisor.<init>(PersistenceExceptionTranslationAdvisor.java:70) ~[spring-tx-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.dao.annotation.PersistenceExceptionTranslationPostProcessor.setBeanFactory(PersistenceExceptionTranslationPostProcessor.java:103) ~[spring-tx-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeAwareMethods(AbstractAutowireCapableBeanFactory.java:1475) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1443) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] ... 24 common frames omitted Caused by: javax.persistence.PersistenceException: [PersistenceUnit: default] Unable to build EntityManagerFactory at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:915) ~[hibernate-entitymanager-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:890) ~[hibernate-entitymanager-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java:74) ~[hibernate-entitymanager-4.1.8.Final.jar:4.1.8.Final] at org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean.createNativeEntityManagerFactory(LocalContainerEntityManagerFactoryBean.java:287) ~[spring-orm-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.orm.jpa.AbstractEntityManagerFactoryBean.afterPropertiesSet(AbstractEntityManagerFactoryBean.java:310) ~[spring-orm-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1514) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1452) ~[spring-beans-3.1.3.RELEASE.jar:3.1.3.RELEASE] ... 39 common frames omitted Caused by: org.hibernate.HibernateException: Connection cannot be null when 'hibernate.dialect' not set at org.hibernate.service.jdbc.dialect.internal.DialectFactoryImpl.determineDialect(DialectFactoryImpl.java:97) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.service.jdbc.dialect.internal.DialectFactoryImpl.buildDialect(DialectFactoryImpl.java:67) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.engine.jdbc.internal.JdbcServicesImpl.configure(JdbcServicesImpl.java:170) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.service.internal.StandardServiceRegistryImpl.configureService(StandardServiceRegistryImpl.java:75) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.service.internal.AbstractServiceRegistryImpl.initializeService(AbstractServiceRegistryImpl.java:159) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.service.internal.AbstractServiceRegistryImpl.getService(AbstractServiceRegistryImpl.java:131) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.cfg.SettingsFactory.buildSettings(SettingsFactory.java:77) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.cfg.Configuration.buildSettingsInternal(Configuration.java:2283) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.cfg.Configuration.buildSettings(Configuration.java:2279) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1748) ~[hibernate-core-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.ejb.EntityManagerFactoryImpl.<init>(EntityManagerFactoryImpl.java:94) ~[hibernate-entitymanager-4.1.8.Final.jar:4.1.8.Final] at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:905) ~[hibernate-entitymanager-4.1.8.Final.jar:4.1.8.Final] ... 45 common frames omitted 10:19:56.761 DEBUG l.s.c.w.l.ApplicationContextPostListener[35] - Invoke ApplicationContextPostListener contextInitialized

CodeIgniter 3.1.3发送加密的URL变量偶尔不起作用

<div class="post-text" itemprop="text"> <p>I am trying to pass an encrypted user_ID variable through url using the new CI encryption library, passing the variable into the controller and into the model to run a query based on the passed variable value. The problem is sometimes it is working and sometimes it is not. I set my encryption key by the instruction given in the user guide and i have load the library in the autoload: </p> <pre><code>$key = bin2hex($this-&gt;encryption-&gt;create_key(16)); </code></pre> <p>and setting the key into config.php:</p> <pre><code>$config['encryption_key'] = bin2hex('some_bin2hex_numbers_and_letters'); </code></pre> <p>View (getting the variable to be pass):</p> <pre><code>&lt;div class="col-sm-8"&gt; &lt;?php foreach ($user_list as $row) { $ID = $row['user_ID']; $UID = $this-&gt;encryption-&gt;encrypt($ID); $username = $row['user_Username']; $firstname = $row['user_FirstName']; $lastname = $row['user_LastName']; ?&gt; &lt;a href="&lt;?php echo base_url()?&gt;Admin/User?uid=&lt;?php echo $UID;?&gt;"&gt; &lt;h2 style="font-family:'Comic Sans MS', cursive;\"&gt; &lt;?php echo $username." (".$firstname." ".$lastname.") &lt;/h2&gt; &lt;br /&gt;" ?&gt; &lt;/a&gt; &lt;?php } ?&gt; &lt;/div&gt; </code></pre> <p>Controller:</p> <pre><code>public function User() { $ID = $this-&gt;input-&gt;get('uid'); $UID = $this-&gt;encryption-&gt;decrypt($ID); $data['user'] = $this-&gt;Admin_model-&gt;getUserData($UID); $this-&gt;load-&gt;view('pages/admin/admin_header'); $this-&gt;load-&gt;view('pages/admin/admin_user_data', $data); $this-&gt;load-&gt;view('templates/footer2'); } </code></pre> <p>model (to get the passed variable and return a row):</p> <pre><code>public function getUserData($UID) { $query = $this-&gt;db-&gt;query("SELECT * FROM `tbl_user` WHERE `tbl_user`.`user_ID`='$data'"); $row = $query-&gt;row(); return $row; } </code></pre> <p>view admin_user_data (the view to display the result of passed variable):</p> <pre><code>&lt;h1&gt; &lt;?php echo "User ID: ".$user-&gt;user_ID."&lt;br /&gt;"; echo "Username: ".$user-&gt;user_Username."&lt;br /&gt;"; echo "First Name: ".$user-&gt;user_FirstName."&lt;br /&gt;"; echo "Last Name: ".$user-&gt;user_LastName."&lt;br /&gt;"; ?&gt; &lt;/h1&gt; </code></pre> </div>

在Windows 10系统上启用PHP 7中的php_ssh2库

<div class="post-text" itemprop="text"> <p>I tried to enable php_ssh2 library in PHP 7 on windows 10 system. I have tried many ways, but nothing helps me. </p> <p>When I tried to access "ssh2_connect()" function, it shows the below error "Fatal error: Call to undefined function ssh2_connect()". </p> <p>OS: Windows 10</p> <p>PHP Version : 7.2.4 (Wamp Server 3.1.3)</p> <p>Please anyone help me on this?</p> </div>

HMVC Codeigniter:无法找到指定的类:Session.php

<div class="post-text" itemprop="text"> <p>I am trying to set up hmvc in codeigniter 3.1.3 using <a href="https://bitbucket.org/wiredesignz/codeigniter-modular-extensions-hmvc/downloads" rel="nofollow noreferrer">https://bitbucket.org/wiredesignz/codeigniter-modular-extensions-hmvc/downloads</a>. I have autoloaded my session library <code>$autoload['libraries'] = array('session');</code> However when I create <code>MY_Controller</code> that extends <code>MX_Controller</code> I get an error</p> <blockquote> <p>Unable to locate the specified class: Session.php</p> </blockquote> <p>This is <code>MY_Controller.php</code></p> <pre><code> &lt;?php class MY_Controller extends MX_Controller { function __construct() { parent::__construct(); } } </code></pre> </div>

任何人都可以破解我尝试使用PHP在MS SQL上存储表单数据时得到的错误消息?

<div class="post-text" itemprop="text"> <p>I attempted to connect to an <code>Microsoft SQL</code> database and store html form data in it using <code>php</code> but was unable to. </p> <p>At first I attempted using the <code>mssql</code> syntax but realized that it was abandoned past <code>5.2</code> (I'm running <code>5.3</code>). Then I attempted to connect using the <code>sqlsrv</code> syntax but that required a driver and editing the php.ini file -- which I did only to receive this error message pertaining to the MS SQL Native Client:</p> <pre><code>&gt; Connection COULD NOT be establishedArray ( [0] =&gt; Array ( [0] =&gt; IMSSP [SQLSTATE] =&gt; IMSSP [1] =&gt; -49 [code] =&gt; -49 [2] =&gt; This extension requires the Microsoft SQL Server 2012 Native Client. Access the following URL to download the Microsoft SQL Server 2012 Native Client ODBC driver for x86: http://go.microsoft.com/fwlink/?LinkId=163712 [message] =&gt; This extension requires the Microsoft SQL Server 2012 Native Client. Access the following URL to download the Microsoft SQL Server 2012 Native Client ODBC driver for x86: http://go.microsoft.com/fwlink/?LinkId=163712 ) [1] =&gt; Array ( [0] =&gt; IM002 [SQLSTATE] =&gt; IM002 [1] =&gt; 0 [code] =&gt; 0 [2] =&gt; [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified [message] =&gt; [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified ) ) </code></pre> <p>A <code>phpinfo</code> file shows that <code>sqlsrv</code> is installed and I've deleted and reinstalled the drivers and native client twice already to no avail..........</p> <p>Here is the stack: </p> <ul> <li>Windows 2003 server </li> <li>IIS 6 web host</li> <li>local install of MS SQL 2008 (previously was attempting to connect to a remote MS SQL 2014 database</li> <li>PHP version 3.1.3</li> </ul> </div>

hadoop启动后端口均未开启

所用的系统是ubuntu18.04 hadoop版本为3.1.3 格式化namenode正常,启动正常,jps后namenode datanode sm都正常,就是端口没启动![图片说明](https://img-ask.csdn.net/upload/202004/03/1585880272_37821.png) 几乎所有网上的方法都试过了,就是端口启动不了

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

华为初面+综合面试(Java技术面)附上面试题

华为面试整体流程大致分为笔试,性格测试,面试,综合面试,回学校等结果。笔试来说,华为的难度较中等,选择题难度和网易腾讯差不多。最后的代码题,相比下来就简单很多,一共3道题目,前2题很容易就AC,题目已经记不太清楚,不过难度确实不大。最后一题最后提交的代码过了75%的样例,一直没有发现剩下的25%可能存在什么坑。 笔试部分太久远,我就不怎么回忆了。直接将面试。 面试 如果说腾讯的面试是挥金如土...

和黑客斗争的 6 天!

互联网公司工作,很难避免不和黑客们打交道,我呆过的两家互联网公司,几乎每月每天每分钟都有黑客在公司网站上扫描。有的是寻找 Sql 注入的缺口,有的是寻找线上服务器可能存在的漏洞,大部分都...

讲一个程序员如何副业月赚三万的真实故事

loonggg读完需要3分钟速读仅需 1 分钟大家好,我是你们的校长。我之前讲过,这年头,只要肯动脑,肯行动,程序员凭借自己的技术,赚钱的方式还是有很多种的。仅仅靠在公司出卖自己的劳动时...

win10暴力查看wifi密码

刚才邻居打了个电话说:喂小灰,你家wifi的密码是多少,我怎么连不上了。 我。。。 我也忘了哎,就找到了一个好办法,分享给大家: 第一种情况:已经连接上的wifi,怎么知道密码? 打开:控制面板\网络和 Internet\网络连接 然后右击wifi连接的无线网卡,选择状态 然后像下图一样: 第二种情况:前提是我不知道啊,但是我以前知道密码。 此时可以利用dos命令了 1、利用netsh wlan...

上班一个月,后悔当初着急入职的选择了

最近有个老铁,告诉我说,上班一个月,后悔当初着急入职现在公司了。他之前在美图做手机研发,今年美图那边今年也有一波组织优化调整,他是其中一个,在协商离职后,当时捉急找工作上班,因为有房贷供着,不能没有收入来源。所以匆忙选了一家公司,实际上是一个大型外包公司,主要派遣给其他手机厂商做外包项目。**当时承诺待遇还不错,所以就立马入职去上班了。但是后面入职后,发现薪酬待遇这块并不是HR所说那样,那个HR自...

总结了 150 余个神奇网站,你不来瞅瞅吗?

原博客再更新,可能就没了,之后将持续更新本篇博客。

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

带了6个月的徒弟当了面试官,而身为高级工程师的我天天修Bug......

即将毕业的应届毕业生一枚,现在只拿到了两家offer,但最近听到一些消息,其中一个offer,我这个组据说客户很少,很有可能整组被裁掉。 想问大家: 如果我刚入职这个组就被裁了怎么办呢? 大家都是什么时候知道自己要被裁了的? 面试软技能指导: BQ/Project/Resume 试听内容: 除了刷题,还有哪些技能是拿到offer不可或缺的要素 如何提升面试软实力:简历, 行为面试,沟通能...

!大部分程序员只会写3年代码

如果世界上都是这种不思进取的软件公司,那别说大部分程序员只会写 3 年代码,恐怕就没有程序员这种职业。

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

HTTP与HTTPS的区别

面试官问HTTP与HTTPS的区别,我这样回答让他竖起大拇指!

程序员毕业去大公司好还是小公司好?

虽然大公司并不是人人都能进,但我仍建议还未毕业的同学,尽力地通过校招向大公司挤,但凡挤进去,你这一生会容易很多。 大公司哪里好?没能进大公司怎么办?答案都在这里了,记得帮我点赞哦。 目录: 技术氛围 内部晋升与跳槽 啥也没学会,公司倒闭了? 不同的人脉圈,注定会有不同的结果 没能去大厂怎么办? 一、技术氛围 纵观整个程序员技术领域,哪个在行业有所名气的大牛,不是在大厂? 而且众所...

程序员为什么千万不要瞎努力?

本文作者用对比非常鲜明的两个开发团队的故事,讲解了敏捷开发之道 —— 如果你的团队缺乏统一标准的环境,那么即使勤劳努力,不仅会极其耗时而且成果甚微,使用...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试:第十六章:Java中级开发(16k)

HashMap底层实现原理,红黑树,B+树,B树的结构原理 Spring的AOP和IOC是什么?它们常见的使用场景有哪些?Spring事务,事务的属性,传播行为,数据库隔离级别 Spring和SpringMVC,MyBatis以及SpringBoot的注解分别有哪些?SpringMVC的工作原理,SpringBoot框架的优点,MyBatis框架的优点 SpringCould组件有哪些,他们...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

终于懂了TCP和UDP协议区别

终于懂了TCP和UDP协议区别

Python爬虫,高清美图我全都要(彼岸桌面壁纸)

爬取彼岸桌面网站较为简单,用到了requests、lxml、Beautiful Soup4

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

美团面试,问了ThreadLocal原理,这个回答让我通过了

他想都想不到,ThreadLocal我烂熟于心

大牛都会用的IDEA调试技巧!!!

导读 前天面试了一个985高校的实习生,问了他平时用什么开发工具,他想也没想的说IDEA,于是我抛砖引玉的问了一下IDEA的调试用过吧,你说说怎么设置断点...

面试官:你连SSO都不懂,就别来面试了

大厂竟然要考我SSO,卧槽。

立即提问
相关内容推荐