suse12sp2:如何安装docker-1.12.1? 40C

各位大神好:

作为一个docker的小白,我想在一台suse:sles:12:sp2上安装docker-1.12.1。

OS信息如下:
mo-887de210b:/data # cat /etc/os-release
NAME="SLES"
VERSION="12-SP2"
VERSION_ID="12.2"
PRETTY_NAME="SUSE Linux Enterprise Server 12 SP2"
ID="sles"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:suse:sles:12:sp2"

安装的具体步骤如下:

好像没有现成的包,要自己去download下来装
install docker on suse 12.1
1.             download:  https://software.opensuse.org/package/docker  (containerd 0.2.3)  
2.             zypper in containerd-0.2.3+git4f0a33a-25.1.x86_64.rpm  
3.             zypper in docker-1.12.1-146.1.x86_64.rpm  
4.          zypper runc-1.0_dev+git10da74a-23.1.x86_64.rpm  
5.             systemctl start docker; systemctl status docker  
6.             docker -v  
7.             docker info 

但是我却在第一步安装containerd-0.2.3时就遭遇了失败:(

containerd-0.2.3+git4f0a33a-25.1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]

哪位大神可以指导一二?
万分感谢!!

具体错误信息如下:

mo-887de210b:/data/docker # zypper in containerd-0.2.3+git4f0a33a-25.1.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW package is going to be installed:
containerd

The following package is not supported by its vendor:
containerd

1 new package to install.
Overall download size: 2.4 MiB. Already cached: 0 B. After the operation, additional 12.2 MiB will be used.
Continue? y/n/...? shows all options: y
Retrieving package containerd-0.2.3+git4f0a33a-25.1.x86_64 (1/1), 2.4 MiB ( 12.2 MiB unpacked)
containerd-0.2.3+git4f0a33a-25.1.x86_64.rpm:
Header V3 RSA/SHA256 Signature, key ID 72174fc2: NOKEY
V3 RSA/SHA256 Signature, key ID 72174fc2: NOKEY

containerd-0.2.3+git4f0a33a-25.1.x86_64 (Plain RPM files cache): Signature verification failed [4-Signatures public key is not available]
Abort, retry, ignore? a/r/i: i
Checking for file conflicts: .................................................................................................................................done Installing: containerd-0.2.3+git4f0a33a-25.1.x86_64 ....................................................................................................[done]
Additional rpm output:
warning: /var/tmp/zypp.ZA7LFu/zypper/containerd-0.2.3+git4f0a33a-25.1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 72174fc2: NOKEY
Updating /etc/sysconfig/containerd…

mo-887de210b:/data/docker # zypper in docker-1.12.1-146.1.x86_64.rpm
Loading repository data...
Reading installed packages...
Resolving package dependencies...
 
Problem: nothing provides containerd = 0.2.3 needed by docker-1.12.1-146.1.x86_64
 Solution 1: do not install docker-1.12.1-146.1.x86_64
 Solution 2: break docker-1.12.1-146.1.x86_64 by ignoring some of its dependencies
 
Choose from above solutions by number or cancel 1/2/c: c

1个回答

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐