weixin_39634443
weixin_39634443
2021-01-10 10:35

nuttx-bringup: multicopter: motors won't spin

This needs more investigation. I flashed the nuttx-bringup branch onto a pixhawk on a multicopter. I can arm but the motors won't spin if I throttle up. It seems that the controller is running correctly and publishing meaningful data to the actuator controls uorb topic.

Is this a known issue or do you wan't me to investigate further? (E.g. look at pwm output, mixer, ...)

该提问来源于开源项目:PX4/PX4-Autopilot

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

6条回答

  • weixin_39634443 weixin_39634443 4月前

    unfortunately that didn't help. I will investigate this a bit more...

    点赞 评论 复制链接分享
  • weixin_39634443 weixin_39634443 4月前

    The issue is that the mixer is not loaded correctly because some variables ate not expanded in the rc.interface script. Fixed in #1708

    点赞 评论 复制链接分享
  • weixin_39886251 weixin_39886251 4月前

    Tried turning your RC off when powering your multicopter? Only turn on the RC after you hear the confirmation sound of the ESC power-up.

    点赞 评论 复制链接分享
  • weixin_39517520 weixin_39517520 4月前

    This is the first report of it. Anything you can do to isolate it would be very much appreciated.

    点赞 评论 复制链接分享
  • weixin_39558221 weixin_39558221 4月前

    that's the same symptom I had in #1649. Does a sleep after starting commander help?

    点赞 评论 复制链接分享
  • weixin_39517520 weixin_39517520 4月前

    I just pushed a fix that deals with the communications with the pio. I can imagine that this issue you're seeing might have been related. Would you please retest with the latest nuttx_bringup 9dcd7ef35e0beb8f30f3901759210f14a64287ff

    点赞 评论 复制链接分享

相关推荐