windows下安装cpu版tensorflow出现的一些问题 5C

先上图吧直观些
[img=https://img-bbs.csdn.net/upload/201808/18/1534583574_934305.png][/img][img=https://img-bbs.csdn.net/upload/201808/18/1534583599_478276.png][/img]
这些是刚通过命令 pip install tensorflow 装好完成之后运行测试的图
后面通过查找搜索需要安装一些倚赖项,但是本人之前用过python所以大部分的包都是装好的[img=https://img-bbs.csdn.net/upload/201808/18/1534584319_654731.png][/img]
[img=https://img-bbs.csdn.net/upload/201808/18/1534584344_365962.png][/img][img=https://img-bbs.csdn.net/upload/201808/18/1534584352_665680.png][/img]
可以看见包都是已经装好的vc++2015也ok
然后报错依旧是[b]Failed to load the native TensorFlow runtime.[/b]
请路过做过出现过此类问题的大佬帮忙解决下

0

2个回答

 图没有看见。cpu版本的tensorflow不难装,但是要注意这么两个问题,一个是它仅仅支持x64的系统,32bit的不行。
另一个,从1.6版开始,它默认的发行版需要avx avx2指令集的支持,这意味着酷睿i7 4代以前的cpu都用不起来。(比如你的cpu 是i7 3770k,或者 i5 2500等,第一位<4)

后一个办法可以通过自己下载sse版本的whl包,在本地安装解决。
建议你直接在全新的电脑商安装 anaconda,然后在它的命令行里再用pip安装。网络本身没有问题的话,一装就好的,应该。
0

下载对应版本的ANACONDA,在安装tensorflow

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!