qq08818
qq08818
采纳率100%
2018-09-03 00:25

node.js npm build之后页面空白页

20
已采纳

npm build后编译正常的图片说明

但是在项目启动之后,页面就变成了空白页。
图片说明

项目之前是没有问题的,但是最近下载下来想重新跑一下的时候,就突然页面空白了。试了好多办法都没用,求熟悉的大佬们帮忙

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

4条回答

  • qq_32015315 Cynical大少爷 3年前

    不出意外的话,应该是路径的问题。看看控制台的报错,找到你的根路径,然后根据根路径再去匹配你的样式路径,也算是最佳的方式了,长时间不使用有些杀毒软件会清理掉一些文件。

    点赞 评论 复制链接分享
  • oyljerry oyljerry 3年前

    从浏览器错误日志看,有安全策略等禁止了你的一些热加载什么的,导致页面出问题了

    点赞 1 评论 复制链接分享
  • qq08818 qq08818 3年前

    问题记录,路径问题,webpack.config.js里面设置跳转路径问题。

    点赞 评论 复制链接分享
  • qq08818 qq08818 3年前

    问题补充: 页面是用的react。 packge.json 代码如下:
    "name": "wangxiang",
    "version": "1.0.0",
    "description": "admin",
    "main": "index.js",
    "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "build": "webpack",
    "start": "webpack-dev-server react/main.js --devtool eval --progress --hot --inline --colors --content-base webapp/build",
    "deploy": "set NODE_ENV=production && webpack --config webpack.production.config.js"
    },
    "dependencies": {
    "antd": "1.1.0",
    "babel-runtime": "6.x",
    "compression-webpack-plugin": "^0.4.0",
    "echarts": "^3.4.0",
    "react": "0.14.x",
    "react-dom": "0.14.x",
    "reflux": "^0.4.1",
    "reqwest": "^2.0.5",
    "webpack-parallel-uglify-plugin": "^0.4.2"
    },
    "devDependencies": {
    "animate.css": "^3.5.1",
    "babel-core": "^6.10.4",
    "babel-eslint": "6.x",
    "babel-loader": "6.x",
    "babel-plugin-antd": "^0.4.0",
    "babel-plugin-transform-es2015-modules-simple-amd": "^0.3.0",
    "babel-plugin-transform-runtime": "6.x",
    "babel-preset-es2015": "6.x",
    "babel-preset-react": "6.x",
    "babel-preset-stage-0": "6.x",
    "copy-webpack-plugin": "2.x",
    "css-loader": "~0.23.0",
    "es5-shim": "^4.5.8",
    "es6-promise": "^3.2.1",
    "http-proxy-middleware": "0.17.2",
    "open-browser-webpack-plugin": "0.0.2",
    "react-hot-loader": "^1.3.0",
    "style-loader": "~0.13.0",
    "url-loader": "^0.5.7",
    "webpack": "1.x",
    "webpack-dev-server": "^1.14.1"
    },
    "author": "dwj",
    "license": "ISC"

    关键现在有异常也好,就是没有异常提示。唯一能看到的错误就是空白页面里的什么热加载
    
    点赞 评论 复制链接分享

相关推荐