ubuntu中已经对VIM进行设置,为什么仍然没有语法高亮?

etc/vim中的vimrc中内容如下,重启过后仍然没有语法高亮

 " All system-wide defaults are set in $VIMRUNTIME/debian.vim and sourced by
" the call to :runtime you can find below.  If you wish to change any of those
" settings, you should do it in this file (/etc/vim/vimrc), since debian.vim
" will be overwritten everytime an upgrade of the vim packages is performed.
" It is recommended to make changes after sourcing debian.vim since it alters
" the value of the 'compatible' option.

" This line should not be removed as it ensures that various options are
" properly set to work with the Vim-related packages available in Debian.
runtime! debian.vim

" Uncomment the next line to make Vim more Vi-compatible
" NOTE: debian.vim sets 'nocompatible'.  Setting 'compatible' changes numerous
" options, so any other options should be set AFTER setting 'compatible'.
"set compatible

" Vim5 and later versions support syntax highlighting. Uncommenting the next
" line enables syntax highlighting by default.
if has("syntax")
  syntax on
endif

" If using a dark background within the editing area and syntax highlighting
" turn on this option as well
"set background=dark

" Uncomment the following to have Vim jump to the last position when
" reopening a file
"if has("autocmd")
"  au BufReadPost * if line("'\"") > 1 && line("'\"") <= line("$") | exe "normal! g'\"" | endif
"endif

" Uncomment the following to have Vim load indentation rules and plugins
" according to the detected filetype.
"if has("autocmd")
"  filetype plugin indent on
"endif

" The following are commented out as they cause vim to behave a lot
" differently from regular Vi. They are highly recommended though.
"set showcmd        " Show (partial) command in status line.
"set showmatch      " Show matching brackets.
"set ignorecase     " Do case insensitive matching
"set smartcase      " Do smart case matching
"set incsearch      " Incremental search
"set autowrite      " Automatically save before commands like :next and :make
"set hidden     " Hide buffers when they are abandoned
"set mouse=a        " Enable mouse usage (all modes)

" Source a global configuration file if available
if filereadable("/etc/vim/vimrc.local")
  source /etc/vim/vimrc.local
endif 

set ai                          " 自动缩进,新行与前面的行保持—致的自动空格
set aw                        " 自动写,转入shell或件时,当前的缓冲区被写入
set flash                     " 在出错处闪烁但不呜叫(缺省)
set ic                          " 在查询及模式匹配时忽赂大小写
set nu        
set number                " 屏幕左边显示行号
set showmatch          " 显示括号配对,当键入“]”“)”时,高亮度显示匹配的括号
set showmode           " 处于文本输入方式时加亮按钮条中的模式指示器
set showcmd             " 在状态栏显示目前所执行的完成的指令片段亦会显示出来



colorscheme peachpuff " 设定背景为夜间模式
filetype plugin on        " 自动识别文件类型,自n.vim”文件,使用缩进定义文件
set autoindent            " 设置自动缩进:即每行;使用 noautoindent 取消设置
set cindent                 " 以C/C++的模式缩进
set noignorecase       " 默认区分大小写
set ruler                     " 打开状态栏标尺
set scrolloff=5            " 设定光标离窗口上下边界 5 行时窗口自动滚动
set shiftwidth=4          " 设定 << 和 >> 命令移动时的宽度为 4
set softtabstop=4       " 使得按退格键时可以一次4 个时删掉所有剩下的空格)
set tabstop=4             " 设定 tab 长度为 4
set wrap                     " 自动换行显示
syntax enable
syntax on                    " 自动语法
0

2个回答

重新编译下配置文件 sudo source /etc/vim/vimrc

0
0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
Vim语法高亮设置不成功!
" All system-wide defaults are set in $VIMRUNTIME/debian.vim (usually justrn" /usr/share/vim/vimcurrent/debian.vim) and sourced by the call to :runtimern" you can find below. If you wish to change any of those settings, you shouldrn" do it in this file (/etc/vim/vimrc), since debian.vim will be overwrittenrn" everytime an upgrade of the vim packages is performed. It is recommended torn" make changes after sourcing debian.vim since it alters the value of thern" 'compatible' option.rnrn" This line should not be removed as it ensures that various options arern" properly set to work with the Vim-related packages available in Debian.rnruntime! debian.vimrnrn" Uncomment the next line to make Vim more Vi-compatiblern" NOTE: debian.vim sets 'nocompatible'. Setting 'compatible' changes numerousrn" options, so any other options should be set AFTER setting 'compatible'.rn"set compatiblernrn" Vim5 and later versions support syntax highlighting. Uncommenting thern" following enables syntax highlighting by default.rnif has("syntax")rn syntax onrnendifrnrn" If using a dark background within the editing area and syntax highlightingrn" turn on this option as wellrn"set background=darkrnrn" Uncomment the following to have Vim jump to the last position whenrn" reopening a filern"if has("autocmd")rn" au BufReadPost * if line("'\"") > 1 && line("'\"") <= line("$") | exe "normal! g'\"" | endifrn"endifrnrn" Uncomment the following to have Vim load indentation rules and pluginsrn" according to the detected filetype.rn"if has("autocmd")rn" filetype plugin indent onrn"endifrnrn" The following are commented out as they cause vim to behave a lotrn" differently from regular Vi. They are highly recommended though.rn"set showcmd " Show (partial) command in status line.rn"set showmatch " Show matching brackets.rn"set ignorecase " Do case insensitive matchingrn"set smartcase " Do smart case matchingrn"set incsearch " Incremental searchrn"set autowrite " Automatically save before commands like :next and :makern"set hidden " Hide buffers when they are abandonedrn"set mouse=a " Enable mouse usage (all modes)rnset tabstop=5rnset softtabstop=5rnset shiftwidth=5rnset autoindentrnset nurnset mouse=arnrnrnsyntax onrnrnif&term=="xterm"rn set t_Co=8rn set t_Sb=^[[4%dmrn set t_Sf=^[[3%dmrnendifrnrn" Source a global configuration file if availablernif filereadable("/etc/vim/vimrc.local")rn source /etc/vim/vimrc.localrnendifrn===============================================================rnrn这是我设置的语法高亮显示不出来啊,上google查了几个小时还是不行啊,挺喜欢Vim的。是不是要下载插件才能显示语法高亮啊?Linxu下高手请指教一下!
vim设置go语法高亮
快速设置vim的go语法高亮
对vim进行设置
vim是Linux中的十分常用的工具,可以利用的vim提高开发的效率。可以对vim进行个性化的设置,满足的个人使用习惯。在Ubuntu中,vim的设置通过修改文件进行设置。可以在的每次打开vim的时候,进行设置,不过都是的临时的设置。再次打开vim的时候,上次的设置也就失效了。下面介绍一种对vim的配置文件设置的方法,每次打开vim都有效的设置。
vim语法高亮
vim语法高亮呢 Note:本文包含的所有操作仅在max os上验证过 vim路径 vim 目录下有两个文件 $ cd /usr/share/vim $ ls -l total 0 drwxr-xr-x 37 root wheel 1184 7 27 2017 vim80 -rw-r--r-- 1 root wheel 557 7 27 2017 vimrc...
VIM 语法高亮
把 "syntax enable" 命令加入到 |vimrc| 文件中。
vim中的django模板语法高亮
django模板中经常会有javascript代码在 {% block script %} 和 {% endblock %}之间,默认的vim语法高亮插件不能识别这一部分代码。 解决办法是,在语法高亮文件htmldjango.vim中添加以下两行: [code=&quot;sh&quot;] &quot; for javascript code in django template block syn inc...
Ubuntu 14.04下已经给adb设置了权限,为什么仍然还提示没有权限
heliheng@heliheng-Inspiron-5520:/media/heliheng/Resource/android-sdk-linux/platform-tools$ sudo chmod 777 adbnheliheng@heliheng-Inspiron-5520:/media/heliheng/Resource/android-sdk-linux/platform-tools$ ./adbnbash: ./adb: 权限不够n
ubuntu下vim的其他设置
转载:http://www.lupaworld.com/151392/viewspace-45863.html  
ubuntu 下vim的简单设置
先看系统上有没有vim,直接在终端上打vim,有的话会进入vim,没有的话,先装一下,用sudo apt-get install vim命令。有密码的话输入即可。装完后,用vi ~/.vimrc进入vim进行设置。按“i”进入插入模式如下: syntax on    启用语法高亮 set nu          显示行号 set shiftwidth=4        设定缩进为两个空格
UBUNTU下VIM配色设置
VIM默认高亮配色与UBUNTU主题颜色不太相配,有时都看不清. 其实不用另外再找颜色主题,只要与UBUNTU终端的配置改一下就行了 编辑 -&gt; 配置文件首选项 -&gt; 颜色 -&gt; 去掉使用系统主题中的颜色并选择内置方案为黑底灰字...
notepad++中对go的语法高亮设置
参考 https://blog.csdn.net/liang19890820/article/details/53102322   1.下载 go.xml,将其拷贝至 Notepad++ 安装目录下的 plugins\APIs 下面(例如:D:\Program Files\Notepad++\plugins\APIs)。 2.下载 userDefineLang.xml,在其内容最前面添加 &amp;l...
设置mac自带的vim环境 语法高亮
1 ### Mac 中的命令输入 localhost:~ cc$ cd ~ localhost:~ cc$ pwd /Users/cc localhost:~ cc$ vi .vimrc > 设置后的效果 ###  文档中的代码是  .vimrc "=====================================
为什么我的vc.net没有了语法高亮了?
比如我的string声明,cin和cout.
SecureCRT下vim语法高亮
a 安装vim-enhanced包 b 修改secureCRT的属性:Options-&gt;SessionOptions -&gt;Emulation,然后把Terminal类型改成xterm,并点中ANSI Color复选框。 c 按:进入命令模式输入syntax on也没有效果.这是因为vi没有识别你编译的文件类型 在命令模式下输入:set filetype=c ...
vim函数语法高亮
&quot;highlight Functionssyn match cFunctions &quot;\&amp;lt;[a-zA-Z_][a-zA-Z_0-9]*\&amp;gt;[^()]*)(&quot;me=e-2syn match cFunctions &quot;\&amp;lt;[a-zA-Z_][a-zA-Z_0-9]*\&amp;gt;\s*(&quot;me=e-1hi cFunctions gui=NONE cterm=bold  ctermfg=blu...
设置Linux下vi和vim语法高亮、显示行数
vim默认情况下已经有语法高亮了,现在我们要设置打开的时候默认显示行数。而对于vi我们只需在使用的时候默认使用vim即可。 1、vim加入语法高亮和显示行数功能若要对全部用户起作用vi /etc/vimrc在最后加入syntax on set nu syntax on 开启语法高亮 set nu 显示行数 若找不到vimrc文件可以全局查找 find / -name “vimrc”
linux vim显示行号、语法高亮、自动缩进的设置
本文对vim的设置仅仅针对centos系统 vim的配置文件存放在/etc/目录中,配置文件名为vimrc 在Fedora中vim的配置文件存放在/etc目录中,配置文件名为vimrc 在终端 输入以下命令来编辑vimrc配置文件: vim /etc/vimrc 或gedit /etc/vimrc   vim /etc/virc 或gedit /etc/virc   (...
vim显示行号、语法高亮、自动缩进的设置(转载)
在UBUNTU中vim的配置文件存放在/etc/vim目录中,配置文件名为vimrc 在Fedora中vim的配置文件存放在/etc目录中,配置文件名为vimrc 在Red Hat Linux 中vim的配置文件存放在/etc目录中,配置文件名为vimrc set nocompatible                 &quot;去掉有关vi一致性模式,避免以前版本的bug和局限     ...
vim显示行号、语法高亮、自动缩进的设置
【本文是引用,非原创】 没办法,javaeye的收藏突然不好用了,我只能新建一篇了。 先把标记文章出处:http://tjmzgn.iteye.com/blog/525756 在UBUNTU中vim的配置文件存放在/etc/vim目录中,配置文件名为vimrc 在Fedora中vim的配置文件存放在/etc目录中,配置文件名为vimrc 在终端 输入以下命令来编辑vimr...
如何在Fedora22发行版的vim下设置语法高亮
会看这篇博客的同学肯定或多或少知道vim的强大,这里我就不费口舌。下面我只要讲一下在Fedora22的vim下设置语法高亮,别的比如显示行号,缩进等基本设置和之前版本没有什么区别。 其实在普通用户模式下,vim已经实现了语法高亮,因为在/etc/vimrc中已经有这么两句来实现了语法的高亮。 " Switch syntax highlighting on, when the termina
DMU软件 语法高亮 vim设置--学习笔记6
用vim编程时, DMU的关键词没有语法高亮, 看着不舒服, 就进行一下设置, 并记录过程. 设置的效果如下 设置流程 本次设置的比较简单, 将关键词分为: 模型model, 比如DMU1, DMU2… 不同组成part, 比如DATA, VARIATE, MODEL… 不同结构类型type, 比如PED, COR… 新建DIR.vim文件, 里面设置相关参数 新建DIR_suffix.vim...
linux下使用vim编程设置go语法高亮
一直用vim进行go编程,因为没有设置语法高亮,颜色单一。随着代码量上涨,时间久了,看得眼睛累,于是上网找了一下如何在vim下设置go的语法高亮。终于弄好了,现在把这个步骤简单记录一下。 使用的系统:Debian GNU/Linux 8 vim 版本:vim7.4 go版本:go version go1.10 linux/amd64 第一步:切换到root用户安装git   第...
VIM语法高亮和SV支持
VIM语法高亮和SV支持,非常好用,谢谢大家支持
vim的语法高亮及配置文件说明
本文主要针对那些刚刚入门的菜鸟,老手请自动忽略,谢谢。 一、安装vim: sudo pacman -S vim 随后根据提示输入超级用户密码即可完成安装 二、配置自己的语法高亮文件,主要是修改~/.vimrc,也就是自己所在用户目录的根目录下,该文件是vim的配置文件,是个隐藏文件,需要使用按下f8才能看到这个文件。 一些说明:(1)配置文件中以"开始的行都是被注释掉的,实...
vim cuda语法高亮
vibing搜索后,发现使用下面的办法:Add these two lines to ~/.vimrc:au BufNewFile,BufRead *.cu set ft=cuda au BufNewFile,BufRead *.cuh set ft=cudaAnd put http://vim.cybermirror.org/runtime/syntax/cuda.vim in ~/.vim/sy
VIM语法高亮和缩进问题
语法高亮问题似乎已经解决俄,可是缩进没有解决,每行带脉都对齐实在是难看,也不容易查错。怎么设成缩进? 在网上查了下,可是没有解决?
vim显示代码语法高亮
设置 ~/.vimrc set nocompatible set backspace=indent,eol,start set ts=4 set keymodel=startsel set nu set autoindent set ruler syntax on colorscheme torte set gfn=Anonymous:h12 set anti  获取s...
vim go 语法高亮
GO语言V1.3.3自带的VIM相关插件,包括语法高亮等,详见README文档
vim取消语法高亮
vim中使用“/+keyword”匹配关键词后,再次打开其他的文本遇到同样的关键词也会高亮,这时我们需要取消高亮,方法是“:nohl”
vim STL语法高亮
一个vim插件,使vim支持stl库的语法高亮
vim 语法高亮 颜色
根据dante.vim修改.更清爽醒目! 下载以后把第40行 hi Comment term=bold ctermfg=darkcyan guifg=greyblue 的greyblue改成#606568 或者在rgb.txt文件里加上一行: 96 101 104 greyblue
vim安装Typescript语法高亮
下载vim-plugcurl -fLo ~/.vim/autoload/plug.vim --create-dirs \ https://raw.githubusercontent.com/junegunn/vim-plug/master/plug.vim下载typescript的plugingit clone https://github.com/leafgarland/typescrip
antlrv3的vim语法高亮插件.
antlrv3的vim语法高亮插件. 标题代表了所有的含义,不再多说了。
ubuntu 默认vim 没有+寄存器
这个+寄存器代表系统剪切板;   复制:“+y 粘贴:”+p ubuntu默认安装的vim是不支持系统剪切板的 需要执行以下安装: sudo apt-get install vim-gnome
Ubuntu下安装vim的问题和vim的设置
最近,由于个人需要,想在Linux系统(Ubuntu10.04)下使用vim,但是尚未安装,所以就只能先安装,但是在安装的时候总是不成功,上网查找了很多教程也都解决不了,后来在sources.list发现了问题 安装失败提示的信息: Reading package lists... Done Building dependency tree Reading state informatio
Ubuntu中对github上已经创建的项目进行修改
1. 为已创建的项目添加新的分支 2. 对已创建的项目中的某个文件进行增删
Ubuntu下vim中tab键缩进设置
Ubuntu中,vim一个tab键缩进为8个空格,可以进入vimrc配置文件来设置tab键的缩进数 登入root用户,进入/etc/vim目录, 再进入vimrc文件,进行修改. 在vimrc中,加入 set tabstop=4  最后保存. 就这么简单.
ubuntu下的vim设置配色方案
之前每次打开vim都要重新设置配色方案,特别麻烦,于是今天网上搜了很久的设置配色方案,但是在vim文件夹下的vimrc文件又是只读的不能修改,于是试了好几次。最后起效果的是先输入:vi~/.vimrc然后在打开的文件里面输入color morning(自己想要的配色方案名称)然后保存就好了。之前试过在home下直接新建vimrc,失败。也试过set color(或colorscheme) morn...
在vs2008里面怎么对.cu进行语法高亮?
Want pretty syntax highlighting when editing your .cu files in Visual Studio?rnHeres how:rnrn---rnVisual Studio .Net 2005 / Visual Studio 8:rnrn1. If you don't have a usertype.dat file in your "Microsoft Visual Studio 8\Common7\IDE" folder, then copy the included usertype.dat file there. If you do, append the contents of the included usertype.dat onto the end of the "Microsoft Visual Studio 8\Common7\IDE\usertype.dat"rnrn2. Start Visual Studio 8. Select the menu "Tools->Options...". Open "Text Editor" in the tree view on the left, and click on "File Extension". Type cu in the "Extension" box, and click "Add". Click "OK" on the dialog box. rnrn3. Restart Visual Studio and your CUDA code should now have syntax highlighting.rn我用的是上面这个sdk里面的方法 但不管用 请问有什么办法?
Ubuntu中vim配置文件
一个比较完善的vim配置,一直在用,很实用
相关热词 c#异步发送kafka c#窗体编号 c# 操作二进制文件 c# 反射 机制 c#线程 窗体失去响应 c#角度转弧度 c# 解析gps数据 c# vs设置 语法版本 c# json含回车 c#多线程demo