MyEclipse换JDK之后出错

做Maven的时候要用到JDK1.7,然而Myeclipse自带的时1.6,我想换一下,但是一换就会出错,很是无奈。。。大神们求指教

图片说明

图片说明

图片说明

图片说明
图片说明

maven执行时报错

 -Dmaven.multiModuleProjectDirectory system propery is not set. Check $M2_HOME environment variable and mvn script match.

4个回答

你的地址要指向jdk中的jre目录,然后要使用新的jdk时把环境变量修改一下。把jdk1.6的环境变量删掉(建议),配置新的环境变量。我这里有个一键配置的
https://download.csdn.net/download/hu_belif/10682197
试试配置一下环境变量,再更换eclipse里的jdk看看。

看下你的jdk安装正确没有,并且环境变量配置对了没有。注意,你的目录应该是jre的目录,但是你似乎现在是jdk

你安装的jdk的路径似乎不在jdk文件夹里面,建议把之前的jdk删除干净,再检查一下你那个jdk的环境变量配置好没。注意,环境变量的路径别填错了。希望能对你有所帮助。

qq_38197169
lzzscl,这个SB 谢谢。。。我看你的弄好的。。但是之后采纳的时候点错了。。。很尴尬。。。抱歉了。。。。
大约一年之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!