futurezhongshentong
futurezhongshentong
采纳率0%
2018-09-25 16:58

DDI指标改写为MT4应用指标,求助大神帮忙看看这个程序改怎么写成MT4,尝试多次都编译失败

TR:=MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1)));
DMZ:=IFELSE((HIGH+LOW)<=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
DMF:=IFELSE((HIGH+LOW)>=(REF(HIGH,1)+REF(LOW,1)),0,MAX(ABS(HIGH-REF(HIGH,1)),ABS(LOW-REF(LOW,1))));
DIZ:=SUM(DMZ,N)/(SUM(DMZ,N)+SUM(DMF,N));
DIF:=SUM(DMF,N)/(SUM(DMF,N)+SUM(DMZ,N));
DDI:=DIZ-DIF;
DDI,COLORSTICK;
ADDI:SMA(DDI,N1,M),COLORRED;
AD:EMA(ADDI,M1),COLORGREEN,DOT;
原理:
原理:

1、TR=(最高价-昨日最高价)的绝对值与(最低价-昨日最低价)的绝对值两者之间较大者。

2、如果(最高价+最低价)<=(昨日最高价+昨日最低价),DMZ=0,
如果(最高价+最低价)>(昨日最高价+昨日最低价),DMZ=(最高价-昨日最低价)的绝对值与
(最低价-昨日最低价)的绝对值中较大值。

3、如果(最高价+最低价)>=(昨日最高价+昨日最低价),DMF=0,
如果(最高价+最低价)<(昨日最高价+昨日最低价),DMZ=(最高价-昨日最低价)的绝对值与
(最低价-昨日最低价)的绝对值中较大值。

4、DIZ=N个周期DMZ的和/(N个周期DMZ的和+N个周期DMF的和)

5、DIF=N个周期DMF的和/(N个周期DMF的和+N个周期DMZ的和)

6、DDI=DIZ-DIF

7、ADDI=DDI在一定周期内的加权平均

8、AD=ADDI在一定周期内的简单移动平均

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

1条回答

  • hotbboy hotbboy 1月前

    我有

    点赞 评论 复制链接分享