Aet_Leng
2018-10-13 03:58
采纳率: 87.5%
浏览 639

VS2017_.net & EF6.20 & MySql 数据向导闪退

我使用
VS2017_.net
& EF6.20
& MySql.Data 8.0.12
&MySql.Data.EntityFrameworkCore 8.0.12
在创建数据向导 时提示我
您的项目引用了最新版实体框架;但是找不到进行数据连接所需的与此版本兼容的实体框架数据库提供程序.--如果您已安装.....................................然后再执行此操作
当我安装
MySql.Data.Entity 版本(6.10.8) 之后 创建数据向导闪退

项目基于 .Net Framework 4.6
请问我该如何选择NuGet包呢?

本地MySql安装如图
图片说明

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

1条回答 默认 最新

  • tangxjcxv65 2020-04-01 14:55
    已采纳

    1、把NuGet包清空
    2、.Net Framework 4.6 与mysql-connector-net之间的版本对应关系很重要;
    3、安装mysql-connector-net之后,到安装目当,例如C:\Program Files (x86)\MySQL\MySQL Connector Net 6.9.9\Assemblies中查看,是不是有v4.6,或者小于v4.6,如果大于v4.6,会闪退,生成不了Model1.edmx

    点赞 打赏 评论

相关推荐 更多相似问题