liunx安装nginx出现问的题,求解。问题如图

图片说明

在liunx的centos7系统上编译nginx阶段出现如上的错误,OpenSSL的版本是openssl-1.1.1

            编译的参数如下
            ./configure --sbin-path=/usr/local/nginx/nginx \
            --conf-path=/usr/local/nginx/nginx.conf \
            --pid-path=/usr/local/nginx/nginx.pid \
            --with-http_ssl_module \
            --with-pcre=/usr/local/src/pcre-8.42 \
            --with-zlib=/usr/local/src/zlib-1.2.11 \
            --with-openssl=/usr/local/src/openssl-1.1.1
            make
            make install
zhucehenfanren
吃青草的懒洋洋 版本问题
一年多之前 回复

1个回答

Linux上安装nginx时,需要先进行安装插件,包括有pcre、openssl和zlib。具体的你可以看下边这个地址里的:
https://www.cnblogs.com/taiyonghai/p/6728707.html

zhucehenfanren
吃青草的懒洋洋 回复dltsbydh: 搞清楚了,是版本问题。OpenSSL1.1.1这个版本不行,换成1.0.*低版本就编译通过了。
一年多之前 回复
zhucehenfanren
吃青草的懒洋洋 回复: 我是根据这个安装的http://www.nginx.cn/install只是版本不懂,其他都一样。
一年多之前 回复
zhucehenfanren
吃青草的懒洋洋 回复dltsbydh: 谢谢,不过还是没有解决我问题的方法。
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: 这是安装nginx时候经常出现的问题,你可以看下
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: https://www.cnblogs.com/codersay/p/4301677.html
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: https://www.cnblogs.com/felixzh/p/8709038.html
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: https://blog.csdn.net/txk15619567977/article/details/40652683
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: 有些插件在config的时候会出现错误信息,但不管的话直接make install的话有时也是可以安装成功的,但这会影响最后nginx的安装
一年多之前 回复
zhucehenfanren
吃青草的懒洋洋 只有在最后安装nginx的时候出现这样的错误。编译nginx的参数在原文中给出了
一年多之前 回复
zhucehenfanren
吃青草的懒洋洋 回复dltsbydh: 没有,一切正常
一年多之前 回复
dltsbydh
紫气天堂 回复zhucehenfanren: 有些插件安装的时候需要加上一些参数,你安装的时候要注意下config的时候有没有错误信息
一年多之前 回复
zhucehenfanren
吃青草的懒洋洋 全安装了
一年多之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐