csdnceshi78
2014-09-13 15:50 阅读 365
已采纳

Xcode 进程启动失败: 安全性

I have been developing an app for 1 or 2 weeks now and just yesterday I have updated my iPhone 5S to the iOS 8 GM. Everything worked fine and I could test on my device as well until I deleted the app from my phone and wanted to build again. The following error appeared:

Could not launch "My App"
process launch failed: Security

Screenshot added

When I test with the simulator it works fine. Is this because of the iOS 8 GM update and how can I fix this launch problem? I want to be able to test on my iPhone and in the simulator.

转载于:https://stackoverflow.com/questions/25824908/xcode-process-launch-failed-security

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享

14条回答 默认 最新

  • 已采纳
    csdnceshi69 YaoRaoLov 2014-09-14 19:36

    If you get this, the app has installed on your device. You have to tap the icon. It will ask you if you really want to run it. Say “yes” and then Build & Run again.

    As from iOS 9, it is required to go to Settings → General → DeviceManagement → DeveloperApp → Trust.

    点赞 26 评论 复制链接分享
  • weixin_41568208 北城已荒凉 2014-09-22 00:47

    Hey so the accepted answer works, except if you need to debug the initial launch of the app. However I think that answer is more of a work around, and not an actual solution. From my understanding this message occurs when you have some weirdness in your provisioning profile / cert setup so make extra sure everything is in tip-top shape in that dept. before ramming your head against the wall repeatedly.

    What worked for me was as follows from the apple docs:

    Provisioning Profiles Known Issue If you have upgraded to the GM seed from other betas you may see your apps crashing due to provisioning profile issues.

    Workaround:

    1. Connect the device via USB to your Mac

    2. Launch Xcode Choose Window ->Devices

    3. Right click on the device in left column, choose "Show Provisioning Profiles"

    4. Click on the provisioning profile in question

    5. Press the "-" button Continue to removing all affected profiles.

    6. Re-install the app

    Make sure you right click on the image of the device not the name of the device or you won't see the provisioning profiles option. I restored my new phone from an old backup and there was a lot of cruft hanging around, i also had 2 different dev. certs active (not sure why) but i deleted one, made a new profile got rid of all the profiles on device and it worked.

    Hope this helps someone else.

    点赞 26 评论 复制链接分享
  • csdnceshi80 胖鸭 2015-06-17 10:32

    Updated answer for Xcode 7: Tapping the app no longer works (as of beta 1 it just displays an "untrusted enterprise developer" message with only a Dismiss button).

    To fix, open the Settings app, go to General / Profiles, and you'll see your profile. Mark it trusted and things should start working normally again.

    Updated For iOS 9.2.1 and Xcode 7.2.1:

    Goto: Settings > General > Device Management > Select App from Developer Apps > Trust App.

    点赞 23 评论 复制链接分享
  • csdnceshi64 游.程 2014-09-13 16:01

    I have the same issue. I click ok in xcode and when launching the app on my iPhone I'm asked if I want to trust this application. Doing it, the app runs and further build-and-run from xcode went without any issue until deleting the app from the iPhone and reinstalling it. Then goto first line ;-)

    点赞 8 评论 复制链接分享
  • csdnceshi73 喵-见缝插针 2015-12-10 15:08

    In iOS 9.2 they renamed the 'Profiles' to 'Device Management'

    This is how you should do it now:

    1. Settings -> General -> Device Management
    2. Verify the app
    点赞 7 评论 复制链接分享
  • csdnceshi51 旧行李 2015-10-30 12:36

    Ok this this seems late and I was testing the app with internet connection off to test my app for some functionality. As I turned off the internet it gave me such error. After I turned on the internet I can install again. I know this is silly but this might be helpful to someone

    点赞 5 评论 复制链接分享
  • csdnceshi70 笑故挽风 2015-10-10 06:45

    Update for iOS9.2.1 and XCode 7.2.1

    If you get this error when building to a device in XCode:

    Error Image for XCode Build

    On your device, tap the app icon that would have just been added from your attempt at building the app and you should see this:

    enter image description here

    Next, on your device, go to Settings --> General --> Device Management, and you will see this page:

    enter image description here

    Select the profile you are using with XCode, and you should see this page: enter image description here

    Click Trust "username@email.com" then click Trust on the next popup.

    Go back to XCode and re-run your project and it should build the app to your device.

    点赞 4 评论 复制链接分享
  • csdnceshi50 三生石@ 2015-09-21 14:17

    Alternatively if one does not see "Untrust App Developer" dialog:

    Go to your iPhone > Settings > General > Profile > "you@email.com" > Trust

    点赞 3 评论 复制链接分享
  • csdnceshi56 lrony* 2015-10-20 23:13

    SETTINGS -> GENERAL -> Profiles & Device Management choose the developer profile and push Trust.

    if you do not have Profiles & Device Management menu you have to enroll your device on beta.apple.com and download the profile from Safari.

    1. install the profile
    2. Restart your device
    3. tap on the developer profile and trust.

    You are all set.

    点赞 3 评论 复制链接分享
  • weixin_41568196 撒拉嘿哟木头 2015-01-24 00:41

    To get around the process launch failed: Security issue and immediately launch the app on your device, tap the app icon on your iOS device after running the app via Xcode.

    This will allow you to immediately run the app. It may not actually "fix" the root issue that is causing these permission alerts.

    Be sure to tap the app icon while the Xcode alert is still shown. Otherwise the app will not run. I continually forget this vital step and am unable to run the app on my device. Thus I am documenting it here for myself and everyone else :)

    1. Run the app via Xcode. You will see the security alert below. Do not press OK.

    Could not launch "AppName" process launch failed: Security

    1. On your iOS device, tap the newly installed app icon:

    tap the app icon on your iOS device

    1. After tapping the icon, you should now see an alert asking you to "Trust" the Untrusted App Developer. After doing so the app will immediately run, unconnected to the Xcode debugger.

      • If you do not see this "Trust" alert, you likely pressed "OK" in Xcode too soon. Do not press "OK" on the Xcode alert until after trusting the developer.

    Trust this developer?

    1. Finally, go back and press "OK" on the Xcode alert. You will have to re-run the app to connect the running app on your iOS device to the Xcode debugger.

    Now press OK in Xcode.

    点赞 2 评论 复制链接分享
  • csdnceshi79 python小菜 2014-09-20 00:34

    Xcode is able to build and install the app, but isn't able to launch it the first time. You just need to tap on the app's icon on the phone, then you will be prompted to ask if you want to trust the developer. Allow it and the app will launch, then Xcode will be able to automatically install & launch this and your other apps.

    点赞 评论 复制链接分享
  • weixin_41568126 乱世@小熊 2014-09-22 02:12

    "If you get this, the app has installed on your device. You have to tap the icon. It will ask you if you really want to run it. Say “yes” and then Build & Run again."

    To add to that, this only holds true the moment you get the error, if you click OK, then tap on the app. It will do nothing. Scratched my head on that for 30 odd minutes, searching for alternative ways to address the problem.

    点赞 评论 复制链接分享
  • csdnceshi51 旧行李 2014-09-24 15:35

    BTW, this also happens if you change the team of your target in Xcode and rebuild. Was quite puzzled to see that problem with an app that I had run on the device before. Took me a while to figure out… Might only happen the first time building to a device with a team, though.

    点赞 评论 复制链接分享
  • csdnceshi67 bug^君 2016-01-06 15:07

    I had this issue before on Xcode 7 cause then i realized it's all about my internet connection it was down and the security check using the internet to make sure your developer account is correct. and when it see no internet it give this error … after i have fixed my internet it works good.

    点赞 评论 复制链接分享

相关推荐