csdnceshi65
larry*wei
采纳率0%
2012-07-12 22:23

无法启动 Eclipse-Java,但返回退出代码13

已采纳

I am trying to get my first taste of Android development using Eclipse. I ran into this problem when trying to run Eclipse, having installed version 4.2 only minutes ago.

After first trying to start Eclipse without any parameters to specify the Java VM, I got an error message saying it couldn't find a Java VM called javaw.exe inside the Eclipse folder, so I found where Java was installed and specified that location as the parameter in the shortcut's target. Now I get a different error, "Java was started but returned exit code=13".

Similar questions seem to indicate that it's a 32-bit/64-bit conflict, but I'm 99% positive that I downloaded 64-bit versions of both Eclipse and Java (RE 7u5), which I chose because I have 64-bit Windows 7.

  • If anyone knows how to confirm that my Eclipse and Java are 64-bit, that'd be appreciated.
  • If you think my problem is a different one, please help!
  • Please speak as plainly as you can, as I am totally new to Eclipse and Java.

Shortcut Target: "C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe" -vm "C:\Program Files (x86)\Java\jre7\bin\javaw.exe"

Full error code...:

Java was started but returned exit code=13
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins\org.eclipse.platform_4.2.0.v201206081400\splash.bmp
-launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\eclipse_1503.dll
-startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e30_5c
-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar

转载于:https://stackoverflow.com/questions/11461607/cant-start-eclipse-java-was-started-but-returned-exit-code-13

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

30条回答

  • weixin_41568174 from.. 4年前

    There are working combinations of OS, JDK and Eclipse bitness. In my case, I was using a 64-bit JDK with a 32-bit Eclipse on a 64-bit OS. After downgrading the JDK to 32-bit, Eclipse started working.

    Kindly use one of the following combinations.

    • 32-bit OS, 32-bit JDK, 32-bit Eclipse (32-bit only)
    • 64-bit OS, 32-bit JDK, 32-bit Eclipse
    • 64-bit OS, 64-bit JDK, 64-bit Eclipse (64-bit only)
    点赞 21 评论 复制链接分享
  • csdnceshi59 ℙℕℤℝ 9年前

    Your version of Eclipse is 64-bit, based on the paths and filenames. However, the version of Java that it's picking up is 32-bit, as indicated by where it is coming from, on this line:

    -vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
    

    Program Files (x86) is the folder where 64-bit Windows places 32-bit programs.

    Program Files is the folder where 64-bit Windows places 64-bit programs.

    This can happen when a system has more than one JVM installed, as is often the case on Windows 64-bit (for example, the JRE download page uses the bit-ness of the browser to determine what bit-ness download to offer you, and many people use(d) 32-bit browsers even though they run 64-bit Windows).

    The best way to fix this, assuming you do in fact have 64-bit JRE or JDK on your system, is to specify in eclipse.ini exactly which JVM you want it to use. The instructions are detailed in the Eclipse wiki page, but basically you have to specify the -vm option in the ini file - make sure to read the wiki page carefully as the format is very specific.

    Specifying the JVM path in eclipse.ini is strongly recommended because doing so isolates Eclipse from any potential changes to your system PATH that some program installers might make (I'm talking to you, Oracle!).

    Another option would be to download and use 32-bit Eclipse instead of 64-bit, but it's still strongly recommended to specify the path to the JVM in eclipse.ini.


    Left for historical reference:

    To check your version of Java, run

      java -version 
    

    in a console (command prompt). On Windows 7 with 64-bit Java 6 I get:

      java version "1.6.0_27"
      Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
      Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)
    

    Note the 3rd line, which shows that this is a 64-bit version.

    On a 32-bit version you'll get something like:

      Java HotSpot(TM) Client VM (build 20.1-b02, mixed mode, sharing) 
    
    点赞 30 评论 复制链接分享
  • csdnceshi73 喵-见缝插针 7年前

    For me the solution was to go into (on Windows 8.1):

    System > Advanced system setting > Environment Variables 
    

    Under 'System variables' in the 'Path' variable there was the following first:

    C:\ProgramData\Oracle\Java\javapath;
    

    I removed this and Eclipse worked again!

    点赞 28 评论 复制链接分享
  • csdnceshi77 狐狸.fox 7年前

    If you have recently installed Java 8 and uninstalled Java 7, install JDK 8 and retry.

    点赞 22 评论 复制链接分享
  • csdnceshi72 谁还没个明天 7年前

    I got this error and found that my PATH variable (on Windows) was probably changed. First in my PATH was this entry:

    C:\ProgramData\Oracle\Java\javapath
    

    ...and Eclipse ran "C:\ProgramData\Oracle\Java\javapath\javaw" - which gave the error. I suspect that this is something that came along with an installation of Java 8.

    I have several Java versions installed (6,7 and 8), so I removed that entry from the PATH and tried to restart Eclipse again, which worked fine.

    If it's doesn't work for you, you'll need to upgrade your JDK (to the Java versions - 8 in this case).

    Instructions on how to edit PATH variable

    点赞 20 评论 复制链接分享
  • csdnceshi72 谁还没个明天 6年前

    I also encountered the same issue. It turned out that the environment variable Path was pointing to an incorrect Java version.

    Please check the environment variable and point it to the correct Java. For example:

    C:\Program Files (x86)\Java\jdk1.6.0_17\bin
    

    To check the environment variable, go to:

    Computer → properties → Advanced system settings → Advanced -> Environment variables
    
    点赞 10 评论 复制链接分享
  • csdnceshi74 7*4 8年前

    Make sure you don't have special characters (%, $, #, etc.) at Eclipse path.

    点赞 10 评论 复制链接分享
  • csdnceshi52 妄徒之命 7年前

    I had the same problem. I was using Windows 8 with a 64-bit OS. I just changed the path to Program Files (x86) and then it started work. I put this line in the eclipse.ini file:

    -vm
     C:\Program Files (x86)\Java\jre7\bin\javaw.exe
    
    点赞 9 评论 复制链接分享
  • csdnceshi80 胖鸭 8年前

    I had the same issue, Java was started but returned exit code=13.

    My solution was to create an environment variable to Windows properties variable name = PATH variable value = C:\Program Files\Java\jdk1.7.0_02\bin, not to C:\Program Files (x86)\Java\jre7\bin.

    Next I added a line to file eclipse.ini → C:\Program Files\Java\jdk1.7.0_02\bin\javaw.exe.

    That worked for me.

    点赞 7 评论 复制链接分享
  • csdnceshi60 ℡Wang Yan 7年前

    This might happen if you have several versions of Java on the same machine. To fix this I did the following:

    1. Checked the current JAVA_HOME value. In Windows, echo %JAVA_HOME%
    2. Accessed the route of javaw.exe
    3. Replaced the shortcuts pointing to the Java home location.
    点赞 7 评论 复制链接分享
  • csdnceshi73 喵-见缝插针 6年前

    It turned out I only had the 32-bit Java runtime installed.

    C:\Program Files (x86)\Java\jre1.8.0_45\
    

    All Eclipse really wanted was for me to install the 64-bit Java runtime. <= SOLVED

    Java SE Runtime Environment 8u45  jdk-8u45-windows-x64.exe
    

    http://www.oracle.com/technetwork/java/javase/downloads/jre8-downloads-2133155.html

    Confirm your installation by checking you now have this folder
    
        C:\Program Files\Java\jre1.8.0_45\
    
    点赞 7 评论 复制链接分享
  • csdnceshi74 7*4 7年前

    I tried some of the solutions, but not worked for me.

    Finally, I found another way, ...

    Go to Environment VariablesSystem Variables

    Set C:\Program Files\Java\jdk1.7.0_02\bin\javaw.exe to the path in the system variables.

    Try it. It worked for me...

    点赞 6 评论 复制链接分享
  • csdnceshi50 三生石@ 6年前

    I had this issue. I installed Java 8 update 25 via Chrome, and therafter attempting to start Eclipse gave the mentioned error.

    Uninstalled that update, and Eclipse works again.

    点赞 6 评论 复制链接分享
  • csdnceshi68 local-host 6年前

    I had this message when I had forgot to install the JDK.

    点赞 6 评论 复制链接分享
  • csdnceshi54 hurriedly% 7年前

    I had an x64 bit JDK. There was nothing in my path settings. So I installed the x86 JDK. This solved my problem perfectly.

    点赞 6 评论 复制链接分享
  • csdnceshi63 elliott.david 9年前

    It could be due to too little memory. You can modify the eclipse.ini file to increase the memory. Something like this might help you: FAQ How do I increase the heap size available to Eclipse?

    点赞 5 评论 复制链接分享
  • csdnceshi61 derek5. 6年前

    The best answer here is too long. I cannot comment so I added my answer.

    1. Go here: http://www.oracle.com/technetwork/java/javase/downloads/index.html
    2. Download the latest SDK (of course for x64 if your computer is x64)
    3. Install it
    4. Now the party is finished, and it's time to work with Eclipse ;)
    点赞 5 评论 复制链接分享
  • csdnceshi70 笑故挽风 9年前

    The strangest fix ever. Look at your Eclipse path, and make sure you do not have strange characters (like !, #, and @). It worked for me.

    点赞 5 评论 复制链接分享
  • csdnceshi61 derek5. 7年前

    enter image description here

    The issue was fixed by doing the following steps.

    1. Eclipse finds the JAVA executables from 'C:\ProgramData\Oracle\Java\javapath'

    2. The folder structure will contain shortcuts to the below executables,
      i. java.exe
      ii. javaw.exe
      iii. javaws.exe

    3. For me the executable paths were pointing to my Program Files(x86) (home for 32 bit applications) folder location

    4. I corrected it to Program Files (which homes 64-bit applications) and the issue got resolved

    Please find the screenshot for the same.

    点赞 5 评论 复制链接分享
  • csdnceshi52 妄徒之命 6年前

    Adding vm argument to .ini file worked for me

    -vm
    C:\Program Files\Java\jdk1.7.0_65\bin\javaw.exe
    
    点赞 5 评论 复制链接分享
  • csdnceshi61 derek5. 6年前

    I had a similar error after installing Java 8 on my Windows 7 system, 64 bit system.

    Changing environment variables, etc. did not help. So I tried to remove the Java Update 8, but that too did not help. Downloading and installing the 64-bit version of Java 8 SDK fixed my problem. I hope this helps.

    点赞 5 评论 复制链接分享
  • csdnceshi79 python小菜 5年前

    Locate eclipse.ini:

    Often at C:\Users\xxx\eclipse\jee-neon\eclipse, add

    -vm
     C:\Program Files (x86)\Java\jre7\bin\javaw.exe
    

    after

    --launcher.appendVmargs
    
    点赞 5 评论 复制链接分享
  • csdnceshi79 python小菜 9年前

    The solution is simple: Put the "eclipse" folder on "C:/Program Files". If it does not work, put it in "C:/Program Files (x86)".

    点赞 4 评论 复制链接分享
  • csdnceshi79 python小菜 4年前
    1. Under system environment variables, make sure "C:\ProgramData\Oracle\Java\javapath" is removed.

    2. Under system environment variables, make sure "C:\Program Files\Java\jdk1.8.0_131\bin" is added.

    enter image description here

    点赞 4 评论 复制链接分享
  • csdnceshi80 胖鸭 7年前

    I tried the following solution:

    I created a shortcut of javaw.exe from path C:\Program Files\Java\jdk1.7.0_71\bin and pasted it into the path C:\ProgramData\Oracle\Java\javapath.

    After that, I launched Eclipse, and it worked for me.

    点赞 4 评论 复制链接分享
  • weixin_41568126 乱世@小熊 7年前

    If you install a 64-bit Eclipse version on a PC with a 32-bit JRE this is guaranteed to occur.

    So the solution is quite straightforward: You need to synchronise them by updating either one. This shall happen when downloading Oracle Fusion middleware and Eclipse expects a 32-bit environment while your JRE is 64-bit and your JAVA home is pointing to a 64-bit JDK.

    点赞 4 评论 复制链接分享
  • csdnceshi57 perhaps? 6年前

    A clean reinstall of the Java JDK did the trick in my case. I am running Eclipse 4.4 (Luna) like a charm now.

    点赞 3 评论 复制链接分享
  • csdnceshi59 ℙℕℤℝ 6年前

    I had the same issue after I upgraded my JDK from 1.7 to 1.8. I'm using Eclipse 4.4 (Luna). The error is gone after I degrade JDK to 1.7.

    点赞 3 评论 复制链接分享
  • csdnceshi78 程序go 7年前

    I uninstalled Java update 25, and the issue was solved.

    点赞 3 评论 复制链接分享
  • csdnceshi59 ℙℕℤℝ 7年前

    I have just solved the same issue upon setting up my Windows 8.1 PC. Exactly like @George Papatheodorou mentioned above (sorry I cannot add a comment), Eclipse and JRE must be both 64 bit or 32 bit.

    However, it seems for Windows 8/8.1 environment, you are going to get 32-bit JRE by default (and I do not know where to change that default for the download), as explained here: http://java.com/en/download/faq/win8_faq.xml

    I was using 64-bit Eclipse so there was a discrepancy. I then installed 32-bit Eclipse and everything works fine this time.

    So before bothering changing any environment variables, check your JRE and Eclipse version.

    Of course you can use 64-bit JRE with 64-bit Eclipse. Just make sure they match because Windows 8.1 will give you 32-bit by default.

    点赞 2 评论 复制链接分享