eclipse导入javaFX项目,报缺少javafx-packager:jar:1.8.0_20 搞不定,大神进来帮我看看

无奈网上关于JavaFX相关信息太少,发帖求助。
POM文件报错信息:
Missing artifact javafx-packager:javafx-packager:jar:1.8.0_20

            <dependencies>
    <dependency>
        <groupId>mysql</groupId>
        <artifactId>mysql-connector-java</artifactId>
        <version>${mysql-connector.version}</version>
    </dependency>
    <!--mybatis database mapper -->
    <dependency>
        <groupId>org.mybatis</groupId>
        <artifactId>mybatis</artifactId>
        <version>${mybatis.version}</version>
    </dependency>
    <dependency>
        <groupId>com.fasterxml.jackson.core</groupId>
        <artifactId>jackson-databind</artifactId>
        <version>${jackson.version}</version>
    </dependency>
    <dependency>
        <groupId>net.sf.json-lib</groupId>
        <artifactId>json-lib</artifactId>
        <version>${json-lib.version}</version>
        <classifier>jdk15</classifier>
    </dependency>
    <dependency>
        <groupId>com.github.sarxos</groupId>
        <artifactId>webcam-capture</artifactId>
        <version>${webcam-capture.version}</version>
    </dependency>
    <dependency>
        <groupId>com.zenjava</groupId>
        <artifactId>javafx-maven-plugin</artifactId>
        <version>${javafx-maven-plugin.version}</version>
    </dependency>
    <dependency>
        <groupId>org.slf4j</groupId>
        <artifactId>slf4j-log4j12</artifactId>
        <version>${slf4j.version}</version>
    </dependency>
    <dependency>
        <groupId>net.java.dev.jna</groupId>
        <artifactId>jna</artifactId>
        <version>4.5.2</version>
    </dependency>
    <dependency>
        <groupId>log4j</groupId>
        <artifactId>log4j</artifactId>
        <version>1.2.17</version>
    </dependency>
</dependencies>

并没有引用javafx-packager:javafx-packager:jar:1.8.0_20,不知道为何报错。台式机就没有问题,各种重装eclipse还有javaFX插件,jdk版本都1.8都换了好几次了还是无济于事。

            报错信息。
            ![图片说明](https://img-ask.csdn.net/upload/201811/14/1542186545_891315.png)

2个回答

yangxie0817
yangxie0817 谢谢,试了真的可以,尽管我还是用的1.8得jdk,POM引入那个openjfx的两个jar错误解决了,万分感谢。
一年多之前 回复
yangxie0817
yangxie0817 谢谢,但是这个用的是JDK11啊,jdk11和fx sdk分离出来了。我这个用的是JDK1.8
一年多之前 回复

谢谢,试了真的可以,尽管我还是用的1.8得jdk,POM引入那个openjfx的两个jar错误解决了,万分感谢。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
安装eclipse出错log,什么原因

[2019-08-25 21:28:31] Executing bootstrap tasks [2019-08-25 21:28:31] Java(TM) SE Runtime Environment 12.0.2+10 [2019-08-25 21:28:31] Product org.eclipse.products.epp.package.jee.2019-06 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup 1.13.0.v20190530-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup.core 1.13.0.v20190531-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Bundle org.eclipse.oomph.setup.p2 1.11.0.v20190530-1228, build=4030, branch=ed8d2fdcc99c1d3461399fc1bee02645433fa697 [2019-08-25 21:28:31] Performing P2 Director (Eclipse IDE for Enterprise Java Developers (2019-06)) [2019-08-25 21:28:31] Offline = false [2019-08-25 21:28:31] Mirrors = true [2019-08-25 21:28:31] Resolving 89 requirements from 3 repositories to E:\eclipse\eclipse\eclipse [2019-08-25 21:28:31] Requirement epp.package.jee [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.platform.feature.group [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.rcp.feature.group [4.12.0,5.0.0) [2019-08-25 21:28:31] Requirement org.eclipse.buildship.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.cft.server.core.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.cft.server.ui.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.common.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.designer.core.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.designer.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.connectivity.oda.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.doc.user.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.apache.derby.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.hsqldb.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.ibm.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.ingres.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.jdbc.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.jdt.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.msft.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.mysql.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.oda.designer.feature.feature.group [2019-08-25 21:28:31] Requirement org.eclipse.datatools.enablement.oda.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.oracle.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.postgresql.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sap.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sdk.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sqlite.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.enablement.sybase.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.intro.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.modelbase.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sdk.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.data.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.ddl.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.ddlgen.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.parsers.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.results.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.schemaobjecteditor.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqldevtools.sqlbuilder.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.datatools.sqltools.doc.user.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.eclemma.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.egit.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.egit.mylyn.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.epp.mpc.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jdt.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.common.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.common.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jaxb.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jaxb.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jpa.eclipselink.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jpt.jpa.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jsf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.common.fproj.enablement.jdt.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.enterprise_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.jsf.apache.trinidad.tagsupport.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_adapters.ext.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_adapters.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.server_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.web_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.webpageeditor.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.axis2tools.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.cxf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.jaxws.dom.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.jst.ws.jaxws.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.logback.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jaxrs.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jpa.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.m2e.wtp.jsf.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.bugzilla_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.context_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.ide_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.java_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn.wikitext_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.mylyn_feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.pde.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.tips.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.tm.terminal.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.common.fproj.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.jsdt.chromium.debug.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.jsdt.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.server_adapters.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.web_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.xml_ui.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.wst.xsl.feature.feature.group [2019-08-25 21:28:32] Requirement org.eclipse.oomph.setup.feature.group [2019-08-25 21:28:32] Repository http://download.eclipse.org/technology/epp/packages/2019-06 [2019-08-25 21:28:32] Repository http://download.eclipse.org/releases/2019-06/201906191000 [2019-08-25 21:28:32] Repository http://download.eclipse.org/oomph/updates/milestone/latest [2019-08-25 21:32:11] ERROR: org.eclipse.equinox.p2.transport.ecf code=1002 Unable to read repository at http://download.eclipse.org/releases/2019-06/201906191000/content.xml.xz. java.net.SocketTimeoutException: Read timed out at java.base/java.net.SocketInputStream.socketRead0(Native Method) at java.base/java.net.SocketInputStream.socketRead(SocketInputStream.java:115) at java.base/java.net.SocketInputStream.read(SocketInputStream.java:168) at java.base/java.net.SocketInputStream.read(SocketInputStream.java:140) at org.apache.http.impl.io.SessionInputBufferImpl.streamRead(SessionInputBufferImpl.java:137) at org.apache.http.impl.io.SessionInputBufferImpl.fillBuffer(SessionInputBufferImpl.java:153) at org.apache.http.impl.io.SessionInputBufferImpl.read(SessionInputBufferImpl.java:206) at org.apache.http.impl.io.ChunkedInputStream.read(ChunkedInputStream.java:189) at org.apache.http.conn.EofSensorInputStream.read(EofSensorInputStream.java:135) at java.base/java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:243) at java.base/java.util.zip.InflaterInputStream.read(InflaterInputStream.java:159) at java.base/java.util.zip.GZIPInputStream.read(GZIPInputStream.java:118) at org.apache.http.client.entity.LazyDecompressingInputStream.read(LazyDecompressingInputStream.java:70) at java.base/java.io.FilterInputStream.read(FilterInputStream.java:133) at java.base/java.io.FilterInputStream.read(FilterInputStream.java:107) at org.eclipse.ecf.provider.filetransfer.retrieve.AbstractRetrieveFileTransfer$1.performFileTransfer(AbstractRetrieveFileTransfer.java:178) at org.eclipse.ecf.filetransfer.FileTransferJob.run(FileTransferJob.java:74) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63) [2019-08-25 21:32:11]

错误: 缺少 JavaFX 运行时组件?

![图片说明](https://img-ask.csdn.net/upload/201707/30/1501378846_734306.png) ![图片说明](https://img-ask.csdn.net/upload/201707/30/1501378856_791364.png) ![图片说明](https://img-ask.csdn.net/upload/201707/30/1501378866_243495.png) 这个 **错误: 缺少 JavaFX 运行时组件, 需要使用该组件来运行此应用程序**是由什么引起的?

怎么在eclipse中开发javaFx?

我的JDK是1.8,怎么样才能在eclipse中开发javaFX?是不是要配置什么东西?求解

JavaFX代码运行之后报错找不到或无法加载主类?

出现报错 错误: 找不到或无法加载主类 com.Test.MyJavaFX 原因: java.lang.NoClassDefFoundError: javafx/application/Application 附上代码 package com.Test; import javafx.application.Application; import javafx.scene.Scene; import javafx.scene.control.Button; import javafx.stage.Stage; public class MyJavaFX extends Application{ @Override public void start(Stage primaryStage) { Button btOK = new Button("OK"); Scene scene = new Scene(btOK, 200, 250); primaryStage.setTitle("MyJavaFX"); primaryStage.setScene(scene); primaryStage.show(); } public static void main(String[] args) { Application.launch(args); } }

用maven打了一个可运行jar,但是运行提示找不到类

``` <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>oms</groupId> <artifactId>international</artifactId> <version>0.0.1-SNAPSHOT</version> <properties> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> </properties> <dependencies> <!-- https://mvnrepository.com/artifact/org.apache.httpcomponents/httpclient --> <dependency> <groupId>org.apache.httpcomponents</groupId> <artifactId>httpclient</artifactId> <version>4.5.5</version> <scope>compile</scope> </dependency> <!-- https://mvnrepository.com/artifact/com.alibaba/fastjson --> <dependency> <groupId>com.alibaba</groupId> <artifactId>fastjson</artifactId> <version>1.2.54</version> <scope>compile</scope> </dependency> <!-- https://mvnrepository.com/artifact/org.apache.commons/commons-lang3 --> <dependency> <groupId>org.apache.commons</groupId> <artifactId>commons-lang3</artifactId> <version>3.8.1</version> </dependency> </dependencies> <build> <pluginManagement> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-jar-plugin</artifactId> <configuration> <source>1.8</source> <target>1.8</target> <archive> <manifest> <mainClass>oms.window.Windowtest</mainClass> <addClasspath>true</addClasspath> </manifest> </archive> </configuration> </plugin> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <configuration> <source>1.8</source> <target>1.8</target> </configuration> </plugin> </plugins> </pluginManagement> </build> </project> ``` ![图片说明](https://img-ask.csdn.net/upload/201901/11/1547209747_503837.png)

把别人的项目导入eclipse,报一些import错

![图片说明](https://img-ask.csdn.net/upload/201801/07/1515337006_199902.gif) The import java.time cannot be resolved错 The import javafx cannot be resolved错 The import javax.security.auth.message cannot be resolved错

JAva fx提示错误: 缺少 JavaFX 运行时组件, 需要使用该组件来运行此应用程序

运行main程序提示不行啊! 以下是相关图片说明,求大神看看 急 还有就是如果想做java软件手机app那种,推荐用什么软件开发吗,eclipse可以吗![图片说明](https://img-ask.csdn.net/upload/201903/14/1552557064_758364.png)![图片说明](https://img-ask.csdn.net/upload/201903/14/1552557073_756852.png) ?

javafx-src和src有什么区别

如题,还在自学Java,昨天想看一下ArrayList的源码,然后发现我的eclipse和NetBeans都不能打开源码。 百度解决方法多次尝试以后发现我的jdk中没有src.zip文件,相反多出来一个javafx-src.zip,请问这两个是一个东西么? 如果是,那么ide不能看源码的问题该如何解答,如果不是,该去如何下载正确的src

javaFx问题 InvocationTargetException

我是一javaFx初学者,据网上说javaFX已经打包入jdk1.8了,按理说就不在需要导入任何包了(网上教程也是这么说的),我用的NetBeans开发的,也装好了jdk1.8,建项目的时候也选的1.8,报错网上搜了一圈确是找不到包。。。。。。。。。跪求大神 错误如下: ```ant -f E:\\netbeats\\JavaFXApplication1 -Djavac.includes=javafxapplication1/Login.java -Dnb.internal.action.name=run.single -Drun.class=javafxapplication1.Login run-single init: Deleting: E:\netbeats\JavaFXApplication1\build\built-jar.properties deps-jar: Updating property file: E:\netbeats\JavaFXApplication1\build\built-jar.properties Compiling 1 source file to E:\netbeats\JavaFXApplication1\build\classes compile-single: run-single: Exception in Application start method java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at com.sun.javafx.application.LauncherImpl.launchApplicationWithArgs(LauncherImpl.java:389) at com.sun.javafx.application.LauncherImpl.launchApplication(LauncherImpl.java:328) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at sun.launcher.LauncherHelper$FXHelper.main(LauncherHelper.java:767) Caused by: java.lang.RuntimeException: Exception in Application start method at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:917) at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$155(LauncherImpl.java:182) at java.lang.Thread.run(Thread.java:748) Caused by: java.lang.NullPointerException at javafxapplication1.Login.start(Login.java:91) at com.sun.javafx.application.LauncherImpl.lambda$launchApplication1$162(LauncherImpl.java:863) at com.sun.javafx.application.PlatformImpl.lambda$runAndWait$175(PlatformImpl.java:326) at com.sun.javafx.application.PlatformImpl.lambda$null$173(PlatformImpl.java:295) at java.security.AccessController.doPrivileged(Native Method) at com.sun.javafx.application.PlatformImpl.lambda$runLater$174(PlatformImpl.java:294) at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95) at com.sun.glass.ui.win.WinApplication._runLoop(Native Method) at com.sun.glass.ui.win.WinApplication.lambda$null$148(WinApplication.java:191) ... 1 more Exception running application javafxapplication1.Login E:\netbeats\JavaFXApplication1\nbproject\build-impl.xml:1052: The following error occurred while executing this line: E:\netbeats\JavaFXApplication1\nbproject\build-impl.xml:806: Java returned: 1 BUILD FAILED (total time: 1 second) ``` 代码如下: ``` /* * To change this license header, choose License Headers in Project Properties. * To change this template file, choose Tools | Templates * and open the template in the editor. */ package javafxapplication1; import javafx.application.Application; import javafx.event.ActionEvent; import javafx.event.EventHandler; import javafx.geometry.Insets; import javafx.geometry.Pos; import javafx.scene.Scene; import javafx.scene.control.Button; import javafx.scene.control.Label; import javafx.scene.control.PasswordField; import javafx.scene.control.TextField; import javafx.scene.layout.GridPane; import javafx.scene.layout.HBox; import javafx.scene.paint.Color; import javafx.scene.text.Font; import javafx.scene.text.FontWeight; import javafx.scene.text.Text; import javafx.stage.Stage; /** * * @author Administrator */ public class Login extends Application{ //start javafx的程序入口 @Override public void start(Stage primaryStage) throws Exception { //设置窗体头部的名称 primaryStage.setTitle("JavaFx Welcome"); GridPane grid = new GridPane(); grid.setAlignment(Pos.CENTER); grid.setHgap(10); grid.setVgap(10); grid.setPadding(new Insets(25,25,25,25)); //创建一个不可编辑的text对象 Text scenetitle = new Text("影锋"); //设置字体,粗细,字号 scenetitle.setFont(Font.font("Tahoma", FontWeight.NORMAL, 20)); //添加到面板 0列0行 列跨度为2 行跨度为1 grid.add(scenetitle, 0, 0,2,1); //创建文本 Label userName = new Label("User Name:"); //1列1行 grid.add(userName, 0, 1); //创建文本框 TextField userTextField = new TextField(); grid.add(userTextField, 1, 1); Label pw = new Label("Password:"); grid.add(pw, 0, 2); PasswordField pwBox = new PasswordField(); grid.add(pwBox, 1, 2); //添加按钮 Button btn =new Button("提交"); //创建布局面板,设置它的间距为10 HBox hbBtn = new HBox(10); //设置与面板的其他控件对其 hbBtn.setAlignment(Pos.BOTTOM_RIGHT); //添加到hbBtn面板的节点中 hbBtn.getChildren().add(btn); //添加到grid中 grid.add(hbBtn, 1, 4); //增加用于显示信息的文本 final Text actiontarget = new Text(); grid.add(actiontarget, 1, 6); btn.setOnAction(new EventHandler<ActionEvent>() { @Override public void handle(ActionEvent e) { actiontarget.setFill(Color.FIREBRICK); actiontarget.setText("Sign in button pressed"); } }); //设置窗体对象的的大小 Scene scene = new Scene(grid,300,275); primaryStage.setScene(scene); scene.getStylesheets().add(Login.class.getResource("Login.css").toExternalForm()); primaryStage.show(); } public static void main(String[]args){ launch(args); ```

OpenJdk platform binary idea64启动报错

parallel desktop 虚拟机中装了win7,win7中安装idea64,就简单写了个helloworld输出,运行就报以下错误,win7中的显卡也升级不了 Error:Abnormal build process termination: "C:\Me\JetBrains\IntelliJ IDEA 2018.3.3\jre64\bin\java.exe" -Xmx700m -Djava.awt.headless=true -Djava.endorsed.dirs=\"\" -Djdt.compiler.useSingleThread=true -Dcompile.parallel=false -Drebuild.on.dependency.change=true -Djava.net.preferIPv4Stack=true -Dio.netty.initialSeedUniquifier=5762697851691075053 -Dfile.encoding=GBK -Duser.language=zh -Duser.country=CN -Didea.paths.selector=IntelliJIdea2018.3 "-Didea.home.path=C:\Me\JetBrains\IntelliJ IDEA 2018.3.3" -Didea.config.path=C:\Users\Brazen\.IntelliJIdea2018.3\config -Didea.plugins.path=C:\Users\Brazen\.IntelliJIdea2018.3\config\plugins -Djps.log.dir=C:/Users/Brazen/.IntelliJIdea2018.3/system/log/build-log "-Djps.fallback.jdk.home=C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/jre64" -Djps.fallback.jdk.version=1.8.0_152-release -Dio.netty.noUnsafe=true -Djava.io.tmpdir=C:/Users/Brazen/.IntelliJIdea2018.3/system/compile-server/test_f6da7a95/_temp_ -Djps.backward.ref.index.builder=true -Dkotlin.incremental.compilation=true -Dkotlin.daemon.enabled -Dkotlin.daemon.client.alive.path=\"C:\Users\Brazen\AppData\Local\Temp\kotlin-idea-3894503579951865671-is-running\" -classpath "C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jps-launcher.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/jre64/lib/tools.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/optimizedFileManager.jar" org.jetbrains.jps.cmdline.Launcher "C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/netty-common-4.1.30.Final.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/annotations.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jps-builders.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-spi-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-builder-support-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-aether-provider-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/oro-2.0.8.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/slf4j-api-1.7.25.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/httpcore-4.4.10.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/nanoxml-2.2.3.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/plexus-interpolation-1.21.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-impl-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/commons-lang3-3.4.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/commons-codec-1.10.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/forms_rt.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/trove4j.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-model-builder-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jps-model.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/idea_rt.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/util.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/plexus-component-annotations-1.6.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/protobuf-java-3.4.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/netty-buffer-4.1.30.Final.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/asm-all-7.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/log4j.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-dependency-resolver.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/guava-25.1-jre.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-connector-basic-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/netty-resolver-4.1.30.Final.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-transport-http-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/commons-logging-1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/resources_en.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-api-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-repository-metadata-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jna-platform.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-util-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/netty-transport-4.1.30.Final.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/aether-transport-file-1.1.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jna.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/netty-codec-4.1.30.Final.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/httpclient-4.5.6.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/lz4-1.3.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/platform-api.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-artifact-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jdom.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/maven-model-3.3.9.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/forms-1.1-preview.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/jps-builders-6.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/javac2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/plexus-utils-3.0.22.jar;;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/gson-2.8.5.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/jarutils.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/guava-25.1-jre.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/common-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/manifest-merger-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/sdk-common-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/builder-model-3.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/builder-test-api-3.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/ddmlib-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/repository-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/gradle/lib/gradle-api-4.10.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/gson-2.8.5.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/jarutils.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/lib/guava-25.1-jre.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/common-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/manifest-merger-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/sdk-common-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/builder-model-3.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/builder-test-api-3.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/ddmlib-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/repository-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/gradle/lib/gradle-api-4.10.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/ant/lib/ant-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/uiDesigner/lib/jps/ui-designer-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/IntelliLang/lib/intellilang-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Groovy/lib/groovy-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Groovy/lib/groovy-rt-constants.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/eclipse/lib/eclipse-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/eclipse/lib/common-eclipse-util.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/maven/lib/maven-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/osmorc/lib/osmorc-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/osmorc/lib/biz.aQute.bndlib-4.0.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/osmorc/lib/biz.aQute.repository-4.0.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/osmorc/lib/biz.aQute.resolve-4.0.0.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/osmorc/lib/bundlor-all.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/aspectj/lib/aspectj-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/gradle/lib/gradle-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/devkit/lib/devkit-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/JavaEE/lib/javaee-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/JavaEE/lib/jps/jpa-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/webSphereIntegration/lib/jps/webSphere-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/weblogicIntegration/lib/jps/weblogic-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/jps/android-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/android-common.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/build-common.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/android-rt.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/sdklib.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/common-26.1.2.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/jarutils.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/android/lib/layoutlib-api.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/javaFX/lib/javaFX-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/javaFX/lib/common-javaFX-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/jps/kotlin-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/kotlin-stdlib.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/kotlin-reflect.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/kotlin-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/android-extensions-ide.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Kotlin/lib/android-extensions-compiler.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/flex/lib/flex-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/flex/lib/flex-shared.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/dmServer/lib/dmServer-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/GwtStudio/lib/gwt-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/GoogleAppEngine/lib/google-app-engine-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/GoogleAppEngine/lib/appEngine-runtime.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Grails/lib/grails-jps-plugin.jar;C:/Me/JetBrains/IntelliJ IDEA 2018.3.3/plugins/Grails/lib/grails-compiler-patch.jar" org.jetbrains.jps.cmdline.BuildMain 127.0.0.1 49669 1e1dfc85-eb4c-4dc1-b38c-ed6896c49276 C:/Users/Brazen/.IntelliJIdea2018.3/system/compile-server

IDEA启动报错 Abnormal build process termination

``` Error:Abnormal build process termination: D:\ideaIU-2017.3.3.win\jre64\bin\java -Xmx700m -Djava.awt.headless=true -Djava.endorsed.dirs=\"\" -Djdt.compiler.useSingleThread=true -Dpreload.project.path=D:/ydworkspase/kywdop -Dpreload.config.path=C:/Users/Administrator/.IntelliJIdea2017.3/config/options -Dcompile.parallel=false -Drebuild.on.dependency.change=true -Djava.net.preferIPv4Stack=true -Dio.netty.initialSeedUniquifier=2572012221901114533 -Dfile.encoding=GBK -Duser.language=zh -Duser.country=CN -Didea.paths.selector=IntelliJIdea2017.3 -Didea.home.path=D:\ideaIU-2017.3.3.win -Didea.config.path=C:\Users\Administrator\.IntelliJIdea2017.3\config -Didea.plugins.path=C:\Users\Administrator\.IntelliJIdea2017.3\config\plugins -Djps.log.dir=C:/Users/Administrator/.IntelliJIdea2017.3/system/log/build-log -Djps.fallback.jdk.home=D:/ideaIU-2017.3.3.win/jre64 -Djps.fallback.jdk.version=1.8.0_152-release -Dio.netty.noUnsafe=true -Djava.io.tmpdir=C:/Users/Administrator/.IntelliJIdea2017.3/system/compile-server/kywdop_7993818d/_temp_ -Djps.backward.ref.index.builder=true -Dkotlin.incremental.compilation=true -Dkotlin.daemon.enabled -Dkotlin.daemon.client.alive.path=\"C:\Users\ADMINI~1\AppData\Local\Temp\kotlin-idea-6663494920534556338-is-running\" -classpath D:/ideaIU-2017.3.3.win/lib/jps-launcher.jar;D:/ideaIU-2017.3.3.win/jre64/lib/tools.jar;D:/ideaIU-2017.3.3.win/lib/optimizedFileManager.jar org.jetbrains.jps.cmdline.Launcher D:/ideaIU-2017.3.3.win/lib/jna.jar;D:/ideaIU-2017.3.3.win/lib/annotations.jar;D:/ideaIU-2017.3.3.win/lib/guava-21.0.jar;D:/ideaIU-2017.3.3.win/lib/aether-1.1.0-all.jar;D:/ideaIU-2017.3.3.win/lib/jps-model.jar;D:/ideaIU-2017.3.3.win/lib/openapi.jar;D:/ideaIU-2017.3.3.win/lib/commons-logging-1.2.jar;D:/ideaIU-2017.3.3.win/lib/aether-dependency-resolver.jar;D:/ideaIU-2017.3.3.win/lib/nanoxml-2.2.3.jar;D:/ideaIU-2017.3.3.win/lib/resources_en.jar;D:/ideaIU-2017.3.3.win/lib/trove4j.jar;D:/ideaIU-2017.3.3.win/lib/snappy-in-java-0.5.1.jar;D:/ideaIU-2017.3.3.win/lib/jps-builders-6.jar;D:/ideaIU-2017.3.3.win/lib/log4j.jar;D:/ideaIU-2017.3.3.win/lib/protobuf-java-2.5.0.jar;D:/ideaIU-2017.3.3.win/lib/asm-all.jar;D:/ideaIU-2017.3.3.win/lib/forms_rt.jar;D:/ideaIU-2017.3.3.win/lib/httpcore-4.4.5.jar;D:/ideaIU-2017.3.3.win/lib/jna-platform.jar;D:/ideaIU-2017.3.3.win/lib/slf4j-api-1.7.10.jar;D:/ideaIU-2017.3.3.win/lib/jdom.jar;D:/ideaIU-2017.3.3.win/lib/httpclient-4.5.2.jar;D:/ideaIU-2017.3.3.win/lib/jps-builders.jar;D:/ideaIU-2017.3.3.win/lib/oromatcher.jar;D:/ideaIU-2017.3.3.win/lib/commons-codec-1.9.jar;D:/ideaIU-2017.3.3.win/lib/util.jar;D:/ideaIU-2017.3.3.win/lib/jgoodies-forms.jar;D:/ideaIU-2017.3.3.win/lib/netty-all-4.1.13.Final.jar;D:/ideaIU-2017.3.3.win/lib/maven-aether-provider-3.3.9-all.jar;D:/ideaIU-2017.3.3.win/lib/idea_rt.jar;D:/ideaIU-2017.3.3.win/lib/javac2.jar;;D:/ideaIU-2017.3.3.win/lib/gson-2.8.2.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/jarutils.jar;D:/ideaIU-2017.3.3.win/lib/guava-21.0.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/android-common.jar;D:/ideaIU-2017.3.3.win/plugins/gradle/lib/gradle-tooling-api-4.0.jar;D:/ideaIU-2017.3.3.win/lib/gson-2.8.2.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/jarutils.jar;D:/ideaIU-2017.3.3.win/lib/guava-21.0.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/android-common.jar;D:/ideaIU-2017.3.3.win/plugins/gradle/lib/gradle-tooling-api-4.0.jar;D:/ideaIU-2017.3.3.win/plugins/ant/lib/ant-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/uiDesigner/lib/jps/ui-designer-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/IntelliLang/lib/intellilang-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/Groovy/lib/groovy-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/Groovy/lib/groovy-rt-constants.jar;D:/ideaIU-2017.3.3.win/plugins/eclipse/lib/eclipse-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/eclipse/lib/common-eclipse-util.jar;D:/ideaIU-2017.3.3.win/plugins/maven/lib/maven-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/maven/lib/plexus-utils-2.0.6.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/osmorc-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/bndlib-3.3.0.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/bnd-repository-3.3.0.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/bnd-resolve-3.3.0.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/plexus-utils-3.0.10.jar;D:/ideaIU-2017.3.3.win/plugins/osmorc/lib/bundlor-all.jar;D:/ideaIU-2017.3.3.win/plugins/aspectj/lib/aspectj-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/flex/lib/flex-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/flex/lib/flex-shared.jar;D:/ideaIU-2017.3.3.win/plugins/gradle/lib/gradle-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/devkit/lib/devkit-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/JavaEE/lib/javaee-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/JavaEE/lib/jps/jpa-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/webSphereIntegration/lib/jps/webSphere-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/weblogicIntegration/lib/jps/weblogic-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/dmServer/lib/dmServer-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/GwtStudio/lib/gwt-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/GoogleAppEngine/lib/google-app-engine-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/GoogleAppEngine/lib/appEngine-runtime.jar;D:/ideaIU-2017.3.3.win/plugins/Grails/lib/grails-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/Grails/lib/grails-compiler-patch.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/jps/android-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/android-common.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/android-rt.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/sdk-common.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/repository.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/sdklib.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/jarutils.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/layoutlib-api.jar;D:/ideaIU-2017.3.3.win/plugins/android/lib/manifest-merger.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/jps/kotlin-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/kotlin-stdlib.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/kotlin-reflect.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/kotlin-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/android-extensions-ide.jar;D:/ideaIU-2017.3.3.win/plugins/Kotlin/lib/android-extensions-compiler.jar;D:/ideaIU-2017.3.3.win/plugins/javaFX/lib/javaFX-jps-plugin.jar;D:/ideaIU-2017.3.3.win/plugins/javaFX/lib/common-javaFX-plugin.jar org.jetbrains.jps.cmdline.BuildMain 127.0.0.1 64844 8759eab2-d18e-4afe-82d1-bedce519aed2 C:/Users/Administrator/.IntelliJIdea2017.3/system/compile-server Build process started. Classpath: D:/ideaIU-2017.3.3.win/lib/jps-launcher.jar;D:/ideaIU-2017.3.3.win/jre64/lib/tools.jar;D:/ideaIU-2017.3.3.win/lib/optimizedFileManager.jar SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".SLF4J: Defaulting to no-operation (NOP) logger implementationSLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.Error connecting to 127.0.0.1:64844; reason: Address already in use: no further information: /127.0.0.1:64844 io.netty.channel.AbstractChannel$AnnotatedSocketException: Address already in use: no further information: /127.0.0.1:64844 at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method) at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:717) at io.netty.channel.socket.nio.NioSocketChannel.doFinishConnect(NioSocketChannel.java:352) at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.finishConnect(AbstractNioChannel.java:340) at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:632) at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:579) at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:496) at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:458) at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) at java.lang.Thread.run(Thread.java:745) Caused by: java.net.BindException: Address already in use: no further information ... 10 more Exiting. ```

JavaFX 部署 运行出错

刚学JavaFX 跟着教程 一步一步往下做, 到部署的时候 右键bulid.xml文件, Run as ==> Ant build 报错 谁知道可能是什么原因吗? init-fx-tasks: [taskdef] Could not load definitions from resource com/sun/javafx/tools/ant/antlib.xml. It could not be found. do-deploy: [copy] Copying 3 files to D:\MyWork\git\git-demo\pack_fx\build\dist\libs BUILD FAILED D:\MyWork\git\git-demo\pack_fx\build\build.xml:116: Problem: failed to create task or type javafx:com.sun.javafx.tools.ant:resources Cause: The name is undefined. Action: Check the spelling. Action: Check that any custom tasks/types have been declared. Action: Check that any <presetdef>/<macrodef> declarations have taken place. No types or tasks have been defined in this namespace yet ![图片说明](https://img-ask.csdn.net/upload/201603/18/1458285677_954386.png)

JavaFX-CSS中label字体加粗怎么实现

使用-fx-font:bloder 12px "宋体";怎么控制不了啊,求救。。。。

如何把Javafx程序打包成EXE文件

把Javafx程序打包成EXE文件,程序里含有配置文件。我原先用exe4j打包的时候,总是说找不到配置文件,就会一直报错。

NetBeans 8.2冻结在Ubuntu 17.04上[关闭]

<div class="post-text" itemprop="text"> <p>Frequently NetBeans 8.2 freeze on Ubuntu 17.04 with the following error:</p> <blockquote> <p>GLib:ERROR:../../../../glib/ghash.c:373:g_hash_table_lookup_node:assertion failed: (hash_table-&gt;ref_count &gt; 0) /home/caiofior/netbeans-8.2/platform/lib/nbexec: riga 470: 4898 Annullato (core dump creato) "/usr/bin/java" -Djdk.home="/usr" -classpath "/home/caiofior/netbeans-8.2/platform/lib/boot.jar:/home/caiofior/netbeans-8.2/platform/lib/org-openide-modules.jar:/home/caiofior/netbeans-8.2/platform/lib/org-openide-util.jar:/home/caiofior/netbeans-8.2/platform/lib/org-openide-util-lookup.jar:/home/caiofior/netbeans-8.2/platform/lib/org-openide-util-ui.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/boot_ja.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/boot_pt_BR.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/boot_ru.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/boot_zh_CN.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-modules_ja.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-modules_pt_BR.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-modules_ru.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-modules_zh_CN.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util_ja.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-lookup_ja.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-lookup_pt_BR.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-lookup_ru.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-lookup_zh_CN.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util_pt_BR.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util_ru.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-ui_ja.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-ui_pt_BR.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-ui_ru.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util-ui_zh_CN.jar:/home/caiofior/netbeans-8.2/platform/lib/locale/org-openide-util_zh_CN.jar" -Dnetbeans.default_userdir_root="/home/caiofior/.netbeans" -Dnetbeans.dirs="/home/caiofior/netbeans-8.2/nb:/home/caiofior/netbeans-8.2/ergonomics:/home/caiofior/netbeans-8.2/ide:/home/caiofior/netbeans-8.2/extide:/home/caiofior/netbeans-8.2/java:/home/caiofior/netbeans-8.2/apisupport:/home/caiofior/netbeans-8.2/webcommon:/home/caiofior/netbeans-8.2/websvccommon:/home/caiofior/netbeans-8.2/enterprise:/home/caiofior/netbeans-8.2/mobility:/home/caiofior/netbeans-8.2/profiler:/home/caiofior/netbeans-8.2/python:/home/caiofior/netbeans-8.2/php:/home/caiofior/netbeans-8.2/identity:/home/caiofior/netbeans-8.2/harness:/home/caiofior/netbeans-8.2/cnd:/home/caiofior/netbeans-8.2/cndext:/home/caiofior/netbeans-8.2/dlight:/home/caiofior/netbeans-8.2/groovy:/home/caiofior/netbeans-8.2/extra:/home/caiofior/netbeans-8.2/javacard:/home/caiofior/netbeans-8.2/javafx:" -Dnetbeans.home="/home/caiofior/netbeans-8.2/platform" '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade' '-Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense' '-Xmx1024m' '-client' '-Xss2m' '-Xms32m' '-Dapple.laf.useScreenMenuBar=true' '-Dapple.awt.graphics.UseQuartz=true' '-Dsun.java2d.noddraw=true' '-Dsun.java2d.dpiaware=true' '-Dsun.zip.disableMemoryMapping=true' -DaddExports:java.desktop/sun.awt=ALL-UNNAMED -DaddExports:java.base/jdk.internal.jrtfs=ALL-UNNAMED -DaddExports:java.desktop/java.awt.peer=ALL-UNNAMED -DaddExports:java.desktop/com.sun.beans.editors=ALL-UNNAMED -DaddExports:java.desktop/sun.awt.im=ALL-UNNAMED -DaddExports:java.desktop/com.sun.java.swing.plaf.gtk=ALL-UNNAMED -DaddExports:java.management/sun.management=ALL-UNNAMED -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath="/home/caiofior/.netbeans/8.2/var/log/heapdump.hprof" -splash:"/home/caiofior/.cache/netbeans/8.2/splash.png" org.netbeans.Main --cachedir "/home/caiofior/.cache/netbeans/8.2" --userdir "/home/caiofior/.netbeans/8.2" "--branding" "nb" 0&lt;&amp;0</p> </blockquote> </div>

idea下启动项目报错,但是在eclipse下启动运行正常

idea下启动项目报错,但是在eclipse下启动运行正常,用的tomcat,报错信息如下,求解答! 不知道有什么问题,搞了一早上也没有解决! ![图片说明](https://img-ask.csdn.net/upload/201508/10/1439187671_19928.png) ![图片说明](https://img-ask.csdn.net/upload/201508/10/1439187681_281520.png)

使用 maven 进行javaFX 打包 可是包运行不了??

我才用maven进行打包 <plugin> <artifactId>maven-compiler-plugin</artifactId> <version>2.10</version> <configuration> <source>1.8</source> <target>1.8</target> <encoding>UTF-8</encoding> </configuration> </plugin> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-assembly-plugin</artifactId> <version>3.1.0</version> <executions> <execution> <phase>package</phase> <goals> <goal>single</goal> </goals> <configuration> <archive> <manifest> <mainClass> com.pa1500.MainApp </mainClass> </manifest> </archive> <descriptorRefs> <descriptorRef>jar-with-dependencies</descriptorRef> </descriptorRefs> </configuration> </execution> </executions> </plugin> 以上就是我的build 配置 但是打出来的包不能运行 提示有个本地包没有找到??求jie

javaFX字体加粗/斜体都不能使用

fontFamilyStr = FontUtil.getFxFontName(fontFamilyStr.trim()); switch(fontStyle){ case 0://regular font=Font.font(fontFamilyStr, FontPosture.REGULAR, fontSize); break; case 1://bold font=Font.font(fontFamilyStr, FontWeight.BOLD, fontSize); break; case 2://italic font=Font.font(fontFamilyStr, FontPosture.ITALIC, fontSize); break; case 3://bold_italic font=Font.font(fontFamilyStr, FontWeight.BOLD, FontPosture.ITALIC,fontSize); break; default: break; } return font; ![图片说明](https://img-ask.csdn.net/upload/201703/23/1490236943_490309.png)

JavaFX异常:Exception in Application start method

``` package com.shun.demo; import javafx.application.Application; import javafx.scene.paint.Color; import javafx.scene.control.*; import javafx.scene.layout.*; import javafx.scene.text.*; import javafx.stage.Stage; import javafx.scene.Scene; public class JavaFX extends Application { @Override public void start(Stage primaryStage) { //Panes StackPane stackPane=new StackPane(); GridPane gridPane=new GridPane(); //Nodes Button button=new Button("OK"); TextField textUsername=new TextField(); textUsername.setPromptText("Please Enter your Username..."); PasswordField textPassword=new PasswordField(); textPassword.setPromptText("Please Enter your Password..."); //Panes gridPane.add(new Label("Username:"),0,0); gridPane.add(textUsername,1,0); gridPane.add(new Label("Password:"),0,1); gridPane.add(textPassword,1,1); gridPane.add(button,2,1); stackPane.getChildren().add(gridPane); Scene scene=new Scene(stackPane,200,200); //Stage primaryStage.setScene(scene); primaryStage.setTitle("MyJavaFX"); primaryStage.show(); } public static void main(String[] args) { launch(args); } } ``` 求解决。

在中国程序员是青春饭吗?

今年,我也32了 ,为了不给大家误导,咨询了猎头、圈内好友,以及年过35岁的几位老程序员……舍了老脸去揭人家伤疤……希望能给大家以帮助,记得帮我点赞哦。 目录: 你以为的人生 一次又一次的伤害 猎头界的真相 如何应对互联网行业的「中年危机」 一、你以为的人生 刚入行时,拿着傲人的工资,想着好好干,以为我们的人生是这样的: 等真到了那一天,你会发现,你的人生很可能是这样的: ...

再不跳槽,应届毕业生拿的都比我多了!

跳槽几乎是每个人职业生涯的一部分,很多HR说“三年两跳”已经是一个跳槽频繁与否的阈值了,可为什么市面上有很多程序员不到一年就跳槽呢?他们不担心影响履历吗? PayScale之前发布的**《员工最短任期公司排行榜》中,两家码农大厂Amazon和Google**,以1年和1.1年的员工任期中位数分列第二、第四名。 PayScale:员工最短任期公司排行榜 意外的是,任期中位数极小的这两家公司,薪资...

我以为我学懂了数据结构,直到看了这个导图才发现,我错了

数据结构与算法思维导图

数据库——玩转SQL语句(以MySQL为例)

一、前言 照着大学的SQL server来学

技术大佬:我去,你写的 switch 语句也太老土了吧

昨天早上通过远程的方式 review 了两名新来同事的代码,大部分代码都写得很漂亮,严谨的同时注释也很到位,这令我非常满意。但当我看到他们当中有一个人写的 switch 语句时,还是忍不住破口大骂:“我擦,小王,你丫写的 switch 语句也太老土了吧!” 来看看小王写的代码吧,看完不要骂我装逼啊。 private static String createPlayer(PlayerTypes p...

华为初面+综合面试(Java技术面)附上面试题

华为面试整体流程大致分为笔试,性格测试,面试,综合面试,回学校等结果。笔试来说,华为的难度较中等,选择题难度和网易腾讯差不多。最后的代码题,相比下来就简单很多,一共3道题目,前2题很容易就AC,题目已经记不太清楚,不过难度确实不大。最后一题最后提交的代码过了75%的样例,一直没有发现剩下的25%可能存在什么坑。 笔试部分太久远,我就不怎么回忆了。直接将面试。 面试 如果说腾讯的面试是挥金如土...

和黑客斗争的 6 天!

互联网公司工作,很难避免不和黑客们打交道,我呆过的两家互联网公司,几乎每月每天每分钟都有黑客在公司网站上扫描。有的是寻找 Sql 注入的缺口,有的是寻找线上服务器可能存在的漏洞,大部分都...

讲一个程序员如何副业月赚三万的真实故事

loonggg读完需要3分钟速读仅需 1 分钟大家好,我是你们的校长。我之前讲过,这年头,只要肯动脑,肯行动,程序员凭借自己的技术,赚钱的方式还是有很多种的。仅仅靠在公司出卖自己的劳动时...

上班一个月,后悔当初着急入职的选择了

最近有个老铁,告诉我说,上班一个月,后悔当初着急入职现在公司了。他之前在美图做手机研发,今年美图那边今年也有一波组织优化调整,他是其中一个,在协商离职后,当时捉急找工作上班,因为有房贷供着,不能没有收入来源。所以匆忙选了一家公司,实际上是一个大型外包公司,主要派遣给其他手机厂商做外包项目。**当时承诺待遇还不错,所以就立马入职去上班了。但是后面入职后,发现薪酬待遇这块并不是HR所说那样,那个HR自...

总结了 150 余个神奇网站,你不来瞅瞅吗?

原博客再更新,可能就没了,之后将持续更新本篇博客。

副业收入是我做程序媛的3倍,工作外的B面人生是怎样的?

提到“程序员”,多数人脑海里首先想到的大约是:为人木讷、薪水超高、工作枯燥…… 然而,当离开工作岗位,撕去层层标签,脱下“程序员”这身外套,有的人生动又有趣,马上展现出了完全不同的A/B面人生! 不论是简单的爱好,还是正经的副业,他们都干得同样出色。偶尔,还能和程序员的特质结合,产生奇妙的“化学反应”。 @Charlotte:平日素颜示人,周末美妆博主 大家都以为程序媛也个个不修边幅,但我们也许...

MySQL数据库面试题(2020最新版)

文章目录数据库基础知识为什么要使用数据库什么是SQL?什么是MySQL?数据库三大范式是什么mysql有关权限的表都有哪几个MySQL的binlog有有几种录入格式?分别有什么区别?数据类型mysql有哪些数据类型引擎MySQL存储引擎MyISAM与InnoDB区别MyISAM索引与InnoDB索引的区别?InnoDB引擎的4大特性存储引擎选择索引什么是索引?索引有哪些优缺点?索引使用场景(重点)...

如果你是老板,你会不会踢了这样的员工?

有个好朋友ZS,是技术总监,昨天问我:“有一个老下属,跟了我很多年,做事勤勤恳恳,主动性也很好。但随着公司的发展,他的进步速度,跟不上团队的步伐了,有点...

我入职阿里后,才知道原来简历这么写

私下里,有不少读者问我:“二哥,如何才能写出一份专业的技术简历呢?我总感觉自己写的简历太烂了,所以投了无数份,都石沉大海了。”说实话,我自己好多年没有写过简历了,但我认识的一个同行,他在阿里,给我说了一些他当年写简历的方法论,我感觉太牛逼了,实在是忍不住,就分享了出来,希望能够帮助到你。 01、简历的本质 作为简历的撰写者,你必须要搞清楚一点,简历的本质是什么,它就是为了来销售你的价值主张的。往深...

程序员写出这样的代码,能不挨骂吗?

当你换槽填坑时,面对一个新的环境。能够快速熟练,上手实现业务需求是关键。但是,哪些因素会影响你快速上手呢?是原有代码写的不够好?还是注释写的不够好?昨夜...

离职半年了,老东家又发 offer,回不回?

有小伙伴问松哥这个问题,他在上海某公司,在离职了几个月后,前公司的领导联系到他,希望他能够返聘回去,他很纠结要不要回去? 俗话说好马不吃回头草,但是这个小伙伴既然感到纠结了,我觉得至少说明了两个问题:1.曾经的公司还不错;2.现在的日子也不是很如意。否则应该就不会纠结了。 老实说,松哥之前也有过类似的经历,今天就来和小伙伴们聊聊回头草到底吃不吃。 首先一个基本观点,就是离职了也没必要和老东家弄的苦...

HTTP与HTTPS的区别

面试官问HTTP与HTTPS的区别,我这样回答让他竖起大拇指!

程序员毕业去大公司好还是小公司好?

虽然大公司并不是人人都能进,但我仍建议还未毕业的同学,尽力地通过校招向大公司挤,但凡挤进去,你这一生会容易很多。 大公司哪里好?没能进大公司怎么办?答案都在这里了,记得帮我点赞哦。 目录: 技术氛围 内部晋升与跳槽 啥也没学会,公司倒闭了? 不同的人脉圈,注定会有不同的结果 没能去大厂怎么办? 一、技术氛围 纵观整个程序员技术领域,哪个在行业有所名气的大牛,不是在大厂? 而且众所...

程序员为什么千万不要瞎努力?

本文作者用对比非常鲜明的两个开发团队的故事,讲解了敏捷开发之道 —— 如果你的团队缺乏统一标准的环境,那么即使勤劳努力,不仅会极其耗时而且成果甚微,使用...

为什么程序员做外包会被瞧不起?

二哥,有个事想询问下您的意见,您觉得应届生值得去外包吗?公司虽然挺大的,中xx,但待遇感觉挺低,马上要报到,挺纠结的。

当HR压你价,说你只值7K,你该怎么回答?

当HR压你价,说你只值7K时,你可以流畅地回答,记住,是流畅,不能犹豫。 礼貌地说:“7K是吗?了解了。嗯~其实我对贵司的面试官印象很好。只不过,现在我的手头上已经有一份11K的offer。来面试,主要也是自己对贵司挺有兴趣的,所以过来看看……”(未完) 这段话主要是陪HR互诈的同时,从公司兴趣,公司职员印象上,都给予对方正面的肯定,既能提升HR的好感度,又能让谈判气氛融洽,为后面的发挥留足空间。...

面试阿里p7,被按在地上摩擦,鬼知道我经历了什么?

面试阿里p7被问到的问题(当时我只知道第一个):@Conditional是做什么的?@Conditional多个条件是什么逻辑关系?条件判断在什么时候执...

终于懂了TCP和UDP协议区别

终于懂了TCP和UDP协议区别

无代码时代来临,程序员如何保住饭碗?

编程语言层出不穷,从最初的机器语言到如今2500种以上的高级语言,程序员们大呼“学到头秃”。程序员一边面临编程语言不断推陈出新,一边面临由于许多代码已存在,程序员编写新应用程序时存在重复“搬砖”的现象。 无代码/低代码编程应运而生。无代码/低代码是一种创建应用的方法,它可以让开发者使用最少的编码知识来快速开发应用程序。开发者通过图形界面中,可视化建模来组装和配置应用程序。这样一来,开发者直...

面试了一个 31 岁程序员,让我有所触动,30岁以上的程序员该何去何从?

最近面试了一个31岁8年经验的程序猿,让我有点感慨,大龄程序猿该何去何从。

大三实习生,字节跳动面经分享,已拿Offer

说实话,自己的算法,我一个不会,太难了吧

程序员垃圾简历长什么样?

已经连续五年参加大厂校招、社招的技术面试工作,简历看的不下于万份 这篇文章会用实例告诉你,什么是差的程序员简历! 疫情快要结束了,各个公司也都开始春招了,作为即将红遍大江南北的新晋UP主,那当然要为小伙伴们做点事(手动狗头)。 就在公众号里公开征简历,义务帮大家看,并一一点评。《启舰:春招在即,义务帮大家看看简历吧》 一石激起千层浪,三天收到两百多封简历。 花光了两个星期的所有空闲时...

《C语言函数速查》main()主函数

每一个C程序都必须有一main()函数, 可以根据自己的爱好把它放在程序的某个地方。有些程序员把它放在最前面, 而另一些程序员把它放在最后面, 无论放在哪个地方, 以下几点说明都是适合的。

Java岗开发3年,公司临时抽查算法,离职后这几题我记一辈子

前几天我们公司做了一件蠢事,非常非常愚蠢的事情。我原以为从学校出来之后,除了找工作有测试外,不会有任何与考试有关的事儿。 但是,天有不测风云,公司技术总监、人事总监两位大佬突然降临到我们事业线,叫上我老大,给我们组织了一场别开生面的“考试”。 那是一个风和日丽的下午,我翘着二郎腿,左手端着一杯卡布奇诺,右手抓着我的罗技鼠标,滚动着轮轴,穿梭在头条热点之间。 “淡黄的长裙~蓬松的头发...

大牛都会用的IDEA调试技巧!!!

导读 前天面试了一个985高校的实习生,问了他平时用什么开发工具,他想也没想的说IDEA,于是我抛砖引玉的问了一下IDEA的调试用过吧,你说说怎么设置断点...

立即提问
相关内容推荐