eclipse导入javaFX项目,报缺少javafx-packager:jar:1.8.0_20 搞不定,大神进来帮我看看

无奈网上关于JavaFX相关信息太少,发帖求助。
POM文件报错信息:
Missing artifact javafx-packager:javafx-packager:jar:1.8.0_20

            <dependencies>
    <dependency>
        <groupId>mysql</groupId>
        <artifactId>mysql-connector-java</artifactId>
        <version>${mysql-connector.version}</version>
    </dependency>
    <!--mybatis database mapper -->
    <dependency>
        <groupId>org.mybatis</groupId>
        <artifactId>mybatis</artifactId>
        <version>${mybatis.version}</version>
    </dependency>
    <dependency>
        <groupId>com.fasterxml.jackson.core</groupId>
        <artifactId>jackson-databind</artifactId>
        <version>${jackson.version}</version>
    </dependency>
    <dependency>
        <groupId>net.sf.json-lib</groupId>
        <artifactId>json-lib</artifactId>
        <version>${json-lib.version}</version>
        <classifier>jdk15</classifier>
    </dependency>
    <dependency>
        <groupId>com.github.sarxos</groupId>
        <artifactId>webcam-capture</artifactId>
        <version>${webcam-capture.version}</version>
    </dependency>
    <dependency>
        <groupId>com.zenjava</groupId>
        <artifactId>javafx-maven-plugin</artifactId>
        <version>${javafx-maven-plugin.version}</version>
    </dependency>
    <dependency>
        <groupId>org.slf4j</groupId>
        <artifactId>slf4j-log4j12</artifactId>
        <version>${slf4j.version}</version>
    </dependency>
    <dependency>
        <groupId>net.java.dev.jna</groupId>
        <artifactId>jna</artifactId>
        <version>4.5.2</version>
    </dependency>
    <dependency>
        <groupId>log4j</groupId>
        <artifactId>log4j</artifactId>
        <version>1.2.17</version>
    </dependency>
</dependencies>

并没有引用javafx-packager:javafx-packager:jar:1.8.0_20,不知道为何报错。台式机就没有问题,各种重装eclipse还有javaFX插件,jdk版本都1.8都换了好几次了还是无济于事。

            报错信息。
            ![图片说明](https://img-ask.csdn.net/upload/201811/14/1542186545_891315.png)

2个回答

yangxie0817
yangxie0817 谢谢,试了真的可以,尽管我还是用的1.8得jdk,POM引入那个openjfx的两个jar错误解决了,万分感谢。
11 个月之前 回复
yangxie0817
yangxie0817 谢谢,但是这个用的是JDK11啊,jdk11和fx sdk分离出来了。我这个用的是JDK1.8
11 个月之前 回复

谢谢,试了真的可以,尽管我还是用的1.8得jdk,POM引入那个openjfx的两个jar错误解决了,万分感谢。

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!