npm install realm --save 失败

图片说明图片说明图片说明

2个回答

你的npm的版本是不是10+?

xsb_20171227
今天是星期五 回复z13222038779: 好的,再次感谢
接近 2 年之前 回复
z13222038779
糕天原 回复xsb_20171227: 之前做过RN,遇到过这个问题,然后Google到的。
接近 2 年之前 回复
xsb_20171227
今天是星期五 回复z13222038779: 十分感谢啊!这个问题折磨我几天了。话说你怎么知道需要这么改啊
接近 2 年之前 回复
xsb_20171227
今天是星期五 回复z13222038779: 哈哈,果然有用。
接近 2 年之前 回复
z13222038779
糕天原 回复xsb_20171227:1.执行 npm install --save realm@0.14.3 2.打开node_modules/realm/package.json 删掉"postlink": "node_modules/realm/scripts/rnpm-postlink.js"这行 3.执行react-native link realm
接近 2 年之前 回复
z13222038779
糕天原 回复xsb_20171227: 第三张图的错吗?
接近 2 年之前 回复
xsb_20171227
今天是星期五 还是不行,现在我的node是9.11.1,npm是5.6.0。我发现安装realm的时候,好像realm是安装起了的,然后报了上图的错误,然后由自动把realm删除了。应该是缺了点什么导致的
接近 2 年之前 回复
xsb_20171227
今天是星期五 回复z13222038779: 好的,我试试
接近 2 年之前 回复
z13222038779
糕天原 回复xsb_20171227: 建议使用nvm 管理node非常方便
接近 2 年之前 回复
z13222038779
糕天原 回复xsb_20171227: node换成9.11.1的试试,之前我遇到过同样的问题。其它的依赖没有引入成功的可以直接自己手动引入下
接近 2 年之前 回复
xsb_20171227
今天是星期五 安装node.js时,自带的。node是10.14.1
接近 2 年之前 回复
xsb_20171227
今天是星期五 6.4.1
接近 2 年之前 回复

找到问题原因了,还是因为我的nodejs版本高了,我降低到7.9,成功安装了realm。
如果是新项目,无论是上面那位兄弟说的降低realm版本还是降低nodejs版本都没关系。但是我这个是二次开发的项目,这种就不能降低realm版本了。下面链接就是降低realm版本后出现的问题
https://blog.csdn.net/xsb_20171227/article/details/86636266

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问
相关内容推荐