rvm 安装 ruby require': cannot load such file -- rubygems/core_ext/kernel_warn (LoadError)"

图片说明

rvm 安装 ruby 报这样的错,怎么整啊,大神来帮帮我,一天了都没搞好

"/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- rubygems/core_ext/kernel_warn (LoadError)"

clap4trap
clap4trap 回复qq724541826:网上都搜不到解释,是不是10.14.2新出的问题啊,快一个礼拜了还是没查到解决方法,只能先用旧电脑了
9 个月之前 回复
qq724541826
qq724541826 回复qq514299026: 我也 没弄好呢 好烦啊 也有两三天了
9 个月之前 回复
weixin_44293554
麦兜宝宝 请指教
9 个月之前 回复
weixin_44293554
麦兜宝宝 回复qq514299026: 搞好了吗
9 个月之前 回复
clap4trap
clap4trap 换了电脑也遇到这样的问题,搞了好几天,mark一下等大佬指教一下
9 个月之前 回复
qq514299026
qq514299026 我也是刚买的 Macbook air, 安装cocoapods出现同样的问题, 整了几天都没解决
9 个月之前 回复

2个回答

可以试下这个 sudo gem update --system 2.7.4
来自:https://stackoverflow.com/questions/53856625/ruby-error-after-upgrading-os-to-mojave-and-installing-xcode-10-1
我把mac 系统升级到最新的了, 反正我就做了这两件事就好了

qq_26897373
倾城灬小默 回复clap4trap: 大佬问下您是怎么解决的 麻烦告知下 还卡着呢
8 个月之前 回复
clap4trap
clap4trap 回复qq724541826: https://blog.csdn.net/qq_15618773/article/details/81222981 试下这个,应该是sip没关
9 个月之前 回复
u014128241
匆匆的吼 回复qq724541826: 我也是这个问题怎么解决的
9 个月之前 回复
qq724541826
qq724541826 回复clap4trap: While executing gem ... (Gem::FilePermissionError) You don't have write permissions for the /usr/bin directory. 这个问题
9 个月之前 回复
qq724541826
qq724541826 回复clap4trap 我怎么按着这个解决不了- -
9 个月之前 回复
clap4trap
clap4trap 谢谢,我的问题也解决了,太感谢了
9 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
使用rvm安装rubygems 低版本
由于有一些老系统需要维护,老系统在新版本rubygems下使用出现异常,但是rvm安装ruby的时候默认安装新的rubygems。所以需要降级到指定的rubygems版本,那么可以使用   rvm install rubygems 1.3.7 --force     1.3.7 可以替换成自己需要安装的版本号 ...
如何安装Ruby和RubyGems
Ubuntu 从一个终端,使用apt-get命令行工具来安装Ruby和RubyGems,如下所示 安装完整的Ruby包和RubyGems apt-get update apt-get install ruby-full rubygems which gem root@4ba0757f5803:/var/jenkins_home/# which gem /u...
如何安装 Ruby 和 RubyGems
如何安装 Ruby 和 RubyGems做一些简单介绍
ruby中require和load的区别
ruby中require和load用法很类似,但是它们有一定的区别。
rvm,ruby的安装
os: centos 7.5 ruby:2.4.4 安装rvm # curl -L get.rvm.io | bash -s stable % Total % Received % Xferd Average Speed Time Time Time Current Dload Uplo...
require win32api 提示no such file to load
各位,rn 本人初学ruby,拷贝了个程序在Netbeans上试运行,提示loaderror:no such file to load--win32api。rn我想是win32api这个包没导进来,Google,baidu没找到类似win32api的包或是dll下载,不知是要设置什么还是rn要安装什么,烦请各位指点下迷津。谢谢!rn
`require': no such file to load -- sqlite3/sqlite3_native
NULL 博文链接:https://tomsxh001.iteye.com/blog/849198
rvm安装ruby简易教程
安装前的准备下载工具sudo apt-get install curl git下载curl -L get.rvm.io | bash -s stable加载rvmsource ~/.rvm/scripts/rvm安装ruby查看可以使用 的rubyrvm list known安装rvm install 2.2.1 —此处选择一个版本号就行了需要等待一些时间—错误很多人写过错误,但我还是没找到合适的
ruby版本低,使用rvm安装ruby
简介:在安装redis时报错说ruby的版本低,用rvm进行安装ruby:(用源码进行安装ruby也不行)安装步骤:1.安装RVM:gpg2 --keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3 curl -L get.rvm.io | bash -s stable find / -name rvm -print source /u...
Ruby 系列安装 <RVM 版>
RVM安装ruby系统应用免除编译安装的痛苦, 方便快捷。 su password(...密码) $ bash &lt; &gt; ~/.bash_profile $ ln -sf /usr/local/rvm /root/.rvm $ source .bash_profile (查看是否安装成功, 命令如下, 看到 rvm is a function 即成功) $ ty...
RubyGems rvm相关命令的使用
RubyGems rvm相关命令的使用 列出已知ruby的版本 安装一个 Ruby 版本 切换 Ruby 版本 查询已安装的ruby 卸载一个已安装的ruby列出已知ruby的版本该命令能够列出rvm的各个版本(并非已安装到本地的版本)rvm list known安装一个 Ruby 版本通过 rvm list known 命令能够知道ruby的各个版本,可以选择
用rvm安装升级ruby
1. 在安装redis时报错说ruby的版本低,用rvm进行安装ruby:(用源码进行安装ruby也不行) 2. 安装RVM:   gpg2 --keyserver hkp://keys.gnupg.net --recv-keys D39DC0E3   curl -L get.rvm.io | bash -s stable   find / -name rvm -print   sour
Cannot load/parse the WSDL file
Deployment Error:rn No files returned from server for service_port: 'Service_ServiceSoap12'rn Error code: 'Cannot load/parse the WSDL file 'rn Proxy was not created.rn地址如下,请大家帮看下。rnhttp://218.65.20.55/ERwebservice/Service.asmx?WSDL
安装rvm,配置ruby环境,安装CocoaPods
安装rvm,配置ruby环境,安装CocoaPods        笔记本特别卡,然后检查后发现硬盘坏了,换了硬盘,重新安装了新的系统,cocoapods也需要重新配置,不过建议有情况和我类似的朋友们先去打苹果技术电话。因为后来发现不是硬盘的问题导致的卡顿。目录:安装rvm:第一步-第三步        配置/更新ruby:第四步-第六步        安装CocoaPods:第七步       ...
rubygems ruby 包管理
rubygems ruby 包管理,最新的
Windows 下搭建 Ruby 开发环境与安装 RubyGems
转载:https://www.cnblogs.com/wind128/p/4226058.html 1、从http://rubyinstaller.org/downloads/下载“rubyinstaller-2.1.5-x64.exe”。 2、 双击下载的程序进行安装,勾选如下图的选项。默认安装目录为:C:\Ruby21-x64。 ps:该图与版本不一致(忘记截图了),打勾选项是一样就行 3...
CentOS7搭建ruby环境(RVM安装ruby以及ruby加速)
血淋淋的教训,第二次使用rvm安装ruby(以普通用户运行) [qqq@haproxy ~]$ gpg2 --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB [qqq@haproxy ~]$ curl -L https://get.rvm.io | bash ...
Ruby学习之RubyGems(gem)包管理器的安装和使用
RubyGems 是 Ruby 的一个包管理器,它提供一个分发 Ruby 程序和库的标准格式,还提供一个管理程序包安装的工具,它旨在方便地管理 gem 安装的工具,以及用于分发 gem 的服务器。这类似于 Ubuntu 下的apt-get, Centos 的 yum,Python 的 pip。 如果我们的 Ruby 低于 1.9 版本,也可以通过手动安装,步骤很简单,通过https://ruby...
Ubuntu安装ruby:使用RVM
直接在Ubuntu的软件源中安装ruby,只能安装1.9.1的,无法安装最新版。有些软件依赖于Ruby 2,而有些软件依赖于Ruby旧的版本。使用rvm可以很好地解决这个问题。RVM 是一个命令行工具,可以提供一个便捷的多版本 Ruby 环境的安装、管理和切换。RVM的安装$ gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C27
ruby管理工具rvm
安装rvm根据官网显示,只需执行以下两条命令即可安装:# gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 # \curl -sSL https://get.rvm.io | bash -s stable执行完以上两条命令后会有如下提示: * First you nee
用rvm切换ruby
1.查看已安装ruby版本列表 rvm list 2.查看当前ruby版本 rvm current 3.移除ruby版本 rvm remove 2.2.2 4.查看可安装ruby版本 rvm list known 5.安装ruby版本 rvm install ruby-2.4.1 6.切换ruby版本 rvm use 2.4.1 --defaul...
RVM Ruby 管理工具
1、RVM 简介 1.1 Ruby 简介 Ruby 是一种面向对象的脚本语言,简单易用,功能强大。能跨平台和可移植性好等等。其实就是种脚本语言。 Ruby 的软件源使用的是亚马逊的云服务,国内网络环境下载时可能会出现各种不稳定和超时,所以自带的需要FQ。 可以将官方 ruby 源替换成国内淘宝 ruby:https://ruby.taobao.org/ 或者是 China ruby 源:htt...
RVM切换ruby版本
RVM是Ruby Version Manager的缩写,是一个命令行工具,它可以让你轻松地安装,管理和使用多个版本的Ruby.不同的rails项目使用等ruby和rails版本不一样的时候,可以使用RVM自由切换。 安装RVM Install RVM (development ...
卸载rvm,卸载rvm安装的ruby以及解决相关问题
背景:系统为macos,自带ruby版本较低,因为工具需要安装flick程序安装flick时有报错,但是最后也显示安装成功了,但是无法运行,/usr/local/Cellar/ruby23/2.3.3/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': dlopen(/usr/local/lib/ruby/gems...
linux下安装ruby版本管理器RVM
这里以ubuntu为例。 直接以如下命令行安装可能会不成功,因为rvm.io站点有时会被墙: curl -sSL https://get.rvm.io | bash -s stable #或者 curl -L https://rvm.io | bash -s stable 没关系,我们可以直接从git仓库里下载并安装RVM,首...
Ruby版本管理(RVM)
RVM是一个命令行管理工具,允许开发者很容易的去安装、管理ruby的版本;并且可以很容易的在多个ruy版本之间切换。 RVM的安装(可能需要连接VPN): 第一步: gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 第二部,安装ruby: \curl -sSL
使用RVM安装ruby rails环境
apt-get install ruby-rvm 安装rvm rvm -v 查看rvm是否安装成功 rvm install ruby-2.0.0 安装ruby2.0,版本号自己定,在使用rvm安装ruby的时候由于国内被墙,直接这样安装不成功,解决方法是: 1、进入rvm目录,找到con...
linux,不使用rvm情况下,安装ruby
Centos 6.5在使用yum -y install ruby 安装ruby的时候,版本号会低于2.2.2. ,在搭建redis集群环境时,执行gem install redis命令时提示以下错误信息: ERROR: Error installing redis: redis requires Ruby version &amp;gt;= 2.2.2. Centos6.5 yum源默认是1.8...
在Ubuntu上使用RVM安装Ruby
<img src="https://img-bss.csdn.net/201903040517183350.jpg" alt="" /><img src="https://img-bss.csdn.net/201903040517279072.jpg" alt="" /><img src="https://img-bss.csdn.net/201903040517354656.jpg" alt="" /><img src="https://img-bss.csdn.net/201903040517433920.jpg" alt="" /><img src="https://img-bss.csdn.net/201903040517524565.jpg" alt="" />
为Redis集群做准备:安装ruby、rubygems以及重启客户端后rvm等命令无效
因为Redis集群需要使用ruby命令,所以需要安装ruby。下面是安装Ruby和Rubygems的文章。 https://blog.csdn.net/michaelehome/article/details/79533496 当然了,我按着上面的步骤弄是会出现很多错误的,最后我知道了RVM可以管理Ruby版本。那么我肯定是用这个啊,以后就算ruby出新版本我也可以简单就升级完了。 1、首先...
创建集群时,关于BUG:…cannot load such file -- redis (LoadError)的解决方法
集群文件配置好后,gem源也是国内,但是还会有一个问题,就是redis的相关依赖。 BUG: Traceback (most recent call last): 2: from /usr/local/bin/redis-trib.rb:25:in `&lt;main&gt;' 1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_requ...
error cannot load resource file sqresus.dll
我是第一次裝ORACLE,在應用程序和ODBC里面都報上述的錯誤rn謝謝
新手require和load问题
require "R1.rb"rn提示错误:in `gem_original_require': no such file to load -- R1.rb (LoadError)rn我是新手,希望可以写的稍微详细一点,谢谢!
安装 rvm
使用curl安装 运行 curl -L get.rvm.io | bash -s stable 如果出现以下内容 在复制红色方框里的命令,粘贴运行 之后在执行 curl -L get.rvm.io | bash -s stable 出现以下内容时即为安装成功 最后执行 source /etc/profile.d/rvm.sh ,便安装完成了...
cannot find name 'require'
![图片说明](https://img-ask.csdn.net/upload/201805/23/1527011826_941564.jpg)
Ruby升级,使用RVM升级
由于使用Redis Cluster需要用到 Ruby环境,把安装Ruby过程中记录一下。 安装Ruby yum install ruby 由于redis-4.0.0.gem需要的是 ruby2.2.2以上的版本,所以使用RVM升级Ruby,RVM官网:http://www.rvm.io/ 安装GPG(必须安装) gpg2 --recv-keys 409B6B1796C275462A17...
使用rvm管理ruby版本
$ bash &amp;lt; &amp;lt;( curl http://rvm.beginrescueend.com/releases/rvm-install-head ) # 安裝 rvm rvm list # 查看目前安裝的 ruby 版本 rvm info # 查看目前使用的環境訊息 rvm list known # 列出可以安裝的版本 rvm install ruby-1.9.2-hea...
在安装redis-stat出错
出现错误: /usr/local/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- redis-stat (LoadError) from /usr/local/lib/ruby/2.1.0/rubygems/core_ext/kernel_re
更新rvm,更新ruby的提前
1、安装 RVM RVM:Ruby Version Manager,Ruby版本管理器,包括Ruby的版本管理和Gem库管理(gemset) [ruby] view plain copy $ curl -L get.rvm.io | bash -s stable   等待一段时间后就可以成功安装好 RVM。
RVM切换Ruby和Rails版本
目的是运行多个ruby和rails版本 apt-get install git-core ...3个,参考我博客其他文章 apt-get curl 安装RVM详见:https://rvm.beginrescueend.com/rvm/install/照着做。 如果是Multi-user,rvm会被自动安装到/usr/local/rvm,否则会被安装到/home/zj/.rvm 在sour...
相关热词 c#入门推荐书 c# 解码海康数据流 c# xml的遍历循环 c# 取 查看源码没有的 c#解决高并发 委托 c#日期转化为字符串 c# 显示问号 c# 字典对象池 c#5.0 安装程序 c# 分页算法