hy4724
hy4724
2018-12-22 16:43

在cmd中安装jupyter出错

  • python

在安装requests和beautifulsoup4时没有问题,安装jupyter也没有报错,
然后打开jupyter notebook时就报错

Traceback (most recent call last):
  File "c:\pa_worm\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "c:\pa_worm\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "c:\pa_worm\Scripts\jupyter-notebook.EXE\__main__.py", line 5, in <module>
  File "c:\pa_worm\lib\site-packages\notebook\notebookapp.py", line 47, in <module>
    from zmq.eventloop import ioloop
  File "c:\pa_worm\lib\site-packages\zmq\__init__.py", line 47, in <module>
    from zmq import backend
  File "c:\pa_worm\lib\site-packages\zmq\backend\__init__.py", line 40, in <module>
    reraise(*exc_info)
  File "c:\pa_worm\lib\site-packages\zmq\utils\sixcerpt.py", line 34, in reraise
    raise value
  File "c:\pa_worm\lib\site-packages\zmq\backend\__init__.py", line 27, in <module>
    _ns = select_backend(first)
  File "c:\pa_worm\lib\site-packages\zmq\backend\select.py", line 27, in select_backend
    mod = __import__(name, fromlist=public_api)
  File "c:\pa_worm\lib\site-packages\zmq\backend\cython\__init__.py", line 6, in <module>
    from . import (constants, error, message, context,
ImportError: DLL load failed: 找不到指定的模块。

看不懂这是什么原因有人遇到过这种情况吗

  • 点赞
  • 回答
  • 收藏
  • 复制链接分享

3条回答