阿里云上部署 jdk1.8 tomcat8.5 tomcat启动访问8080端口报错? 5C

java.lang.NoClassDefFoundError: Could not initialize class org.apache.jasper.el.ELContextImpl

org.apache.jasper.JasperException: java.lang.ClassNotFoundException: org.apache.jsp.index_jsp

这两个错咋回事
我只是tomcat启动访问tomcat页面报错的 我tomcat里面什么都没放

1个回答

应该是jsp相关的jar包冲突了

Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
立即提问

相似问题

3
jdk1.6访问https接口报错,jdk1.7访问正常,服务端jdk为1.7
2
IDEA 2018.3.4版本,jdk1.8, 用scanner接受控制台的输入时,发现会报错,用next和nextLine都不行
0
java jdk 1.8 rt. jar GetInstance.Instance() 底层只有方法头是怎么执行的 继续往下跟已经跟不到了
4
JDK1.8安装完成不需要配置环境变量?
2
求助,使用springboot写了一个小的后台进行取数,基于jdk1.8,打包之后报错 ,服务器jdk版本低
1
jdk1.8+hibernate5.2 错误:javax.persistence.joinColumn.foreignKey()
1
windows系统运行正常 mac系统就出现错误 jdk1.8 , tomcat8.5 , macOs Mojave 10.14.4
1
jdk1.7发送不了post请求 jdk1.8却可以
3
IDEA+Tomcat8.5运行报错
0
jdk11.0版本为什么安装不上sdk
2
jdk1.8无法发布webservice接口
2
项目迁移升级到jdk1.8,tomcat8下可以运行,weblogic12c下报错?
3
linux下启动tomcat失败
1
在windows2003下把tomcat安装为系统服务后,使用服务方式启动tomact 访问网页空白,但是使用自带startup.bat启动是正常的(注:原来的tomcat为解压版安装)
1
启动zookeeper和tomcat9,但是dubbo-admin-2.5.4.war无法启动?
1
java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Tomcat].StandardHost[localhost].TomcatEmbeddedContext[]]
2
开发文档jdk版本和java jdk版本什么关系?我网上找的开发文档是jdk1.8,但是电脑上javajdk版本是12.0
1
求助!!Linux tomcat部署war包 初始化bean失败 org.springframework.beans.factory.BeanCreationException: Error creating bean with name
0
IntelliJ IDEA 2019 不支持JDK1.5?
2
Jenkins打包项目报错,JDK1.8