was中java.j2ee.validation.jar与应用程序引用的validation-api.jar冲突,求解决?

[19-1-1 21:29:48:427 CST] 00000081 SystemOut O 01-01 21:29:48.425 WARN [o.s.b.w.s.c.AnnotationConfigServletWebServerApplicationContext] - Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'msgLocalPushTask': Unsatisfied dependency expressed through field 'msgPushService'; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'msgPushService': Unsatisfied dependency expressed through field 'validator'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'beanValidator' defined in class path resource [com/jeesite/autoconfigure/core/WebMvcAutoConfiguration.class]: Invocation of init method failed; nested exception is java.lang.NoSuchMethodError: javax/validation/Configuration.getDefaultParameterNameProvider()Ljavax/validation/ParameterNameProvider; (loaded from file:/C:/IBM/WebSphere/AppServer/plugins/javax.j2ee.validation.jar by org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader@27b4fd49) called from class org.springframework.validation.beanvalidation.LocalValidatorFactoryBean (loaded from file:/C:/IBM/WebSphere/AppServer/profiles/AppSrv01/installedApps/DESKTOP-M355DDANode01Cell/web_war.ear/web.war/WEB-INF/lib/spring-context-5.0.9.RELEASE.jar by
com.ibm.ws.classloader.CompoundClassLoader@84cbd275[war:web_war/web.war]

0
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
SDK开发中解决引用第三发库引发的冲突
网上有很多强大的开源库,站在巨人的肩膀上开发会大大增强开发的稳定性,提高效率。但是如果SDK中使用了某个三方开源库,然后其他开发者接入该SDK,可能他的app中也引用了相同的三方开源库,那么就产生冲突报错,那么如何解决呢?n两个办法:n1.如果三方开源库架构简单,并且足够稳定,那么可以修改原三方开源库的前缀标示,达到区分。n如"AFNetworking" ...
如何解决因共享组件而导致的应用程序之间的冲突?
解决冲突问题的关键是可靠的版本控制系统。rnrn.NET Framework在程序集清单中记录有关应用程序依赖项的详细信息,该依赖项信息包括其版本号,可在运行时使用该版本号来加载依赖项的正确版本。 rnrn.NET Framework 提供以下3个版本策略级别: rnrn1、应用程序策略:在默认情况下,公共语言运行库负责加载清单中指定的依赖项的版本。可以在应用程序配置文件中进行应用程序策略配置,应
iOS程序开发引用的第三方库之间出现冲突的处理方法
之前看过一篇类似的解说文章,链接为点击跳转原文,然后我也遇上了相同的问题,第三方包中的AsynSocket与自己工程的AsynSocket发生了冲突,通过控制台指令xcrun -sdk iphoneos lipo -info libx.a 发现libx.a中包含的armv7和arm64两种类型的文件,说明一下narm64:iPhone6s | iphone6s plus|iPhone6| iPhon
Android studio 引入第三方库时,解决版本冲突的问题
compile ('com.jakewharton.rxbinding2:rxbinding-design:2.0.0') {n exclude group: 'com.android.support'n}在要导入的包后面添加 " { exclude group: 'com.android.support'} ",group:表示只要包含com.android.support的都除去 n...
android 项目jar包冲突问题解决
大家在做开发中竟然需要用到一些三方库 或者 需要集成三方的SDK开发包,尤其是项目特别庞大的时候,引用的三方的东西特别多,那么肯定会碰到一些jar包冲突的情况。nn常见的情况有以下几种nn目录nn1.项目自己引用jar包重复nn2.项目中jar包和三方SDKnn3.三方sdk之间都含有相同类nn4.打包时候出现编译错误,出现冲突nn1.项目自己引用jar包重复nncom.android.dex.D...
同时引入多个js发生冲突
同时引入多个js发生冲突
解决子项目中引用包的版本冲突问题
为了解决子项目中引用包的版本冲突问题,可以用以下方案解决:nnnn1.新建pom文件放所有子项目中用到的公共依赖nnnnn//新建pom文件用来管理版本com.zzk.dependencynzzk-common-bomn${zzk-common-bom.version}npomnnn123-SNAPSHOTn0.0.1-SNAPSHOT
Android studio 依赖冲突的解决
最近刚接手一个项目,里面模块有三四个,引入的第三方包更多了。但是问题来了,新配置的studio一运行就报了错。Error:Execution failed for task ':app:processDebugManifest'. Manifest merger failed : Attribute meta-data#android.support.VERSION@value value=(25
抛砖引玉:Java中依赖冲突的解决方法
依赖冲突的解决方法nn早在去年的一次面试中,我就曾被问及依赖冲突如何解决,当时确实没有遇到过相关的问题,所以似乎并没有给出很满意的答案。因为在通常情况下,构建工具帮你解决了这些问题,好像一切都没有发生过,万事大吉。正所谓,“出来混,总是要还的”——最近在升级Spring版本时又遇到了这个问题,并且断断续续地困扰了我一段时间,到现在为止总算是完整地解决了。故有此文,以告慰我逝去的青春。nnnn依赖冲...
js多个库冲突的解决办法
当一个项目中引入多个第三方库的时候,由于没有命名空间的约束(命名空间就好比同一个目录下的文件夹一样,名字相同就会产生冲突),库与库之间发生冲突在所难免。rn        那么,既然有冲突的问题,为什么要使用多个库呢?原因是jQuery 只不过是DOM 操作为主的库,方便我们日常Web 开发。但有时,我们的项目有更多特殊的功能需要引入其他的库,比如用户界面UI 方面的库,游戏引擎方面的库等等一系列
Gradle 引用第三方库,jar包冲突解决方案
一、使用exclude标签nn//RxTools工具类集合https://github.com/vondear/RxToolsnapi 'com.github.vondear:RxTools:v1.7.6.4'nn//zxing第三方https://github.com/mylhyl/Android-Zxingnapi ('com.mylhyl:zxingscanner:2.1.0'){
解决studio中导入依赖库有重复冲突的办法
项目中难免会加入很多第三方的库,来节省我们的开发时间,其中也就难免会有库重复,导致编译错误rn例:rnrn导入takephoto库导致编译失败,说与glide库冲突。因为我前面还有一个库中也引用了glide。在这个两个库都不想换的情况下,有个解决办法rnrn在其中一个依赖库中加入注明:rncompile ('com.jph.takephoto:takephoto_library:4.0.2'){n
java jar包冲突解决方案
引言在使用java语言开发,maven做项目管理时,我们经常遇到一个头疼的问题就是jar包冲突。比如项目中不同的两个依赖A和B,都同时依赖了一个项目C,但是依赖的版本不同,这时候我们就要考虑这两个版本之间是否有冲突,不解决这些冲突,我们的项目虽然能编译成功,但执行的时候总是会报各种异常。 本篇主要介绍shade插件解决jar包冲突问题
针对工程中使用了各平台的sdk及引入第三方平台的整体sdk包冲突的解决方法
在我的项目中,登录功能后台直接对接了微信及其他的服务平台,但是登录方式使用了shareSDK方式 ,这样我们项目中共有两个微信的sdk包,第三方的代理会直接替代掉我们登录时候使用的微信的代理对象.rnrnrn微信及shareSDK给出的解决方法是在openURL的两个对应方法中去更改代理对象,无法解决问题.rn查看微信demo及shareSDK文档及服务方,发现使用的openURL方法在官方文档中
安卓开发之引入第三方库导致jar包冲突解决办法
这几天的任务是将mapbox的工程合到程序中去,但是合并过程却出现了问题合并方法: n在app的build.gradle中添加dependencies {n compile ('com.mapbox.mapboxsdk:mapbox-android-sdk:0.7.4@aar'){n transitive=truen }n}但是合并后会报错:Error:Execution
jar包的冲突问题如何解决
jar包冲突 rn   启动时出现xxxxNotFound-----rn   1.项目中真的缺少jar包(添加依赖即可)rn   2.jar包多了,产生冲突(也有可能jar包之间允许共存的)rn   引入A的时候依赖B v1.0rn   引入C的时候依赖B v2.0rn   去掉低版本的保留高版本的rn   如何排除依赖jar包rn   应该在冲突的坐标里面进行排除此jar包rnrn例如:比如Ja
引入两个jquery冲突 jQuery冲突解决办法
本人因项目中要用一个插件,这个插件的JS需要jquery-1.8.2.min.js支持,但我的项目中有一个top页面是引入进来的,是用jquery-1.7.2.js的,把1.7.2和1.8.2都加入项目中,这个插件就不能用了,去掉原来的1.7.2这个插件能用但是原来的功能不能用,所以需要共存。rn解决办法是。在top页面中加入noConflictrnrnrn var jQuery_1_7_2 =...
AS中jar包冲突解决方案
使用exclude n过滤可以很好的解决Android项目中jar包冲突的问题,比如说你的项目中引用了v7,同时又引入了v4,在Android 中v7包默认是包含v4包的,那么就可以使用exclude解决冲突,只需要添加如下代码:ncompile ('com.android.support:appcompat-v7:25.2.0'){exclude module: 'support-v4'}在你创建
AndroidStudio项目里面jar包里面的类相冲突的解决方法
在AndroidStudio里面引用jar包的时候会出现com.android.build.api.transform.TransformException: java.util.zip.ZipException: duplicate entry: android/support/v4/view/OnApplyWindowInsetsListener.class类似的冲突问题rn解决方法:rn先可
Validation3个jia包 validation-api,hibernate-validator
ssm框架validator应用jia包3个 hibernate-validator-5.0.1 jboss-logging-3.3.0 validation-api-1.0.0
C++中的名空间(namespace)探讨
讨论在C + + 中如何使用名空间解决引用冲突,名空间的定义、使用以及标准名空间。
maven依赖jar包时版本冲突的解决
共有四种解决方式: n1、第一声明优先原则: n在pom.xml配置文件中,如果有两个名称相同版本不同的依赖声明,那么先写的会生效。 n所以,先声明自己要用的版本的jar包即可。 n2、路径近者优先: n直接依赖优先于传递依赖,如果传递依赖的jar包版本冲突了,那么可以自己声明一个指定版本的依赖jar,即可解决冲突。 n3、排出原则: n传递依赖冲突时,可以在不需要的jar的传递依赖中声明排除,从而
was环境jar包冲突解决方案
问题简述:nn1)was环境:WebSphere Application Server8.5.5;nn2)linux服务器:CentOS7nn3)项目介绍:商业银行项目nn4)异常描述:项目开发完毕后,在本地测试(jetty6、tomcat6)无任何异常。部署到was环境就报各种异常,有业务方面的异常、也有非业务方面的异常。比如:nnjava.lang.NoSuchMethodExceptio...
android 3.1.3 glide引入引发的包重复问题解决
n n n 如图:nnnnnnnimage.pngnn引入glide 4.8.0时,support 包报异常nn解决方法:nimplementation("com.github.bumptech.glide:glide:4.8.0") {n exclude group: 'com.android.support'n }nngroup:表示只要包含com.a...
java 多个第三方jar包冲突解决方案
最近公司在接入腾讯的ysdk(上班以来接第三方sdk最艰难的一次),在这简单说一下哈,就是他们的逻辑太复杂(我觉得有点乱),ysdk和msdk到最后才搞清楚,因为最初是接入他们的msdk,接着接着让换ysdk,接就接呗,又不是没接过,根据他们的文档就开始接,接着接着就遇到问题了,jar包冲突,这是第一个问题,先暂且不说,然后是第二个问题他们的so库放到我们的项目中就被压缩变小的很多,所以就报错,弄
eclipse导入的jar包中包路径和类名与本地工程包路径类名冲突的解决办法
注意冲突是导入jar包中的类名与本地代码中的类名冲突,不是网上大多数的两个jar包中类名冲突。rnrn两个jar包互相冲突的解决办法,网上可以搜到很多,我就不多说了,问题是我遇到的特别奇葩的bug,jar包中类名与本地工程类名冲突,更奇葩的是路径也一样。rnrn**直接删掉任意一个就可以了啊**rnrn但我这个奇葩的问题来自与奇葩的需求,两个还都要保留,这就没办法了,网上找了很久的资料都没找到,最
怎么解决maven管理jar包冲突问题
maven管理jar包依赖的时候,假如你的依赖包A需要间接依赖B的1.0版本,而你的工程里又需要用到B的2.0版本,这个时候就可能会出现运行时jar冲突的异常,会报rnjava.lang.NoSuchMethodErrorrn或者 java.lang.ClassNotFoundException 、java.lang.NoClassDefFoundErrorrn解决方法一:rn第一步:查询冲突ja
css样式冲突
css样式设置冲突的时候,各方式的样式设置优先级后面加!important > 行内样式(在标签上直接设置的样式) >  通过id设置样式的 > 同种方式的在css文件中排最后的样式 ...
jsp页面中同时引入juery.js与其他js冲突,导致js不起作用
上图中jsp页面引入的jquery库,跟自定义的chat.js冲突,解决办法:将其中js中的方法头重命名,var jq=jQuery.noConflict();
Android Studio 引入Jar包,Jar包冲突问题总结
Android Studio 引入Jar包,Jar包冲突问题总结,V4 V7包冲突解决
AS中v4包冲突解决办法
v7包包含v4包:maven引入v7包,gradle会自动加入所有v4包的依赖,并且和v7相同的版本。v4包引入分析:都是maven的方式引入v4包:不会冲突,gradle会自动选择较高版本maven引入,同时本地引入v4包:如果版本相同,不会冲突,否则冲突结论v4依赖冲突实质:是不同v4版本的冲突,并且是maven和本地引入版本不同才会冲突解决办法:    项目通常会使用很多开源库,统一所有的v...
maven的依赖特性,冲突解决(五)
rn转载请注明出处哈:http://yanan0628.iteye.com/blog/2270409rn rn1.maven依赖的几个特性rn    1.1 依赖范围 -scope标签rn    maven在构建过程有3套classpath,我们会根据配置依赖的范围 依赖不同的classpath,如下图:rn    rncompile:默认是compile,对 编译 测试 运行 都有效rnprov...
maven项目解决jar包冲突的四种方式
依赖一个jar包往往会下载相互关联的jar包这就是依赖传递rnrn依赖传递经常出现ja包冲突,解决方案:直接排除指定的jar包rnrn1、排除原则rnn n org.springframeworkn spring-beansn n rnrn2、版本号限定原则rnn 4.3.8.RELEASEn nn n n n n org.sprin
【安卓】android第三方库导致support版本冲突解决方案
问题nn升级compileSdk版本到26,同时修改了support包的版本,报错nnn all com.android.support libraries must use the exact same version specification(mixing versions can lead to runtime crashes)nnn也就是说有引入的第三方库和目前编译版本有冲突。nnnn...
android 中gradle依赖冲突解决
android项目开发中经常会遇到库依赖异常,大多是版本依赖的冲突问题,说明下常见的版本依赖冲突解决方式首页看下我们项目的依赖关系./gradlew dependencies :app:dependenciesn :app表示依赖module n mac下运行可能人别不了命令行,运行chmod +x gradlew添加权限n可以看到依赖结构是树状结构,各库下又依赖了android的官方提供的一些
java类冲突解决
find . -name '*.jar' -exec jar -tvf {} \; | grep EE
Android Studio 引用第三方包时,因版本com.android.support不同发生冲突的解决办法
compile ('com.jakewharton.rxbinding2:rxbinding-design:2.0.0') {n exclude group: 'com.android.support'n}rn在要导入的包后面添加 " { exclude group: 'com.android.support') ",group:表示只要包含com.android.support的都除去
Android引入多个jar包,冲突问题解决方案
此篇文章适应的环境是引入jar包,即本地文件。如果是网络library则不适应,没试过你也可以尝试一下,不过肯定一堆错误。nnMore than one file was found with OS independent path 'META-INF/proguard/okhttp3.pro'nnnn1.关掉你的项目(防止编程工具报IOException)。nn2.找到你项目中的libs-&g...
javaWeb项目中jar包冲突问题
1、java.lang.NoSuchMethodError: org.apache.http.entity.StringEntity.<init>(Ljava/lang/String;Lorg/apachnn项目本来正常运行,突然提示没有对应方法,500nn网上说的都是jar包冲突,但是找半天不晓得那个jar包问题;nn做法:找到报错信息第一行,点击链接进去,对应方法所在的jar包就是...
Android主工程与依赖库的FileProvider冲突的问题
在Android7.0版本中,为了安全的考虑引入了FileProvider类,所以这就造成我们的主工程和依赖库中都有可能使用了FileProvider的相关引用在AndroidManifest文件中引起冲突,解决的方法是,在我们们主工程中新建一个类继承自FileProvider,然后在主工程的AndroidManifest中关于provider的配置中,name属性引用我们新建的类,就可以解决我们
文章热词 机器学习教程 Objective-C培训 交互设计视频教程 颜色模型 设计制作学习
相关热词 mysql关联查询两次本表 native底部 react extjs glyph 图标 数据库应用程序 数据库应用程序

相似问题

0
was中java.j2ee.validation.jar与应用程序引用的validation-api.jar冲突,求解决?
1
org.apache.jasper.JasperException处理异常如何解决?
0
The import com.baidu cannot be resolved controller.jsp文件中
1
cxf调用下面两行的代码执行特别慢是什么情况求大佬解答
1
maven创建项目pom报错,跪求大神帮忙解决,搞了3天了 ||?
3
网上下载的java web导入myeclipse之后出错,接下来怎么解决和运行?
6
为什么在eclipse中能看jdk的源码,却看不了自己打的jar包源码?
1
#java web#在java web项目运行中,抛出了下面的异常,怎么解决啊
3
java web在进行管理员操作的时候,抛出了下面的异常,怎么解决啊
0
安装TAS时候报的错误求大神解决
0
使用activiti工作流时,部署流程,发动流程,启动流程。。。。都会报这个错,求大神解决
1
org.springframework.beans.factory.BeanCreationException这个错怎么解决
1
Android Studio3.2.1中Bmob依赖添加
1
在pom文件中依赖了servlet-api,在项目中也加了tomcat library,为什么没有冲突呢?
1
mvn exec:java未执行jar中的main方法问题
1
Program type already present: com.tencent.a.a.a.a.a,应如何解决?
0
Program type already present: com.tencent.a.a.a.a.a,应如何解决?
1
如何自动下载jar包中的其他依赖
1
求多个线程读写HBase 1.2.0的同一个cell方法?
1
AS中项目已经导入了jar包,代码里import引用的时候只能显示文件夹显示不了类