sudo apt-get install package时出现E:无法定位软件包

OS:Ubuntu 16.04

问题描述:

sudo apt-get install xxxx

出现

正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
E: 无法定位软件包 xxxx

网上的解决方案例如

sudo apt-get update && apt-get upgrade

我都试过了,没有用,问题依然存在。

sudo gedit /etc/apt/sources.list

换源我也试过了,不行。请问还有什么办法吗??

weixin_44768076
weixin_44768076 你现在解决了没
2 个月之前 回复
geek_xiong
离未罔两 怎么解决的呀,我正在找这个问题呢
4 个月之前 回复
u014179267
longtengwanli_ 同求,刚刚正好碰到这个问题,输入sudo apt-get install sqliteman后,始终出现E: 无法定位软件包 sqliteman
8 个月之前 回复

1个回答

linux是不是太老了,建议你安装ubuntu 18.10

u014179267
longtengwanli_ 我的版本是18.10的,然后是虚拟机里创建了mkvirtualenv后,再安装的,不知道是不是网的原因,因为我sudo apt-get update时都出现错误:5 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntucosmic Release 404 Not Found [IP: 91.189.95.83 80],不知道怎么解决才好
8 个月之前 回复
Csdn user default icon
上传中...
上传图片
插入图片
抄袭、复制答案,以达到刷声望分或其他目的的行为,在CSDN问答是严格禁止的,一经发现立刻封号。是时候展现真正的技术了!
其他相关推荐
解决apt-get install E: 无法定位软件包问题
在etc/apt   的sources.list 添加镜像源   deb http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse 然后 sudo apt-get update  接着安装就可以了
Ubuntu中apt-get install安装软件,显示“E:无法定位软件包”
问题:一般为刚装完Linux  Ubuntu系统,若直接使用apt-get install安装软件,总是显示“E:无法定位软件包”。 解决:可能的一个原因是因为系统没有更新软件源,更新一下软件源。 命令:sudo apt-get update
sudo apt-get install gnome-devel 说无法找到软件包
是虚拟机装的ubuntu7.1,用sudo apt-get install gnome-devel 说无法找到软件包,是命令错了吗,还是要怎么配置一下啊
sudo apt-get install vim-gtk
Ubuntu 中sudo apt-get install vim-gtk 是啥意思??
sudo apt-get install vim
tar:无法识别的选项“--warning=no-timestamp”rn请尝试执行 “tar --help” 或 “tar --usage”rn来获取更多信息。rndpkg-deb: error: 子进程 tar 返回了错误号 64rndpkg:处理 /var/cache/apt/archives/vim-common_2%3a7.3.429-2ubuntu2.1_amd64.deb (--unpack)时出错:rn 子进程 dpkg-deb --control 返回了错误号 2rnrnrnwho know how to fix this problem?
ubuntu 18 当使用命令sudo apt-get install sysv-rc-conf安装不上时,提示“ E: 无法定位软件包问题
1. 进入 etc/apt      2. 使用vim sources.list命令  在里面sources.list 添加镜像源   deb http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse   3.然后 sudo apt-get update     4. sudo ap...
ubuntu18.04 使用apt-get的时候,始终显示“E:无法定位软件包”
想使用apt命令来安装一些软件,可以报“E:无法定位软件包” 排除网络未连接的问题,那就是网络质量的问题!!! 究其原因, ubuntu,我们在使用apt新装软件的时候,会使用官方的网站去下载软件,但是会因为国内的转接点太多,而导致下载的速度非常慢 ,我们可以通过换成一些中间的节点来进行下载,比如阿里源,中科大源,清华源等等,这样的网站,他们会定时和官方的源进行同步和更新,而我们直接同步他们,...
E: 无法定位软件包 libcholmod-dev
在安装g2o库的时候总是出现E: 无法定位软件包 libcholmod-dev这样的问题。 输入sudo apt-get install libcholmod然后按Tab键,Tab键就是自动补充命令,当记不住完整命令的时候,你按下它,他会自动搜索!我在这里出来的是libcholmod3.1.2 ...
E:无法定位软件包 Kdevelop
sudo apt-get update sudo apt-get install kdevelop 名字变为小写
Ubuntu安装软件sudo apt-get install时出现错误
通过终端安装程序sudo apt-get install xxx时出错
Linux:执行sudo apt-get install提示“现在没有可用的软件包
问题描述:sudo apt-get install openssh-server正在读取软件包列表…完成正在分析软件包的依赖关系树Reading state information… 完成现在没有可用的软件包 openssh-server,但是它被其它的软件包引用了。分析:这可能意味着这个缺失的软件包可能已被废弃,或者只能在其他发布源中找到: 软件包 openssh-server 还没有可供安装的候
Ubuntu apt-get install报错:E:有几个t软件包无法下载,要不运行apt-get update....
解决办法: 加一个万能域名: 1.sudo vim /etc/resolv.conf 2.添加nameserver 8.8.8.8 3.wq:保存退出 再次进行sudo apt-get install就可以了
sudo apt-get install build-essential提示E:Couldn't find package build-essential
ubuntu 9.10 下面sudo apt-get update更新不成功 rn都是诸如如下的问题:rn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/restricted Packagesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/main Sourcesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/restricted Sourcesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/universe Packagesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/universe Sourcesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://security.ubuntu.com karmic-security/main Sourcesrn 404 Not Found [IP: 91.189.92.190 80]rnErr http://security.ubuntu.com karmic-security/restricted Sourcesrn 404 Not Found [IP: 91.189.92.190 80]rnErr http://security.ubuntu.com karmic-security/universe Packagesrn 404 Not Found [IP: 91.189.92.190 80]rnErr http://security.ubuntu.com karmic-security/universe Sourcesrn 404 Not Found [IP: 91.189.92.190 80]rnErr http://hk.archive.ubuntu.com karmic/multiverse Packagesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic/multiverse Sourcesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic-updates/main Packagesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic-updates/restricted Packagesrn 404 Not Found [IP: 91.189.92.177 80]rnErr http://hk.archive.ubuntu.com karmic-updates/main Sourcesrn 404 Not Found [IP: 91.189.92.177 80]rnrn软件包也无法安装sudo apt-get install build-essential提示E: Couldn't find package build-essentialrn求大神指教啊
Ubuntu18.04.1安装ROS('E:无法定位软件包')
今天在Ubuntu18.04.1系统中配置ROS的时候一直提示`E:无法定位软件包`,后来发现是ROS的版本不对应导致的,每个不同的ubuntu系统对应着不同的ROS版本,如果装错了就会出现上述问题,在Ubuntu18.04.1环境下可以安装的是melodic版本的,安装教程可以参考官网安装教程,ROS有Melodic、Lunar、Kinetic不同的种类对应着不同的ubuntu版本,Melodi...
ubuntu 运行 sudo apt-get install *** 失败,无法安装软件
rnubuntu 运行 sudo apt-get install *** 失败,无法安装软件,提示如下:rnrn(正在读取数据库 ... 50%dpkg: 无法恢复的致命错误,中止:rn 软件包 poppler-data 的文件名列表文件最后结尾的换行符rnE: Sub-process /usr/bin/dpkg returned an error code (2)rnaisq@aisq-VirtualBox:~$ rnrnrn这个是啥问题啊
sudo apt-get update时的问题
提供sudo apt-get update时出现问题的解决方案!
sudo apt-get install 时意外中断,导致资源加锁
cd /var/lib/apt/lists sudo rm -rf * sudo rm -rf /var/cache/apt/archives/lock sudo rm -rf /var/lib/dpkg/lock
安装zlib1g-dev时提示"E: 无法定位软件包 zliblg-dev"的原因
感觉有点坑 起因 安装zlig1g-dev 依赖包时: sudo apt-get install zliblg-dev安装失败 发现 zlig1g-dev中的第5个字母不是l,而是阿拉伯数字1 解决 输入sudo apt-get install zlib1g-dev即可解决问题...
ubuntu安装软件时提示:E: 无法定位软件包 qtcreator
如题ubuntu12.10安装qtcreator时总是提示这个,在网上没找到好的解决方法。各位大神帮帮忙[img=https://forum.csdn.net/PointForum/ui/scripts/csdn/Plugin/003/monkey/8.gif][/img]rnThinkPad:~$ sudo apt-get install qtcreatorrn正在读取软件包列表... 完成rn正在分析软件包的依赖关系树 rn正在读取状态信息... 完成 rnE: 无法定位软件包 qtcreatorrnrnrnrn
sublime出现Install Package无法使用的问题
现在咱们有时候要使用package control中的Install Package时,会出现这样的报错: there are no packages available for installation 这是因为在首选项下的Package Settings->Package Control->Settings-Default.json文件中的: "channels": [ "h...
解决apt-get install在安装软件包时依赖不兼容问题
解决apt-get install在安装软件包时依赖不兼容问题在树莓派上安装libncurses5-dev出现以下问题解决 在树莓派上安装libncurses5-dev出现以下问题 pi@raspberrypi:~/6lbr/examples/6lbr $ sudo apt-get install libncurses5-dev Reading package lists… Done B...
Unable to locate package错误解决办法
sudo apt-get update
ubuntu16.04下安装vim报错E: Unable to locate package(E:无法定位软件包)的问题
装编辑器sudo apt-get install vim-full 结果报错E: Unable to locate package 在etc/apt   的sources.list 添加镜像源   deb http://archive.ubuntu.com/ubuntu/ trusty main universe restricted multiverse 然后 sudo apt
用 sudo make install 安装软件包时可以指定路径
sudo make DESTDIR=/usr/... install /uninstall
无法定位软件包libX11-dev
安装qt时,按照教程 需要安装这三个 sudo apt-get install libX11-dev libXext-dev libXtst-dev 提示 E:无法定位软件包 源也没什么问题后来改成sudo apt-get install libx11-dev libxext-dev libxtst-dev 都把x改成小写就可以了,喵喵喵???
无法定位软件包
ubuntu中使用apt-get install 安装软件或库时找不到,可能是版本更新导致软件源的更新,一些旧的软件源就找不到。所以就没办法安装一些旧的软件及库。解决方法:在/etc/apt/source.list中更新软件源,例如添加: deb http://cz.archive.ubuntu.com/ubuntu trusty main universe
moveit 无法定位软件包
出现问题 kinetic下安装 MoveIt可能出现问题,对应输入输出如下: Case 1: 输入 $ sudo apt-get install ros-indigo-moveit-full 输出 sudo apt-get install ros-indigo-moveit-full正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 ...
Ubuntu “无法定位软件包”
Ubuntu “无法定位软件包” 问题描述: 在使用Ubuntu 18.0.4 安装ceres库时安装依赖项时报错,如图所示: 原因分析: libcxsparse3.1.2软件包是Ubuntu 14.0.4对应的软件包,所以在Ubuntu 18.0.4目录下无法定位软件包。 解决方法: 使用下面的网址: https://packages.ubuntu.com/ 注意: 1.搜索时关键字尽量只输...
无法定位软件包python-pip
  刚刚安装好系统时,经常遇到这种情况,先不急着更改服务器,先执行下述命令: sudo apt-get update
关于Ubuntu出现无法定位软件包的问题解决
第一种方法: 在 /etc/apt sources.list 添加镜像源 deb http://archive.ubuntu.com/ubuntu/trusty main universe restricted multiverse  sudo apt-get update ~~~ 第二种方法: 1.在修改source.list前,最好先备份一份 执行备份命令 sudo cp /et...
apt 安装软件出现“无法定位软件包”的问题
安装软件出现“无法定位软件包”的问题: 解决: 1、尝试更新软件列表,若出现“无法读取源列表",则重新配置源文件 2、配置源文件,见图2,配置完成保存。 3、再次更新软件列表,发现更新成功,下面可以再次尝试安装软件即可。 打开文件 /etc/apt/sources.list重新配置源文件,将官方源注释,配置新的源后保存再试一遍。 示例源: # 官方源 # deb-src h...
ubuntu16.04安装mysql出现无法定位到软件包!
**ubuntu16.04安装mysql出现无法定位到软件包!** 在网上搜索很久,试了很多方法,大概是如下:Ubuntu 16.04 安装使用MySQL 但是很遗憾就是出现如下错误: 找了各种解答发现是系统设置有问题: 于是进行更改,步骤如下: (一)、1、点击系统设置 2、找到软件和更新,点击进去 ...
sudo apt-get update问题
我用的是ubuntu10.10的系统,添加的是163的源,源如下:rndeb http://mirrors.163.com/ubuntu/ maverick main universe restricted multiverserndeb-src http://mirrors.163.com/ubuntu/ maverick main universe restricted multiverserndeb http://mirrors.163.com/ubuntu/ maverick-security universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-security universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-updates universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-proposed universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-proposed universe main multiverse restrictedrndeb http://mirrors.163.com/ubuntu/ maverick-backports universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-backports universe main multiverse restrictedrndeb-src http://mirrors.163.com/ubuntu/ maverick-updates universe main multiverse restrictedrn在linux下可以打开上面的网站,但打sudo apt-get update时老是报407的错误,错误如下rnW: Failed to fetch http://mirrors.163.com/ubuntu/dists/maverick-backports/multiverse/binary-amd64/Packages.gz 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy filter is denied. )rn我应该怎么做才能让update可以更新,求高手告知!!!!
sudo apt-get常用命令
下面总结一下有关apt-get的常用但容易混淆的指令: 一、卸载 1. sudo apt-get autoclean: 如果你的硬盘空间不大的话,可以定期运行这个程序,将已经删除了的软件包的.deb安装文件从硬盘中删除掉。如果你仍然需要硬盘空间的话,可以试试apt-get clean,这会把你已安装的软件包的安装包也删除掉,当然多数情况下这些包没什么用了,因此这是个为硬盘腾地方的好办法...
sudo apt-get update 出现 GPG错误
[img=https://img-bbs.csdn.net/upload/201806/09/1528553111_479387.png][/img]rnrn这个错误已经困扰我了一个星期,试了很多方法都没有解决。虚拟机版本是ubuntu18.04rn麻烦知道解决问题的大神提供解决办法,谢谢。
在Ubuntu中使用apt-get的时候,始终显示 E 无法定位软件包
在Ubuntu中使用apt-get的时候,始终显示 E 无法定位软件包
在Ubuntu中使用apt-get的时候,始终显示“E:无法定位软件包”
可能的一个原因是因为安装过后没有更新软件源,试试用 sudo apt-get update 命令更新一下软件源。
sudo apt-get update时遇到以下问题
问题: sudo apt-get update时遇到以下问题 W: 以下 ID 的密钥没有可用的公钥: 1397BC53640DB551 W: GPG 错误:http://archive.ubuntukylin.com:10006 xenial InRelease: 由于没有公钥,无法验证下列签名: NO_PUBKEY 8D5A09DC9B929006 W: 无法下载 http:
当在ubuntu下sudo apt-get update出现报错无法更新时解决办法
sudo gedit /etc/apt/sources.list 将文件中的所有http://cn.archive.ubuntu.com/ubuntu/ 替换成http://mirrors.163.com/ubuntu 或者http://mirrors.souhu.com/ubuntu
Ubuntu10.04 执行sudo apt-get update时无法连接
我的系统是Ubuntu10.04,网络连接正常。在执行sudo apt-get update 时出现出现无法连接的问题:部分截屏如下:rn[img=https://img-bbs.csdn.net/upload/201507/22/1437569988_906540.jpg][/img]rn请各位帮个忙,实在不知道怎么整么了?
相关热词 c# 标准差 计算 c#siki第五季 c#入门推荐书 c# 解码海康数据流 c# xml的遍历循环 c# 取 查看源码没有的 c#解决高并发 委托 c#日期转化为字符串 c# 显示问号 c# 字典对象池