wentao365
2008-11-24 10:49
浏览 368
已采纳

weblogic9.2不支持 jdk1.6.0_03 么?

我 使用 weblogic9.2 config wizard 的时候 没有使用 默认提供的 jdk1.5而是手工指定了 1.6 结果 启动时候报 错 :

[code="java"]
There are 1 nested errors:

weblogic.management.ManagementException: [Management:141266]Parsing Failure in c
onfig.xml: javax.xml.namespace.QName; local class incompatible: stream classdesc
serialVersionUID = 4418622981026545151, local class serialVersionUID = -9120448
754896609940
at weblogic.management.provider.internal.RuntimeAccessImpl.(Runtim
eAccessImpl.java:122)
at weblogic.management.provider.internal.RuntimeAccessService.start(Runt
imeAccessService.java:38)
at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesMan
ager.java:374)
at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServ
icesManager.java:125)
at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:630)
at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:402)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:361)
at weblogic.Server.main(Server.java:67)
Caused by: java.io.InvalidClassException: javax.xml.namespace.QName; local class
incompatible: stream classdesc serialVersionUID = 4418622981026545151, local cl
ass serialVersionUID = -9120448754896609940
at java.io.ObjectStreamClass.initNonProxy(ObjectStreamClass.java:562)
at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:158
3)
at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1496)
at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1
732)
at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
at java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
at java.util.HashMap.readObject(HashMap.java:1029)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
sorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974
)
at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1846)

[/code]

如果我采用 默认的 jdk1.5 就不报错正常 。 难道 jdk6.0下 的项目 不能在 weblogic9.2下跑么?

如果不能,那顺便问下 weblogic 10.3 支持 jdk6.0么 ?
[b]问题补充:[/b]
我想知道的事 weblogic9.2不能 配 jdk6么 ?


另外我发现 我的控制台 居然 有 js 脚本错误 。

如 图3 所示 。

真是难以 接受啊!!!!

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 邀请回答

4条回答 默认 最新

  • iteye_3350 2008-11-25 10:12
    已采纳

    Java SE 6 — WebLogic Server 10.3支持并可使用Java SE 6,它是最新版的Java SE平台。

    点赞 打赏 评论
  • zhengbin917943 2008-11-24 11:16

    weblogic8是支持jdk1.4 ,weblogic9是支持jdk1.5的吧

    点赞 打赏 评论
  • 君临天下11111 2008-11-24 14:17

    weblogic92是支持jdk1.6的
    如果你使用的是myeclipse开发工程的话,请在window--->myeclipse enterprise workbench--->servers--->weblogic-->weblogic9.x--->jdk
    配置weblogic jdkname。这里配置的jdk必须是你在weblogic9.2 config wizard 中配置的jdk。

    点赞 打赏 评论
  • YuLimin 2008-11-25 13:04

    遵守如下版本规定:
    WLS 8.X JDK 1.4.X
    WLS 9.X JDK 1.5.X
    WLS 10.X JDK 1.6.X

    点赞 打赏 评论

相关推荐 更多相似问题