KbGolden
2009-02-25 21:17
浏览 278
已采纳

weblogic10.3、JDK1.4.2能否一起使用?

主机环境: AIX Version 5.3!

JDK:java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
Classic VM (build 1.4.2, J2RE 1.4.2 IBM AIX build ca142-20080515 (SR11) (JIT enabled: jitc))
WEBLOGIC:10.3

使用WebLogic Configuration Wizard 配置domain,配置过程中将 JVM Directory修改为JAVA_HOME/JDK142

启动startWebLogic.sh后报错误如下


  • To start WebLogic Server, use a username and *
  • password assigned to an admin-level user. For *
  • server administration, use the WebLogic Server *
  • console at http://hostname:port/console * *************************************************** starting weblogic with Java version: java version "1.4.2" Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2) Classic VM (build 1.4.2, J2RE 1.4.2 IBM AIX build ca142-20080515 (SR11) (JIT enabled: jitc)) Starting WLS with line: /usr/java14/bin/java -Xms256m -Xmx512m -da -Dplatform.home=/myweb/wlserver_10.3 -Dwls.home=/myweb/wlserver_10.3 rver -Dweblogic.home=/myweb/wlserver_10.3 rver -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/myweb/patch_wls1030/profiles/default/sysext_manifest_classpath:/myweb/patch_cie660/profiles/default/sysext_manifest_classpath -Dweblogic.Name=AdminServer -Djava.security.policy=/myweb/wlserver_10.3 rver b/weblogic.policy weblogic.Server The java class could not be loaded. java.lang.UnsupportedClassVersionError: weblogic rver (Unsupported major.minor version 49.0)

这是JDK版本的问题,但是我在新建domain的时候已经将JDK修改为1.4.2,为什么还报这样的错误,难道是weblogic10必须使用JDK5以上的版本?请了解的兄弟给点建议,谢谢

  • 写回答
  • 好问题 提建议
  • 追加酬金
  • 关注问题
  • 邀请回答

1条回答 默认 最新

相关推荐 更多相似问题