magicStar0_0
悠悠执念
采纳率0%
2019-01-12 09:11

eclipse maven install 报错

[ERROR] Plugin org.apache.maven.plugins:maven-surefire-plugin:2.12.4 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.plugins:maven-surefire-plugin:jar:2.12.4: Could not transfer artifact org.apache.maven.plugins:maven-surefire-plugin:pom:2.12.4 from/to central (https://repo.maven.apache.org/maven2): Cannot access https://repo.maven.apache.org/maven2 with type default using the available connector factories: BasicRepositoryConnectorFactory: Cannot access https://repo.maven.apache.org/maven2 using the registered transporter factories: WagonTransporterFactory: java.util.NoSuchElementException
[ERROR] role: org.apache.maven.wagon.Wagon
[ERROR] roleHint: https
[ERROR] -> [Help 1]

  • 点赞
  • 写回答
  • 关注问题
  • 收藏
  • 复制链接分享
  • 邀请回答

2条回答

  • kpoikpok 风格的时光机 2年前

    我感觉可能是网络问题导致相关的jar包下载不下来吧,在maven的配置文件settings.xml(maven安装路径的conf文件夹下)里面把镜像换成国内阿里云的再试试。

    点赞 评论 复制链接分享
  • u012114626 gann2010 2年前

    重装过eclipse了没有,会不会参数设置问题

    点赞 评论 复制链接分享

相关推荐